Jump to content


Photo

Shellshock on ARM


  • Please log in to reply
No replies to this topic

#1 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,988 posts
  • Gender:Male

Posted 29 September 2014 - 01:14 PM

For the snom ONE minis, we have a problem updating the bash. It seems that there is no new version available yet. Anyhow, for those who want to give it a try here is what I have tried:

 

env x='() { :;}; echo vulnerable' bash -c 'echo hello'
apt-get update
gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553
gpg -a --export 6FB2A1C265FFB764 | sudo apt-key add -
gpg --keyserver pgpkeys.mit.edu --recv-key 6FB2A1C265FFB764
gpg -a --export 8B48AD6246925553 | sudo apt-key add -
apt-get update
apt-get install --only-upgrade bash
 

The update gave me an error because obviously some servers have been moved or added. That is why I added those keys to the apt-key list. Then the update actually did realize there is a new bash, and the new bash installation did something. However it seems that the upgrade did not fix the problem yet  :( .






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users