Jump to content
Vodia PBX forum
fonny

Forward calls to cellphone during work-hours

Recommended Posts

Situation: incoming calls go to reception desk, overflow to 3 other employees, after 30s also overflow to 3th employee.

When all users are out of office during work-hour, possibility to redirect all incoming calls to mobile from one of the employees.
Solution:
Defined Agent group (90)
Logged in Agents: 201 211 204 206
Agent selection: preference from the agent settings
All agents for this ACD: 201 211 204 206
Ring stage: 5s
Number of agents added per stage: 1
Caller in queue after hearing ringback for 30s: 203
For all extensions
Redirection Cellphone number is filled in.
Call cell phone: Immediately
When calling the extension in an agent group: Include cell phone
For hunt & callback groups: don't call cell phone
Everything works as expected:
Incoming call is routed to ACD 90
Ringing on 201, after 5s on 211, ... after 30s on 203. No cellphones are called.
Entering Star Code *8090 (set night mode for domain account ACD 90) and 201# will redirect all incoming calls to cell phone of extension 201, entering 204# will redirect all incoming calls to cell phone of extension 204, ... works as expected.
But when user put extension 201 in DND mode, incoming calls don't go thru. The other agents are not called. This doesn't seem to be normal behaviour.
I would expect extensions 211, 204, 206 and 203 be called.
In the log I also get error for No Outbound Dialplan defined for ACD 90.
In the settings Dialplan is set a domain default.
-> when I look in the domain settings, I don't see a Dialplan option!
When I select the Standard Dialplan, and extension 201 has DND active, cellphone of extension 201 is called, after 5s cellphone of extension 211, ...
This doesn't seem to be normal behaviour either. I can understand it is normal behaviour when a dialplan and call cellphone immediately are selected but I expect the extensions also to ring.
pbx is Raspberry v56
Or is there a better solution to solve this setup?

Share this post


Link to post
Share on other sites

Hi,

 

I suppose we deduced your issue.

 

You must have been turning ON the DND on the device (SIP phone) itself. Please :-

1) Delete that setting from the Phone.

2) Turn on the DND on the PBX server for the Extension (201 in your case). You can simply dial the star code *78 on the phone and press send.

3) Try running the scenario again.

4) If you turn OFF the DND (by using the star code *79 on the ext 201) ON-THE-FLY the ext 201 rings again (after the ringing ext has stopped).

 

Hope it works for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×