Jump to content
Vodia PBX forum
koolandrew

Dial plan--removing non numeric characters

Recommended Posts

Hi, i have found that customers who are using softphones on their cell phones have issues with dialling through the pbx.

 

For example if the number is stored in their phone book, in any of the ways below, i cannot determine how to ignore or remove the non-numeric characters:

 

1(555)555-1212

or

555-555-1212

or

(555) 555 1212

 

If there are any type of bracket that they might have used in their phone book, i cannot figure out how to create a rule in the dial plan that ignores those characters.

 

Please help.

Share this post


Link to post
Share on other sites

This is not a dial plan issue. The question is how to interpret the SIP packets, especially the request-URI coming from the soft phone. Do they contain those funny characters? Technically they are fine, and it is actually the job of the "user-agent" to take care about such things.

 

But it might make sense to add a flag or something saying this user, domain or system only process phone numbers and everything else should be taken out.

Share this post


Link to post
Share on other sites

thanks for the reply.

 

I agree about the agent, but i would rather take care of it on the pbx or domain level.

 

I have no idea to implement your last line, could you please provide an example of such.I would like to leave the + alone though, as it is properly handled at the moment, just the other situations with ( ) and -.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I guess the Admin was referring to adding that to the next version of the PBX. As of now, just making sure your customers can enter numbers as suggested by you shall be the best case scenario.

Share this post


Link to post
Share on other sites

I am very surprised that this cannot be resolved. The last response is no help. So i would send out an email, hey customers please remove () and - from your phone numbers in your phone book. Even though it has been working in your phone, it will no longer work when using your pbx........................come on.................

Share this post


Link to post
Share on other sites

The thing is if we add that to the PBX itself, we should make it a settings at least on system level. Who knows, maybe there are people who want to dial spaces and brackets. But I think as a default the characters space, dash, brackets and dot should be removed. We'll put that into the next build.

Share this post


Link to post
Share on other sites

People do it out of habit, or they copied and pasted, and it is certainly easier to read than all numbers. However, these all do need to removed, as you already remove spaces by default...

 

You need to leave the + alone, as removing it will work when it is +15555551212 but doesnt work if is +442075551212, as i dont believe there is a standard to the amount of digits that follow a country code, and now we have 3 digit country codes, so that is best left to handled in the dial plan.

 

Either way, it works when calling from their phone using the native phone dialler but wont work when using a sip dilaller if they are calling from their phone book.

 

thx

Share this post


Link to post
Share on other sites

Latest 57.4 versions have this already with a reasonable default (hopefully) settings for ignoring characters.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×