Jump to content
Vodia PBX forum
almoondsllc

Snom D315 IO provisioning not working

Recommended Posts

Hello,

I just installed the last version of Vodia and I'm trying to do provisioning with a Snom D315 in the LAN but is not working, vodia logs reports:

Web Server: File snomD315/snomD315-firmware.htm not found

And then nothing else.

Phone is this:

https://www.snom.com/ip-phones/desk-phones/d3xx-series/snom-315-desk-telephone/

with firmware version:     snomD315-SIP 8.9.3.46

Vodia PBX version: 60.0.1 (Debian64)

I checked almost everything but it doesn't work, what can I check? Thank you for any tips.

 

Regards,

Alessandro Marzini

Share this post


Link to post
Share on other sites

Yes the server is on the LAN as well and this is what I see:

image.thumb.png.e2923b2a9391b94b815a2b4b2d36f90a.png

But when I reboot the phone, in the phone I found only this (192.168.178.113 is the pbx address):

 

image.png.7d318dde5d29a81ee5c89fe90fbdf3cb.png

 

and in the log I've this:

 

image.png.fcf24474f0420c5d757853783f1f8411.png

Share this post


Link to post
Share on other sites

Hi,

 

Looks like it worked on our 60.0 over here.

Here are the admin level logs:

[5] 16:08:30.889 PROV: Identified prov/snom300.htm by pattern snom???.htm
[9] 16:08:30.889 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.889 PROV: HTTP: Received request for file snom300.htm from 192.168.123.26
[8] 16:08:30.890 PROV: PnP: Extracted MAC for file snom300.htm
[9] 16:08:30.890 PROV: Filter configuration file snom_redirect.xml
auth: false
body: 
content-type: text/xml
filename: snom300.htm
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 
macauth: false
match: 300
resource: /snom300.htm
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[7] 16:08:30.890 PROV: File snom_redirect.xml was rendered without a user
[8] 16:08:30.891 PROV: HTTP: file snom300.htm based on template snom_redirect.xml is sent to 192.168.123.26
[9] 16:08:30.967 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.967 PROV: HTTP: Received request for file snom300-000413280753.htm from 192.168.123.26
[8] 16:08:30.968 PROV: PnP: Extracted MAC 000413280753 for file snom300-000413280753.htm
[8] 16:08:30.968 PROV: Provisioning file snom300-000413280753.htm looking for MAC 000413280753
[8] 16:08:30.970 PROV: PnP: Using the credentials of 448@vodia for file snom_300.xml
[9] 16:08:30.971 PROV: Filter configuration file snom_300.xml
auth: true
body: 
content-type: text/xml
filename: snom300-000413280753.htm
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 000413280753
macauth: false
match: 0
model: 300
resource: /prov/snom300-000413280753.htm
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.974 PROV: HTTP: file snom300-000413280753.htm based on template snom_300.xml is sent to 192.168.123.26
[9] 16:08:31.065 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:31.065 PROV: HTTP: Received request for file snom_cert-000413280753.xml from 192.168.123.26
[8] 16:08:31.065 PROV: PnP: Extracted MAC for file snom_cert-000413280753.xml
[9] 16:08:31.066 PROV: Filter configuration file snom_cert.xml
auth: false
body: 
content-type: text/xml
filename: snom_cert-000413280753.xml
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 
macauth: false
match: 
resource: /prov/snom_cert-000413280753.xml
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[7] 16:08:31.066 PROV: File snom_cert.xml was rendered without a user
[8] 16:08:31.067 PROV: HTTP: file snom_cert-000413280753.xml based on template snom_cert.xml is sent to 192.168.123.26

 

 

And this is the setting  from the web GUI of the phone. 

 

Maybe you can switch the firmware on the phone and try it again?

Flash the phone, switch the PBX into the incognito mode, reboot the phone and then it should show up in the LAN devices.

2.png

Share this post


Link to post
Share on other sites

Hi,

 

Well, we don't have that exact model in the lab as it's not used much so we tested on the closest one. Which would you like us to test it on, closest to that one?

Share this post


Link to post
Share on other sites

Yes I would like if you can test the snomD315 model, can you "simulate" that model in some way? Or how I cab debug the problem? Anyway I'll make other tests, maybe the problem is because I'm using vodiapbx in a kvm machine (but I'm using bridge functionality so everything should be fine).

Share this post


Link to post
Share on other sites

Maybe the pattern was just missing in the pnp_snom file. You can try to edit the pnp_snom.xml file in the templates web page, like this (notice the snomD31?):

  <file name="snom_300.xml" encoding="xml">
    <pattern mac="8">snom30?-############.htm</pattern>
    <pattern mac="9">snomD30?-############.htm</pattern>
    <pattern mac="9">snomD31?-############.htm</pattern>
    <prefix>true</prefix>
    <vendor>snom</vendor>
    <anonymous>true</anonymous>
    <protocol>tftp,http,https</protocol>
  </file>

We will include this in the next build, so please after updating just revert the file then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×