Jump to content
Vodia PBX forum

Recommended Posts

issues i had so far with the upgrade:

 

1. got random 404 on outgoing calls. needed to recreate my dial plans

2. some trunks got deleted with the upgrade to the 4.x version

 

i expected this to be a bigger pain so rest went very smooth.

 

 

EDIT:

3. now i got a big one. after a reboot i got a message: wrong mac address.

no trunk would register anymore.

tried to reapply my license key. got permanent license, valid license but trunks just did not register.

tried to re-register tunks. no change.

rebooted a couple times - no change.

got a demo license and used that one - worked.

put back my license - works again

 

4. having problems to cancel/abort calls through the web interface - safari

this works now. this might have happened with the pbx being screwed up with the license.

 

5. from time to time web interface gets very slow loading pages.

 

 

6. dial plan acting wired. i am calling the same number form the same extension twice. one call gets a 404.

redialing the number a minute later works.

 

____

SIP/2.0 100 Trying

Via: SIP/2.0/TLS 10.0.24.20:4146;branch=z9hG4bK-s7t3896aa083;rport=55476;received=208.82.12.34

From: "Christof Haemmerle" <sip:33@nex9.com>;tag=11tn82kymy

To: <sip:011436767775555@nex9.com;user=phone>;tag=042278ed84

Call-ID: 5c9d263cc39e-vs1cwpy69kb0

CSeq: 1 INVITE

Content-Length: 0

 

 

[7] 20100605172800: Set packet length to 20

[6] 20100605172800: Sending RTP for 5c9d263cc39e-vs1cwpy69kb0#042278ed84 to 10.0.24.20:62036

[8] 20100605172800: Call from an user 33

[8] 20100605172800: To is <sip:011436767775555@nex9.com;user=phone>, user 0, domain 2

[8] 20100605172800: From user 33

[8] 20100605172800: Set the To domain based on From user 33@nex9.com

[8] 20100605172800: Call state for call object 16: idle

[9] 20100605172800: Dialplan: Evaluating !^(311)@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605172800: Dialplan: Evaluating !^(\+?[0-9]*)@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[8] 20100605172800: Dialplan "Standard User": 011436767775555@nex9.com not found in the local system for the Try Loopback

[9] 20100605172800: Dialplan: Evaluating !^([0-9]{7})@.*!sip:212\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605172800: Dialplan: Evaluating !^([0-9]{10})@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605172800: Dialplan: Evaluating !^(1[0-9]{10})@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605172800: Dialplan: Evaluating !^011([0-9]*)@.*!sip:011\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605172800: SIP Rx tls:208.82.12.34:34997:

 

 

 

SIP/2.0 404 Not Found

Via: SIP/2.0/TLS 10.0.24.20:4146;branch=z9hG4bK-s7t3896aa083;rport=55476;received=208.82.12.34

From: "Christof Haemmerle" <sip:33@nex9.com>;tag=11tn82kymy

To: <sip:011436767775555@nex9.com;user=phone>;tag=042278ed84

Call-ID: 5c9d263cc39e-vs1cwpy69kb0

CSeq: 1 INVITE

Contact: <sip:33@222.222.222.222:5061;transport=tls>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: pbxnsip-PBX/4.0.1.3499

Content-Length: 0

 

 

 

2nd call i get a match and it just works.

 

[7] 20100605173239: Set packet length to 20

[6] 20100605173239: Sending RTP for 739e263cb41f-k1qjulvgl27x#edf7976c7c to 10.0.24.20:62134

[8] 20100605173239: Call from an user 33

[8] 20100605173239: To is <sip:011436767775555@nex9.com;user=phone>, user 0, domain 2

[8] 20100605173239: From user 33

[8] 20100605173239: Set the To domain based on From user 33@nex9.com

[8] 20100605173239: Call state for call object 18: idle

[9] 20100605173239: Dialplan: Evaluating !^(311)@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605173239: Dialplan: Evaluating !^(\+?[0-9]*)@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[8] 20100605173239: Dialplan "Standard User": 011436767775555@nex9.com not found in the local system for the Try Loopback

[9] 20100605173239: Dialplan: Evaluating !^([0-9]{7})@.*!sip:212\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605173239: Dialplan: Evaluating !^([0-9]{10})@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605173239: Dialplan: Evaluating !^(1[0-9]{10})@.*!sip:\1@\r;user=phone!i against 011436767775555@nex9.com

[9] 20100605173239: Dialplan: Evaluating !^011([0-9]*)@.*!sip:011\1@\r;user=phone!i against 011436767775555@nex9.com

[5] 20100605173239: Dialplan "Standard User": Match 011436767775555@nex9.com to <sip:011436767775555@gw01-car.dal.us.icall.net;user=phone> on trunk icall-international-reg

[9] 20100605173239: UDP: Opening socket on 0.0.0.0:56104

[9] 20100605173239: UDP: Opening socket on 0.0.0.0:56105

[9] 20100605173239: UDP: Opening socket on [::]:56104

[9] 20100605173239: UDP: Opening socket on [::]:56105

[1] 20100605173239: UDP: TOS could not be set

[8] 20100605173239: Play audio_moh/noise.wav

[1] 20100605173239: UDP: TOS could not be set

[9] 20100605173239: Resolve 7125: url sip:gw01-car.dal.us.icall.net

[9] 20100605173239: Resolve 7125: naptr gw01-car.dal.us.icall.net

[9] 20100605173239: Resolve 7125: srv tls _sips._tcp.gw01-car.dal.us.icall.net

[9] 20100605173239: Resolve 7125: srv tcp _sip._tcp.gw01-car.dal.us.icall.net

[9] 20100605173239: Resolve 7125: srv udp _sip._udp.gw01-car.dal.us.icall.net

[9] 20100605173239: Resolve 7125: aaaa udp gw01-car.dal.us.icall.net 5060

[9] 20100605173239: Resolve 7125: a udp gw01-car.dal.us.icall.net 5060

[9] 20100605173239: Resolve 7125: udp 72.249.14.242 5060

[9] 20100605173239: SIP Tx udp:72.249.14.242:5060:

 

____

 

this is my dialplan:

 

97;verizon;;311;

100;*;;*;

251;icall-domestic-reg;;xxxxxxx;212*

252;icall-domestic-reg;;xxxxxxxxxx;*

253;icall-domestic-reg;;1xxxxxxxxxx;*

255;icall-international-reg;;011*;011*

 

 

 

 

 

reco

Share this post


Link to post
Share on other sites

7. auto provisioning of custom files does not work.

 

i do have a file `pbxdir/html/tftp/snom_870_custom.xml`

 

my phone requestrs: http://pbx.com/provisioning/snom870.htm

inside this file the custom settings url is: https://222.222.222.222:443/tftp/snom_870_custom.xml which retuns a 404 not found.

using a domain instead of the ip works though: https://pbx.com/tftp/snom_870_custom.xml

 

this must be a bug.

Share this post


Link to post
Share on other sites
7. auto provisioning of custom files does not work.

 

i do have a file `pbxdir/html/tftp/snom_870_custom.xml`

 

my phone requestrs: http://pbx.com/provisioning/snom870.htm

inside this file the custom settings url is: https://222.222.222.222:443/tftp/snom_870_custom.xml which retuns a 404 not found.

using a domain instead of the ip works though: https://pbx.com/tftp/snom_870_custom.xml

 

this must be a bug.

 

 

Hi reco,

 

I don't think the tftp directory is supose to be off of the html directory....I have mine as pbxdir/tftp/snom_870_custom.xml and my custom files work.

Share this post


Link to post
Share on other sites

hi there,

 

i see that there is a newer build out (pbxctrl-darwin9.0-4.1.0.4012)

 

where can i get the darwin version?

 

x

Share this post


Link to post
Share on other sites
hi there,

 

i see that there is a newer build out (pbxctrl-darwin9.0-4.1.0.4012)

 

where can i get the darwin version?

 

x

 

We will get you one soon (maybe tomorrow)

Share this post


Link to post
Share on other sites
hi there,

 

i am installing a new system this weekend. where can i get the 4.1 darwin version?

 

thanx

 

We have not built a 4.1 version for Darwin yet.

Share this post


Link to post
Share on other sites

×