Jump to content
Vodia PBX forum

Recommended Posts

OK, but it's impossible this way to access to the admin parameters on the phone.

 

Admin as the same rights with a simple user. How to obtain as in the 4.2.0.3981 the same right level ?

 

How do you to reprovision a phone by the web interface or change some admin parameters in it ?

 

I downgraded the version to the 4.5.0.1050, reprovisionned the phone but the problem is still the same.

 

Have you got any solution to access the admin interface of the phone ?

 

Thanks,

Share this post


Link to post
Share on other sites

But it would be very easy to provision the parameters that you want into the phone--avoiding the need to log into the phone at all! Just set the parameters that you want to set on the PBX, and reboot the phone. That might be easier than trying to solve the riddle with the password.

 

 

BTW this has one positive and wanted side effect: End users cannot screw the phone config up and then call you for help.

Share this post


Link to post
Share on other sites

Admin as the same rights with a simple user. How to obtain as in the 4.2.0.3981 the same right level ?

 

If you open the snom_3xx_phone.xml and snom_820_phone.xml have the below setting (almost at the end)

<admin_mode perm="">off</admin_mode>

 

Either you can delete that line or you can change off to on

 

The First Method under http://wiki.snomone.com/index.php?title=Modifying_Plug_and_Play_Files explains some generic details.

Share this post


Link to post
Share on other sites

Hello everyone,

 

I've juste tried the solution of pbx support by changing the line :

<admin_mode perm="">off</admin_mode>

 

by :

 

<admin_mode perm="">on</admin_mode>

 

on the file snom_820_phone.xml.

 

After some searchs, this template is also used for snom821, snom760, snom720.

 

I rebooted my phone and the admin access is granted !

 

Thanks for the help. I learned something new today.

Share this post


Link to post
Share on other sites

Found a few strange occurrences when using the Snom 820 (8.7.3.7) with the SnomOne Windows (Delta Aurigids (4.5.0.1075).

 

When pressing the Menu button on the 820 and selecting 'Set Cell Phone Inclusion' the 'Don't call cell phone' option has no effect. All the other options - Immediately, 1 second to 30 seconds work fine.

 

I logged this bug back in November 2010 against v4.2.0.3950

Seems snom are not interested in fixing this. It's a joke for users that they cannot turn this feature off once it is enabled.

 

How many users do you have, it might be you can leverage some more support for this bug?

Share this post


Link to post
Share on other sites

I logged this bug back in November 2010 against v4.2.0.3950

Seems snom are not interested in fixing this. It's a joke for users that they cannot turn this feature off once it is enabled.

 

How many users do you have, it might be you can leverage some more support for this bug?

 

I actually resolved the issue by editing the xml file snom/cell_include.xml (Go to Web page Control - phone pnp). I can't remember exactly what the problem was, but it was something like value="" should have been value= in the syntax .

 

Find the the line <Name>{lng cell_time_0}</Name> and I think the next line needed to be changed to be as follows:

 

 

<URL>{ssi link snom/menu.xml &name=cell_time&value=}</URL>

 

 

Hope that helps.

Share this post


Link to post
Share on other sites

×