Jump to content
Vodia PBX forum
reco

soap stopped working

Recommended Posts

hi there,

 

seems snom one stopped reporting the call records to our external billing service.

i did a `tcpdump 'tcp port 80'` and could not find anything.

i am running: 4.5.0.1090 Epsilon Geminids (MacOS)

the log shows the the soap message.

 

 

[9] 20120815134144: SOAP: Store CDR in http://server.com/pbxhandler

<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/" xmlns:sns="http://soap.com/pbx"><env:Body><sns:CDR><PrimaryCallID>44df2b506b78-n3cmwojfjm9c</PrimaryCallID><CallID>44df2b506b78-n3cmwojfjm9c</CallID><From>"Name Name" <sip:33@domain.com></From><To>Name Name <sip:+12223334444@domain.com;user=phone></To><Direction>I</Direction><Type>extcall</Type><RemoteParty></RemoteParty><LocalParty>33</LocalParty><TrunkName></TrunkName><TrunkID></TrunkID><Domain>domain.com</Domain><LocalTime>20120815134125</LocalTime><TimeStart>20120815174125</TimeStart><RingDuration>15</RingDuration><Extension>33@domain.com</Extension><TimeConnected>20120815174139</TimeConnected><DurationHHMMSS>0:00:05</DurationHHMMSS><Duration>5</Duration><TimeEnd>20120815174144</TimeEnd><IPAdr>tls:x.x.x.x:37191</IPAdr><Quality>VQSessionReport: CallTerm

LocalMetrics:

Timestamps:START=2012-08-15T17:41:39Z STOP=2012-08-15T17:41:44Z

CallID:44df2b506b78-n3cmwojfjm9c

FromID:"Name Name" <sip:33@domain.com>;tag=4t5vatwuk1

ToID:<sip:2223334444@domain.com;user=phone>;tag=bd8ba734ac

SessionDesc:PT=9 PD=g722 SR=8000 FD=20 FO=160 FPP=1 PPS=50 PLC=3

LocalAddr:IP=98.113.181.115 PORT=61468 SSRC=0x01316bb1

RemoteAddr:IP=x.x.x.x PORT=32896 SSRC=0xdfa6c145

x-UserAgent:snomONE/4.5.0.1090 Epsilon Geminids

x-SIPterm:SDC=OK SDD=126 SDR=OR

PacketLoss:NLR=99.2 JDR=0.0

BurstGapLoss:BLD=100.0 BD=152 GLD=0.0 GD=7385 GMIN=16

Delay:RTD=0 ESD=0 IAJ=977

QualityEst:MOSLQ=4.2 MOSCQ=1.0

</Quality></sns:CDR></env:Body></env:Envelope>

 

any idea?

Share this post


Link to post
Share on other sites

PBX generally connects to the remote server and if the connection is successful, then it will send the CDR. So, make sure the remote server is accepting the connections from the PBX.

Share this post


Link to post
Share on other sites

thank you for your answer, but i could not even see pbxnsip trying to connect to the server in my tcpdump.

this used to work till mid june 2012...

 

i have a hosted license. can this be disabled by the license?

 

 

 

christof

Share this post


Link to post
Share on other sites

i there,

 

i checked the last entries in our billing system.

it stopped working right after i entered the new key.

 

i send you my key in a private message.

can you look into this?

Share this post


Link to post
Share on other sites

yes i did try to restart the whole service.

 

the wired think really is that i don't see anything in the tcp dump.

 

thanx

Share this post


Link to post
Share on other sites

hi there,

 

not possible, i am posting to an google app engine app hosted on appspot.com.

 

these are the tcp dump command i used:

 

tcpdump -i lo0 'tcp port 80'

tcpdump -i vlan3 'tcp port 80'

 

is there a way to get support for this issue?

 

christof

Share this post


Link to post
Share on other sites

is there away to make it use port 80?

 

i want to post call records to a web app listening on port 80.

 

i tried: http://server.com:80/pbxhandler

 

not working either...

Share this post


Link to post
Share on other sites

Of course you can specify the server port. My answer was related to the sniffing; sniffing on the loopback interface can be a problem; maybe for the sake of testing, just specify an external server to see if you can grab the traffic.

Share this post


Link to post
Share on other sites

i upgraded my server to version 5 to test.

the soap call started to work again.

 

back to 4.5 stopped working.

trust me this is an issue with 4.5.0.1090 Epsilon Geminids (MacOS)

can you please check?

Share this post


Link to post
Share on other sites

in can verify that soap works with pbxctrl-darwin9.0-4.5.0.1075 and stops working with pbxctrl-darwin9.0-4.5.0.1090

 

is there a way to fix this in a new 4.5 release?

 

x

Share this post


Link to post
Share on other sites

Looks like the problem is that your destination advertises both IPv4 and IPv6 addresses. In 4.5, the PBX prefers IPv6. If your server has no IPv6 connectivity, that will fail.

 

Solutions:

  • Get IPv6 working
  • Change the DNS so that you advertise only IPv4
  • Use the IP address
  • Start the service with the argument --ipv6 false (e.g. pbxctrl --dir /pbx/dir --ipv6 false)
  • Upgrade to version 5, where IPv4 is being preferred against IPv6

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×