Jump to content
Vodia PBX forum
andrewgroup

Cell Phone calls drop on Windstream Nuvox Sonus Sip Trunks

Recommended Posts

FYI.

 

 

We have numerous clients using windstream (Formerly Nuvox) SIP trunks provided off of a T1 using a Cisco 2431 IAD. Windstream provides a Client Internet IP address on Wic1 and a seperate single IP in WIC2 for the SIP trunk...

 

A problem began within the past day where calls to or from some cell phones would drop in 15 to 30 seconds. The problems was traced to a setting in the SIP trunk settings in the Sonus Server related to what they call a service Profile.

 

The preferred service profile they call "Nuvox Sip-SipT-Noss" and this accommodates more codecs and keep alive settings for the cell carriers. For some reason this clients service profile was set to "Nuvox Transcode"

 

The following are the settings we are using across the board for all SnomOne installations where Windstream - Nuvox using the Sonus switches are the carriers

 

 

RTP Media - udp range 16384 32767

udp range 49152 53247

Signal Protocol - udp 5060

tcp 5060

udp range 1718 1720

tcp range 1718 1720

udp 2427

tcp 2427

udp 2000

tcp 2000

 

Trunk Settings:

Type: SIP Gateway

Dest: Generic SIP server

Domain: Public IP of PBX

Proxy Address: 74.223.147.173

Codec: G.711U G729A

Settings To Yes or Enabled: Lock Codec During Conversation, Interpret SIP URI as Phone Number

Remote Party: Remote-Party-ID

For DIDs use Send Call to Extension: !(.*)!\1!t!

 

Wind Steam uses SONUS soft switches and they have a known issue. (SEE BELOW)

 

http://wiki.snomone.com/index.php?title=RTCP-XR

In order to disable these settings you must log onto the SIP PBX using the IP address and then move to the ADMIN settings page and paste, (1 by 1) the following URLs into the web.

After each paste the page will switch to a status page, and you should go back to the settings page and do each of the remaining in the same way. These changes do not require a reboot, and take immediate effect.

http://pbx-ip:8080/reg_status.htm?save=save&rtcp_loss_rle=false

http://pbx-ip:8080/reg_status.htm?save=save&rtcp_dup_rle=false

http://pbx-ip:8080/reg_status.htm?save=save&rtcp_rcpt_times=false

http://pbx-ip:8080/reg_status.htm?save=save&rtcp_rcvr_rtt=false

http://pbx-ip:8080/reg_status.htm?save=save&rtcp_voip_metrics=false

Share this post


Link to post
Share on other sites

So after disabling the RTCP-XR does it work now?

 

It is very tricky to find that RTCP-XR problem, I remember it also took us days the first time to realize that equipment that does not do it would actually not just ignore it.

Share this post


Link to post
Share on other sites

Yes, these problems arose last November after windstream - Nuvox did a software upgrade on one of their Sonus Softswitches. We quickly identified the issue after pressing them to tell us the differences between the .173 Switch and another that was on another client with no problems. We learned they had done a software upgrade, and a SIP trace they identified the problem that we were sending the call quality stuff to them that was causing the Sonus to reject the calls... We've had no problems since and make these our default settings..

 

 

 

So after disabling the RTCP-XR does it work now?

 

It is very tricky to find that RTCP-XR problem, I remember it also took us days the first time to realize that equipment that does not do it would actually not just ignore it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×