Jump to content
Vodia PBX forum
sudo

Cell calling out of pbx show cell CID, not extension's

Recommended Posts

When I call into the system (AA) with an associated Cell number I get the special prompt to place an outbound call, check voicemail etc.

 

When I place an outbound call it displays the number of the cell phone and not the ANI set in the extensions general settings.

 

Obviously, we want it to display the business number associated with the pbx and not personal cell phone number.

 

Ive looked around the domain and extensions settings and do not see where to modify this.

 

Any advice?

 

Sudo

Share this post


Link to post
Share on other sites

That is caused by the trunk header settings. You can put something like {ext-ani} into the from field and that should solve your problem at hand... However it would have negative side effects for calls were you do want to see the original caller-ID (regular twinning).

 

What is necessary is that the PBX erases the current From-header before sending the call out and set it to the From-header that would be used when calling from the extension. We will fix that in the next build.

Share this post


Link to post
Share on other sites

We are still having this same issue on version 5.4 if I call my DID press 1 to call out. The call goes out but the remote party receives my cell number with the companies calling name?

Share this post


Link to post
Share on other sites

There is a setting in the domain which controls the "DISA" (that is the name of the feature) flag. Check "Use extension ANI for DISA" in the domain settings.

Share this post


Link to post
Share on other sites

To get to the bottom of the problem you must look at the INVITE packet which is sent to your SIP trunk provider. Unfortunately it seems that every one reads the standard a different way. You might have to consult the providers documentation on how they want it and even if they support it at all. If the provider is on our drop-down list, it would be great to know if we can improve anything on the header side to make the experience for other users smoother.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×