Jump to content
Vodia PBX forum
HighCtenor

Deutsche Telekom

Recommended Posts

Hi

 

The Deutsche Telekom has offered us an upgrade to a VDSL IP-Based Anschluss. That means I have to change to a Sip Gateway or Registration. I have previously used ISDN but that has been turned off.

 

Does anyone have a template of how the Truck is set up for the Deutsche Telekom in Germany? It would help to have an example as a template for making the proper adjustments to the details.

 

 

Share this post


Link to post
Share on other sites

Does the Telekom offer SIP trunking now?! We have a couple in Germany in the drop down, but Deutsche Telekom is missing so far however we would love to add them.

Share this post


Link to post
Share on other sites

Here is the info from their help. It refers to the Router but not to the entries we need to make. When I asked about the registration I was told to not use a password but to use

tel.t-onlne.de for the domain and proxy and to use anonymous@t-online.de as the username. Below you will find the router entries:

 

2/25/2015 Welche Einstellungen sind für die IP­Telefonie mit anderen Clients nötig?
Welche Einstellungen sind für die IP­Telefonie mit anderen Clients nötig?
Die folgenden Einstellungen benötigen Sie, wenn Sie einen SIP­fähigen Software­Client oder Ihr Handy oder
den Router eines anderen Anbieters für die Internettelefonie nutzen möchten. Mit den Routern der Telekom, die für
den IP­basierten Anschluss optimiert sind, benötigen Sie diese Einstellungen nicht.
Wir bieten Ihnen dazu zwar keine detaillierten Konfigurationsanleitungen, da es eine sehr große Anzahl an Angeboten
für die Software­Clients und Hardware­Clients gibt. Dafür erhalten Sie in der folgenden Übersicht aber alle erforderlichen
Angaben, um jeden üblichen Client einzurichten.
Allgemeine Einstellungen:
SIP­ID/Benutzer: Ihre Telefonnummer
Bildschirmname (falls vorhanden): Ihre Telefonnummer
Authentifizierungsname / Benutzername: Ihre E­Mail­Adresse, z. B. ihr­name@t­online.de
Passwort: Ihr Passwort
SIP­Proxy: tel.t­online.de
Registrar: tel.t­online.de
Realm: tel.t­online.de
STUN­Server: stun.t­online.de
Outbound­Proxy: leer lassen oder ebenfalls tel.t­online.de
Bei Einsatz einer Firewall oder eines Routers sind für die IP­Telefonie folgende Portfreischaltungen erforderlich:
UDP (out): Ports 5060, 30000­31000, 40000­41000, 3478, 3479
UDP (in): Ports 5070, 5080, 30000­31000, 40000­41000
TCP (out): Port 80, 443
Hinweise:
Geben Sie die SIP­ID ohne Leerzeichen und Sonderzeichen ein (entspricht Vorwahl und Rufnummer)
Die Eingabe der SIP­ID und des Bildschirmnamens müssen übereinstimmen.
Den Benutzernamen bitte vollständig klein schreiben.
Haben Sie Ihr Passwort vergessen? In diesem Fall halten wir für Sie die Anleitung für
denWiederherstellungsprozess bereit.
Falls Sie E­Mail­Adresse und Passwort noch nicht vergeben haben, können Sie diese im Kundencentereinrichten.

Share this post


Link to post
Share on other sites

Looks straightforward, but with large providers you never know... It would be awesome if you can share your login data with us (private message, change the password after done) so that we can work out the details.

Share this post


Link to post
Share on other sites

Certainly glad to supply it to you. I will supply what I have been told and what I know. If you can help me to fill in the blanks that should let me get it to work today. How shall I send the info to you privately? Please advise

Share this post


Link to post
Share on other sites

It seems that the server does not respond to packets coming from the US. Maybe they accept only packets coming from the Deutsche Telekom network.

Share this post


Link to post
Share on other sites

How would the rejection of packets coming from America affect my ability to use the Vodia here in Germany? What can I do...I need to get the system operational today.

 

-

Share this post


Link to post
Share on other sites

Well we ordered a IP connection ourself, however it will take a week before it is available at least. It seems that whole Germany will get that trunk very soon, so yes we do have an interest to make it easy to set it up.

Share this post


Link to post
Share on other sites

It took a while, but now we have the new VDSL connection (with own IPv6 address :-)) I guess in the next couple of days we can give it a try.

Share this post


Link to post
Share on other sites

OK, this is my trunk setting for several years, but in the last few months I have a lot of "403" before I can make a call:

# Trunk 4 in domain snomone.lan.home
Name: 03012345678
Type: register
RegPass: PASSWORD
Direction: 
Disabled: false
Global: false
Display: 03012345678
RegAccount: 03012345678
RegRegistrar: tel.t-online.de
WrtcDestName: 
WrtcDestNumber: 
RegKeep: 30
RegUser: USERNAME@t-online.de
Icid: 
Require: 
OutboundProxy: tel.t-online.de
Ani: 03012345678@tel.t-online.de
DialExtension: 72
Trusted: false
AcceptRedirect: false
RfcRtp: false
BehindNat: false
RtcpXr: false
Analog: false
RtpBegin: 
RtpEnd: 
Prack: true
SendEmail: 
UseUuid: false
Ring180: false
Failover: never
HeaderRequestUri: {request-uri}
HeaderFrom: {trunk-ani}
HeaderTo: {request-uri}
HeaderPai: 
HeaderPpi: 
HeaderRpi: 
HeaderPrivacy: 12345678
HeaderRpiCharging: icid-value={icid-value};icid-generated-at={ip-address};orig-ioi={domain}
BlockCidPrefix: 
Glob: 
RequestTimeout: 
Codecs: 
CodecLock: true
Pcap: false
DtmfMode: 
Expires: 3600
Fraction: 128
Minimum: 10
FromUser: 
FromSource: ppi
Tel: true
TranscodeDtmf: false
AssociatedAddresses: 
InterOffice: false
DialPlan: 
UseEpid: false
CidUpdate: 
Ignore18xSDP: false
UserHdr: 
Diversion: 
CoBusy: 500 Line Unavailable
CoDest: 
Colines: 
DialogPermission: 

Share this post


Link to post
Share on other sites

What we noticed is that the registration period is longer than most firewall UDP NAT timeouts (typically 60 seconds). Please try to manually override that duration with the setting "Keepalive Time" e.g. set it to 30 and check if that helps.

Share this post


Link to post
Share on other sites

Back again for the 403 (Forbidden) problem:

 

It seems the main problem is given by the fact that the REGISTER is send to server 217.0.18.68 and the call INVITE to server 217.0.20.230. These both IPs are only examples for a lot of SBCs for the domain "tel.t-online.de". The registry string is not the same as the one from the invite, and there for you get forbidden message.

It helps to set the "Proxy Address" to "sip:217.0.18.68" for the trunk, but isn't really nice. Any (hidden) configuration option for that, like "insecure=port,invite" for asterisk?

Share this post


Link to post
Share on other sites

Did you already use the drop-down setup from the PBX trunk setup web page? Usually those problems should be solved with the outbound proxy.

Share this post


Link to post
Share on other sites

Hmm. I think according to the RFC the PBX does the right thing. But I just don't see the practical relevance. The registration process should make sure that the PBX picks a random address (if there are more than one) and then stick to it. I think this is something that we should change; I don't even think that we need a setting for that.

Share this post


Link to post
Share on other sites

Thats the problem exactly, it doesn't stick to the register IP address! The invite IP address is a different one.

 

Thanks for the private board message; will be back here asap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×