Jump to content
Vodia PBX forum

Twilio SIP Trunk

Recommended Posts

Has anyone had any success with configuring a Twilio SIP trunk?


Nothing seems to be working. Appreciate your assistance in advance.

Share this post

Link to post
Share on other sites

Looks very interesting what they are doing there. Seems they favor WebRTC against SIP and SIP is more like an afterthought! But this definitely very interesting. We don't have it in the drop-down (yet). If they more or less support SIP it should be possible to get it working.

Share this post

Link to post
Share on other sites

Thanks for the reply.


We are trying to test their Elastic SIP trunk though haven't been able to get it working after hours of testing.

Share this post

Link to post
Share on other sites



As promised.




With in Twilio here is what I used to get going.

  1. Create Twilio Trunk, i.e friendly name "test-trunk"
  2. Set Termination URI, i.e "test-trunk.pstn.twilio.com"
  3. Set Authentication, IP Access Control, input IP of PBX.
  4. Set Origination URI, sip:domain.yourpbx.com (Domain of where you will be adding the trunk on the Vodia PBX)
  5. Add voice number, configure with 'SIP Trunking' ensure its set to route to to the sip trunk friendly name




With in Vodia PBX under domain.yourpbx.com, here is the trunk setup screens shot,






*Note - based on what Localized URIs you end up using you will need to make sure the Explicitly list addresses for inbound traffic: setting has these reflected, or you could leave it blank but I would advise not to for security purposes, maybe for initial testing you can and then once you are happy its working lock it down.


Use this url to locate the media IP's https://www.twilio.com/docs/api/sip-trunking/getting-started#whitelist I had to input them IP by IP with a space I don't think the PBX would let me to do xxx.xxx.xxx.xxx/26 for example.


When I tried that I could not get calls in. You will need to just spend a few minutes and find out all the IP in the subnet they list for media gateways and put them in.





Twilio will send the full E164 number including + symbol in the request URI make sure you have the number against the extension or hunt group, what ever it is you are using.









Just make sure make your dial plans re-write the numbers to full E164 format including the + symbol or Twilio will not process them.



Let me know if you get stuck

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now