Jump to content
Vodia PBX forum
leonmol

SNOM 320 URI parameters

Recommended Posts

Hi There

 

I experience incoming call problems with SNOM 320 and IPComms VoIP service. I can make outgoing calls but cannot receive incoming calls.

 

After some troubleshooting I determined that the server sends INVITE requests to the telephone without the line= parameter.

 

Could someone advise what is the purpose of this uri parameter and whether it is possible to disable it?

 

The contact tag looks like this:

 

Contact:<sip:name@IP:port;line=ihsdmmnsd>;

 

thanks a lot for advice

 

Share this post


Link to post
Share on other sites

well, there is a router and an ISP (fixed IP).

the router has the relevant port forwarded to the SNOM telephone. Besides, it is used with another VOIP provider and everything works just fine.

 

as to PBX, my telephone registers with the PBX with the line parameter. They can also send the OPTIONS command with the line parameter. However, the INVITE message always comes without the line parameter for some reason :(

 

what is the line parameter used for?

Share this post


Link to post
Share on other sites

Check on the router if there is something like a application layer gateway (ALG) for SIP, and if that is so, turn it off. Or just use TLS for SIP, which is the default if you automatically provision the phones.

 

Are we talking here about problems with the phone or with the SIP trunk provider? Who is dropping the line parameter? SIP phones usually don't send OPTION messages...

Share this post


Link to post
Share on other sites

there is no ALG (don't see it anywhere in settings).

 

the problem is that I cannot configure my SNOM to work with the IPComms trunk. The PBX does not send the INVITE message with the line parameter. I cannot change PBX settings because this is with the service provider.

 

Interestingly, my CSIP softclient on the smartphone works just fine in the same network with the same provider including incoming calls. SNOM somehow behaves differently.

 

Is it possible to disable the line parameter at all? I could not find it in RFC 3261 ...

 

PS. Sorry, could not understand your recommendation about TLS/SIP - this is probably done on the PBX side.

Share this post


Link to post
Share on other sites

Can you post the INVITE here in the message thread (change the phone number to something like 123456789)? Then we may be able to see where the problem is. From your description I still don't get where the problem is and if the PBX is involved at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×