Jump to content
Vodia PBX forum

catprotec

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About catprotec

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Location
    Germany
  1. should have search more carefully. This is the solution - Thanx now my phones are ringing with the correct sounds !
  2. well the extension is registered as: REGISTER 200 <sip:200@192.168.10.218:5062> (udp:192.168.10.218:5062) Tiptel IP 286 2.51.13.2 00156513e98d 212 check-sync what entry is needed to use the ringtone ring2.wav ( which is a internal ringtone in the phone )
  3. ok i found the file: <?xml version="1.0" ?> - <ringtones> - <tone name="custom1"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Custom 1</vendor> <vendor ua="Cisco-.*"><Bellcore-dr4></vendor> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr4></vendor> </tone> - <tone name="custom2"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Custom 2</vendor> <vendor ua="Cisco-.*"><Bellcore-dr4></vendor> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr4></vendor> </tone> - <tone name="custom3"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Custom 3</vendor> <vendor ua="Cisco-.*"><Bellcore-dr4></vendor> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr4></vendor> </tone> - <tone name="custom4"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Custom 4</vendor> <vendor ua="Cisco-.*"><Bellcore-dr4></vendor> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr4></vendor> </tone> - <tone name="internal" type="internal"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Internal</vendor> <vendor ua="Cisco-.*"><Bellcore-dr2></vendor> <vendor ua="Grandstream HT-.*" /> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr2></vendor> </tone> - <tone name="external" type="external"> - <!-- vendor snom off --> <vendor ua="Polycom.*">External</vendor> <vendor ua="Cisco-.*"><Bellcore-dr3></vendor> <vendor ua="Grandstream HT-.*" /> - <!-- vendor snom on --> <vendor><http://127.0.0.1/Bellcore-dr3></vendor> </tone> - <tone name="intercom" type="intercom"> - <!-- vendor snom off --> <vendor ua="Polycom.*">Auto Answer</vendor> <vendor ua="Cisco-.*" type="call-info">auto-answer=0</vendor> <vendor ua="optiPoint .*" type="call-info">auto-answer=0</vendor> - <!-- vendor snom on --> <vendor ua="snom.*" type="call-info"><{from-uri}>;answer-after=0</vendor> - <!-- vendor snom off --> <vendor ua="Linksys.*" type="call-info"><{from-uri}>;answer-after=0</vendor> <vendor ua="Aastra.*" type="call-info"><{from-uri}>;answer-after=0</vendor> <vendor ua="Yealink.*" type="call-info"><{from-uri}>;answer-after=0</vendor> - <!-- vendor snom on --> <vendor type="answer-mode">Auto</vendor> </tone> </ringtones> how should i configure the usage of a special ringtone for Yealink / Tiptel phones ?
  4. I do not find any ringtones.xml file on the computer where the PBX is installed. Where should it be located ?
  5. we also have the same situation using TIPTEL IP286 ( = Yealink T-28 ) if you call the extension direct then a default ringtone is handed over which cannot be changed. Is there a solution ? Regards, Markus
  6. ok - i started the next tests setup a virtual machine with XP and outlook - Firewall is turned completely OFF No Registration possible setup a virtual machine with WIN7 and outlook - firewall completely turned off - IPv6 turned off No Registration possible I don't know how to solve this ?!? I've always use the setting from the WIKI how to setup the TSP means user 101, pass 101, domain localhost ( or sth. else ) PBX-Adress 192.168.10.14 no Firewall is active in our internal test network, nothing blocks the communication between the Client and the PBX
  7. no - firewall is turned off I try to set up a virtual XP machine with outlook and try it there
  8. SOLVED ! we set up a new machine, transferred the configuration and mail is working - seems to be something on my local machine, maybe the virusscan or sth. else. Thx for helping !
  9. ok i captured the interface while pbx is trying to connect to smtp-server very strange thing - wireshark doesn't see any packet for the exchange-server ip-address i'm a bit confused about that - ok - i tried a web.de - email-account - same problems "could not connect to ..." if i use an outlook client with the same credentials it works
  10. i tried from outlook: 5] 2010/06/10 16:43:33: SIP Rx udp:127.0.0.1:8806: NOTIFY sip:localhost SIP/2.0 Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-8r6k1775xrgsquwzu79w;rport From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern> Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 20 NOTIFY Max-Forwards: 70 Contact: <sip:101@127.0.0.1:8806> Event: x-tapi Content-Type: application/x-tapi Content-Length: 50 Action: MakeCall Line: 1 Call: 3 Address: 200 [5] 2010/06/10 16:43:33: SIP Tr udp:127.0.0.1:8806: SIP/2.0 404 Not Available Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-8r6k1775xrgsquwzu79w;rport=8806 From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern> Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 20 NOTIFY Content-Length: 0 [9] 2010/06/10 16:43:33: Message repetition, packet dropped [5] 2010/06/10 16:43:50: SIP Rx udp:192.168.10.1:19828: OPTIONS sip:192.168.10.60 SIP/2.0 Via: SIP/2.0/UDP 192.168.10.1:19828;branch=z9hG4bK-c47cd7cc-a0444733 From: <sip:192.168.10.60>;tag=-168875010--910284630 To: <sip:192.168.10.60> Call-ID: 3310150421@00a05711fc12 CSeq: 1 OPTIONS Max-Forwards: 70 Accept: application/sdp Contact: <sip:192.168.10.1:19828> Content-Length: 0 [9] 2010/06/10 16:43:50: Resolve 767: aaaa udp 192.168.10.1 19828 [9] 2010/06/10 16:43:50: Resolve 767: a udp 192.168.10.1 19828 [9] 2010/06/10 16:43:50: Resolve 767: udp 192.168.10.1 19828 [5] 2010/06/10 16:43:50: SIP Tx udp:192.168.10.1:19828: SIP/2.0 200 Ok Via: SIP/2.0/UDP 192.168.10.1:19828;branch=z9hG4bK-c47cd7cc-a0444733 From: <sip:192.168.10.60>;tag=-168875010--910284630 To: <sip:192.168.10.60>;tag=8d205e7c49 Call-ID: 3310150421@00a05711fc12 CSeq: 1 OPTIONS Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE Content-Length: 0 [5] 2010/06/10 16:43:50: SIP Rx udp:192.168.10.1:31464: OPTIONS sip:192.168.10.60 SIP/2.0 Via: SIP/2.0/UDP 192.168.10.1:31464;branch=z9hG4bK-23a0cfdf-8bb4a1be From: <sip:192.168.10.60>;tag=973706721-1854632180 To: <sip:192.168.10.60> Call-ID: 2401170090@00a05711fc12 CSeq: 1 OPTIONS Max-Forwards: 70 Accept: application/sdp Contact: <sip:192.168.10.1:31464> Content-Length: 0 [9] 2010/06/10 16:43:50: Resolve 768: aaaa udp 192.168.10.1 31464 [9] 2010/06/10 16:43:50: Resolve 768: a udp 192.168.10.1 31464 [9] 2010/06/10 16:43:50: Resolve 768: udp 192.168.10.1 31464 [5] 2010/06/10 16:43:50: SIP Tx udp:192.168.10.1:31464: SIP/2.0 200 Ok Via: SIP/2.0/UDP 192.168.10.1:31464;branch=z9hG4bK-23a0cfdf-8bb4a1be From: <sip:192.168.10.60>;tag=973706721-1854632180 To: <sip:192.168.10.60>;tag=884a622e58 Call-ID: 2401170090@00a05711fc12 CSeq: 1 OPTIONS Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE Content-Length: 0 [5] 2010/06/10 16:43:50: SIP Rx udp:192.168.10.1:9680: OPTIONS sip:192.168.10.60 SIP/2.0 Via: SIP/2.0/UDP 192.168.10.1:9680;branch=z9hG4bK-aca7df57-d61f5b55 From: <sip:192.168.10.60>;tag=-348868801-1214041537 To: <sip:192.168.10.60> Call-ID: 1200585045@00a05711fc12 CSeq: 1 OPTIONS Max-Forwards: 70 Accept: application/sdp Contact: <sip:192.168.10.1:9680> Content-Length: 0 [9] 2010/06/10 16:43:50: Resolve 769: aaaa udp 192.168.10.1 9680 [9] 2010/06/10 16:43:50: Resolve 769: a udp 192.168.10.1 9680 [9] 2010/06/10 16:43:50: Resolve 769: udp 192.168.10.1 9680 [5] 2010/06/10 16:43:50: SIP Tx udp:192.168.10.1:9680: SIP/2.0 200 Ok Via: SIP/2.0/UDP 192.168.10.1:9680;branch=z9hG4bK-aca7df57-d61f5b55 From: <sip:192.168.10.60>;tag=-348868801-1214041537 To: <sip:192.168.10.60>;tag=e13c4192e7 Call-ID: 1200585045@00a05711fc12 CSeq: 1 OPTIONS Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE Content-Length: 0 is it a problem if the PBX is running on my machine and the TSP also registers from my machine and tries to start a call ?
  11. ok another strange thing: if i try to start a call the registration of Extension 101 ( the TAPI-Client ) AND the registration of Extension 100 ( a SIP Phone ) is cleared ?!?
  12. i think it is registered ok: ... SUBSCRIBE sip:localhost SIP/2.0 Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-3ckhkqwcj881zz567glc;rport From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern>;tag=989ffb3ab0 Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 5 SUBSCRIBE Max-Forwards: 70 Contact: <sip:101@127.0.0.1:8806> Event: x-tapi Accept: application/x-tapi Expires: 3600 Content-Length: 0 [5] 2010/06/10 15:09:01: Last message repeated 2 times [9] 2010/06/10 15:09:01: Resolve 362: aaaa udp 127.0.0.1 8806 [9] 2010/06/10 15:09:01: Resolve 362: a udp 127.0.0.1 8806 [9] 2010/06/10 15:09:01: Resolve 362: udp 127.0.0.1 8806 [5] 2010/06/10 15:09:01: SIP Tx udp:127.0.0.1:8806: SIP/2.0 401 Authentication Required Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-3ckhkqwcj881zz567glc;rport=8806 From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern>;tag=989ffb3ab0 Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 5 SUBSCRIBE User-Agent: pbxnsip-PBX/4.0.1.3499 WWW-Authenticate: Digest realm="protec.intern",nonce="441f16a4432449db3682cd1d100a41a4",domain="sip:localhost",algorithm=MD5 Content-Length: 0 [9] 2010/06/10 15:09:02: Resolve 363: aaaa udp 127.0.0.1 8806 [9] 2010/06/10 15:09:02: Resolve 363: a udp 127.0.0.1 8806 [9] 2010/06/10 15:09:02: Resolve 363: udp 127.0.0.1 8806 [5] 2010/06/10 15:09:02: SIP Tx udp:127.0.0.1:8806: SIP/2.0 401 Authentication Required Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-3ckhkqwcj881zz567glc;rport=8806 From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern>;tag=989ffb3ab0 Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 5 SUBSCRIBE User-Agent: pbxnsip-PBX/4.0.1.3499 WWW-Authenticate: Digest realm="protec.intern",nonce="0bef83bf5fe2aa43f363d575d0021a99",domain="sip:localhost",algorithm=MD5 Content-Length: 0 [5] 2010/06/10 15:09:02: SIP Rx udp:127.0.0.1:8806: SUBSCRIBE sip:localhost SIP/2.0 Via: SIP/2.0/UDP 127.0.0.1:8806;branch=z9hG4bK-3ckhkqwcj881zz567glc;rport From: <sip:101@protec.intern>;tag=12218 To: <sip:101@protec.intern>;tag=989ffb3ab0 Call-ID: fw2d9x2zle2qqz00dp99 CSeq: 6 SUBSCRIBE Max-Forwards: 70 Contact: <sip:101@127.0.0.1:8806> Event: x-tapi Accept: application/x-tapi Authorization: Digest realm="protec.intern",nonce="441f16a4432449db3682cd1d100a41a4",response="7c36bc3e056d768242ab1a1e820f07cf",username="101",uri="sip:localhost",algorithm=MD5 Expires: 3600 Content-Length: 0 ... and in the account under registration: x-tapi 101 <sip:101@127.0.0.1:8806> (udp:127.0.0.1:8806) 135 check-sync but if i try to call with dialer nothing is done, nothing is shown in the log of the pbx if i try to call from outlook it says "no free line signal is found" even if i try to reach an internal account
  13. ok :-( what is wireshark ??
  14. Hi, is there any manual how to setup provisioning for Yealink VOIP Phones ? they are listed as suppoerted phones but i cannot find any manual how to use it AND Is it possible to show the domain phonebook on the phone itself ?
  15. Hi @all, I have some problems getting TAPI working on Windows XP I've downloaded the latest TSP-Version, installed it and configured it like in the WIKI. unfortunately no incoming calls are shown on my PC and i cannot make outgoing calls no errors in the event protocol, no log entries on pbxnsip - I'm a bit confused ?!?!? anyone here with similar problems ?
×
×
  • Create New...