Jump to content


  • Posts

  • Joined

  • Last visited

Everything posted by clarity

  1. Still would very much like to get ahold of the version for Debian. How do I get it? There's no reference to where to download it here in this thread or in the general software download areas. The reference in this thread is only for Centos or CS410 or windows. Thanks, Steve
  2. Is debian5 (Lenny) i386 (32bit) officially supported or semi officially supported? In other words should I proceed to use Debian5 since it is newer and considered stable at least from a Debian community standpoint or do I need to make special effort to go back and use Debian 4 with any pbxnsip including 4beta and forward? Thanks. Steve
  3. Where can I download this debian version? Only Centos/WIndows and CS410 are mentioned above. THANKS! Steve
  4. Can you please tell me.. For both the beta and pbxnsip 3.x versions. 1. is it supported in Debian? can we get a debian supported download of the beta? 2. is ithe beta supported in Centos version 5.3 both i386 and 64bit versions? 3. Is pbxnsip supported in any 64bit linux? b. Is there a benefit to using 64bit OS beyond huge ram? c. Is there a benefit to AVOIDING a 64 bit OS? 4. is pbxnsip supported in Debian 5 stable? 5. is it supported in Debian 64bit Linux? 6. is it supported in 64bit windows? THANKS!
  5. What I think you are telling me is to simply have them do just the hot desking (4xx) extension numbers in your example. Make sure the 4xx phones are in the right agent groups but do not log onto the quoe so skip that step. They are already setup exactly like that.. just that they have been doing the log onto the que step as well as hot desking. So I should simply have them *not log onto the queue* and the just use the hot desking at 4xx (6xx) in our case. And this should clear up the problem. (make sure 4xx) (6xx) in our case extension numbers are in the right que(s) hen simply logg off hot desking if not wanting to be in the queue so to speak. I will have them try this. Thanks.. Steve
  6. I had shared this directly with pradeep earlier and he had suggested there may need to be a software update to fix this: I am also cross posting this issue to the public forum per Pradeep's request. 3rdly I have opened a support case and copied this information there as well. THANKS! --- I’m not sure exactly how to go about trouble shooting this problem. I imagine it’s simple. We have a customer of whom I’ve set up hot desking where they log onto their extension number (601) Hot desk. Then they log onto the agent queue by pressing *64 (agent login) The person (601) is entered into a number of agent groups as defined in the agent groups themselves.. You’ll see “601” is part of maybe 5-10 agent groups. The customer is complaining that they are still getting inbound calls to their phone (from other agent groups) of which they are part of when they are already on the phone.. And that the other agents who are logged in are not getting the calls sometimes… In other words it does not always go to an available agent who is not on the phone but is ringing him (601) yet he’s already on the phone having answered a phone call earlier.. If you need to look on our server. The specific extension (hot desking acct) is 601, he’s logging onto phone (501) and then logging into the agent queue by pressing *64. Server hostname: ******.***.*** Username: **** Password: **************** His expectation is that he should not receive any agent queue type calls when he’s already on the phone but someone else who is not on the phone but in the agent group should be getting the second inbound call rather than him. Here are the call details that he was able to get me on the last time it happened… I’ve asked him to try and record the events when it happens and to see if it can be recreated. Do you see anything obviously wrong or have any suggestions on where I can begin to test? Thanks! [Pradeep's response:] Hi Steve, Here is the response from Christian. Looks like we need to add some code to make the behavior that you are looking for. Pradeep Subject: Re: FW: Pbxnsip Hot Desking Ongoing complaint from customer. Hmm. I believe it is a "feature". The agent is something "logical", while the phone is something physical. The PBX knows that the agent is busy talking, but is not sure about the specific device. I believe the workaround must be that the phones that are used as hot desking devices should not be part of a ACD.
  7. This series of questions is geared toward using pbxnsip in a hosted pbx environment (providing services to many many clients). I have to prepare for and expect to be able to support 50,000 phones & up as our company grows & expands. This started out as an email question and per Kevin's suggestion I am posting it on the forum as well so Christian can have a look and answer. --------- I have a few questions you might be able to help me with regarding load balancing large numbers of pbxnsip servers and interrop with session border controllers. Do you have any experience with placing pbxnsip behind any of the well known commercially available and/or open source session border controllers? And can you share your experiences with us? how did it go? what works what does not work? I'm somewhat familiar with the process of using OpenSER as an SBC and placing asterisk & other servers behind it and doing all of the nat traversal/call translations etc in the SBC section of the network. I'm curious of your thoughts toward eventually employing this type of approach with PBXnsip versus having 50+ pbxnsip servers directly on public IP addresses where pbxnsip is handling virtually all of the NAT and call routing/translations. Do you think this approach makes sense? and do you think it would be relatively 'plug -n- play'? Or do you think we'd have a HUGE interrop/development task on our hands before it would work. Have you ever been through this interrop process with any SBC product? My thought today would be to put 10-50 pbxnsip servers behind OpenSER and have OpenSER handle all of the NAT traversal/internal network 'topology hinding' features and place the pnxnsip servers on private non routable IP space behind OpenSER.. yet still maintain and have ALL of the pbxnsip features be able to continue to work behind OpenSER. features like BLF intercom IM really all pbxnsip features that we have today... Do you think they will work behind an SBC like OpenSER? or do you think they would all break due to interrop issues with an SBC, where pbxnsip no longer has total control of the public Internet Interface? Thank you very much for your time and your thoughts!! I am currently working with OpenSER and will be steadily becoming much more familiar with all the ins & outs of this software as we move on. I've also been working on a daily basis with the Stratus ENTICE Softswitch/SBC for about 3 years now. Take Care! Steve
  8. Don't rely on just those customer reports of audio dropping off to determine you are nearing your max CPU for PBXNSIP. Get an IP phone plugged directly into the lan or WAN of the server.. try both. During the busiest time of the day and during those types of loads test with a locally connected telephone and make calls into/out of voicemail. If it's not choppy and sounds perfect in both directions (recorded messages) I'd bet you have plenty of CPU/RAM/IO to spare. Also try PSTN calls if you have locally connected PSTN. (not distant voip). Just my immediate thoughts.. Maybe you have already done these tests. -Steve
  9. Tested with Polycom Phones (IP-650) (IP-670) and IP330 If I change the top (preferred codec) to be G722 in PBXNSIP.. Either globally (settings) -or at the individual account.. G722 calls work great between supported phones and to PBXnsip IVR/Voicemail prompts. However all calls break to other phones that do not support G722 such as Polycom IP-330 or to the PSTN gateway which is G.711 This is not expected behavior. I'd expect if one leg of a call.. be it another phone that does not support G722 or the PSTN Gateway (G711 only) should cause both legs of the call to fall back to the common accepted codec (g711). This is not happening... the IP 650's and 670's are still showiing "HD" in the display and get NO audio with the other end of the call which is G711. G722 phones sem to 'have no clue' that the far end is not supporting G722. I can provide packet traces if needed. Our test box is on Debian4/Intel Xeon. (Linux) License Status: Demo License (3 Minutes) License Duration: Permanent Additional license information: Thanks! Steve
  10. Looks like the problem(s) are that the examples given on that site do not work. I'm guessing the web interface tries to do it the same way which does not work. Further looking around shows that you have to issue the command like this: The -c and -p must come FIRST then the arguments. *this works* pbx:/srv/pbxnsip# taskset -c -p 0 3330 pid 3330's current affinity list: 2 pid 3330's new affinity list: 0 pbx:/srv/pbxnsip# Doing them the way that website suggests: # taskset -c 1 -p 13545 Absolutely does not work in my Linux installation as well as some others I had read about. I'd still like to be able to set it from the web interface.. Is that hard coded? or does it fire off an external script that I can 'fix'? ;-)
  11. Logfile shows "Set processor affinity to 1 failed" on each service startup. How do I fix this? I really would like to lock it down to one CPU core and avoid RTP the associated jitter problems of 'core hopping'. This is a quad core Xeon server and I'm running PBXNSIP (Linux) Deban 4.0 up to date. SMP kernel. Any suggestions? pbx:/proc# cat version Linux version 2.6.18-4-686 (Debian 2.6.18.dfsg.1-12etch2) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Wed May 9 23:03:12 UTC 2007 pbx:/proc# cat cpuinfo processor : 0 vendor_id : GenuineIntel cpu family : 15 model : 4 model name : Intel® Xeon CPU 3.20GHz stepping : 1 cpu MHz : 3192.275 cache size : 1024 KB physical id : 0 siblings : 2 core id : 0 cpu cores : 1 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl cid cx16 xtpr bogomips : 6388.27 processor : 1 vendor_id : GenuineIntel cpu family : 15 model : 4 model name : Intel® Xeon CPU 3.20GHz stepping : 1 cpu MHz : 3192.275 cache size : 1024 KB physical id : 0 siblings : 2 core id : 0 cpu cores : 1 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl cid cx16 xtpr bogomips : 6384.06 processor : 2 vendor_id : GenuineIntel cpu family : 15 model : 4 model name : Intel® Xeon CPU 3.20GHz stepping : 1 cpu MHz : 3192.275 cache size : 1024 KB physical id : 3 siblings : 2 core id : 0 cpu cores : 1 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl cid cx16 xtpr bogomips : 6384.05 processor : 3 vendor_id : GenuineIntel cpu family : 15 model : 4 model name : Intel® Xeon CPU 3.20GHz stepping : 1 cpu MHz : 3192.275 cache size : 1024 KB physical id : 3 siblings : 2 core id : 0 cpu cores : 1 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl cid cx16 xtpr bogomips : 6384.12
  12. Not very easily in this case... the switch is expecting that I will send it the ttl expire value that I want in the registration requests. Every other sip endpoint I have used allows me to change this. And I've not had a problem setting it one any other equipment yet. Is there some way I can change this in pbxnsip a config file maybe? Thanks! Steve
  13. Don't know if this helps or applies... But it works for me on the older Cisco phones and V7 or 6.5 Steve nat_enable: "1" voip_control_port: "5060" start_media_port: "11200" end_media_port: "11300
  14. I think what we are really after here is a means to set the sip expiry value to 120 instead of 3600.... In most endpoints/phones that I work with when I set the re-registration period this is also set simultaneously on that device... I need to get pbxnsip to do this... I need to be able to set the expiry to less than 3600 (120 or 60 in this case). Updating ticket with actual sip header info: Steve
  15. Thanks, gave that a try also tried some of that before posting here :-) Also have a ticket open on this but will post here as well for sharing. --------------- I have tweaked the min and max registration times. Also this problem is pertaining to how often I'd like a sip trunk to re-register and not phones (just to make sure I'm clear in what we are dealing with. I realize some/all the settings may interract It looks like this may have caused a re-register or keepalive change, however our softswitch is still somehow seeing the registration interval as 3600 seconds and not 120. When I say this I mean my switch sees and stores 3600 seconds as how long it expects a registration to live... The settings you mento do seem to cause the registration process to follow... I'm seeing registrations every two minutes now but I do not see the registration TTL (time to live) reflecting that increase. If I change registration interval on a typical phone that is registered to our system I see the TTL value as seen/displayed on our switch change along with it. With pbxnsip it stays set to 3600 regardless of how often pbxnsip is re-registering with us. I don't know if that is due to an initial negotiation of 3600 and then in changes on the backend (pbxnsip) to re-register at minregistration time.... or what... But my softswitch still displays that you are set for a TTL at 3600 seconds... On a typical SIP phone if I register with our switch... that field gets updated on our switch to match... with pbxnsip registering..... it has not changed from 3600 seconds no matter what I have tried in settings. I have presented this problem to our switch vendor as well just incase it some some type of interrop issue. Bottom line of what I need is for our switch to expect re-registration every 120 seconds so that if the pbx disappears and goes off internet we will be aware of it right away and not have to wait an hour... I am using very short call timers for route advance to get around this for now but its a dirty solution and causes 10 seconds of extra delay before the route advances.... If I see the registration as bad, it will advance right away. Thanks! Steve :::::Note to switch vendor. PBX is claiming they are re-registering every 120 seconds persettings but our switch is showing a TTL of 3600 I see Last update field updating every 2 minutes as expected however TTl: stays at 3600 Problem is if they disappear... switch still thinks they are there due to that TTL:3600 I'm expecting/desiring that to timeout quickly (120) so that switch quickly route advances if that gateway is not available. If that internet connection goes down, we still try them as if they were registered. What do I need to do (or get the pbx to do so that this TTL shows up as the lower value that they are actually re-registering at? Steve
  16. As you know we are still battling with this! Looks like you almost have it figured out in software there... Unfortunately that latest fix didn't do anything at all... Maybe somehow check and see if I have the right build? Steve
  17. I see that you have the very cool keepalive feature... however the re-register interval is set at 1 hour and I've not found were to lower that. I need the far end to realize that registration is lost pretty quickly if the network goes down at the client side. As is now the remote system thinks I'm still there and I have to rely on the timers for the next route decision (at far end not pbxnsip) to occur... If I can lower that timer to 2 minutes instead of an hour, this will satisfy our requirement on that matter. Thanks!!! Steve
  18. Partially resolved.... I have my inbound multi DIDs working but.... I didn't realize until now that you can enter multiple identities in the alias field for the AA and not just one. Looking at it a little closer revealed the word "aliases". which ends in an "s" and implies you can have more than 1 ;-) Okay... Still wonder about that dial plan though.... Seems that would be the right way alternate (or more elegant) way to do this... But I get that strange behavior when I try it that way. Seems we still have something wrong there.... If it says call extension... then you should be able to do that yes? If an extension is not registered and it wants to go to voicemail or an auto attendant it looks to me like the system freaks out a little. Thanks! Steve Ps.. pbxnsip newb here.
  19. We have an auto attendant identified by main ID 570 of which I can dial from any phone and of course reach. I can also reach it reliably via 1 DID if that is put into the additional alias field. That seems to work just fine however I have like 5 DIDs that need to reach that same auto attendant. All inbound calls are from a SIP gateway. I thought the best way to do this would be use of the dialplan and the call extension option. I tried this and the results are very strange... Pref=100 (lowest) I am matching here... I also tried this with no other dialplan entrys Trunk=Call Extension Pattern=13131110000 <---Fake number for this post in my config I have real number there Replacement=570 All testing done on direct LAN Calling DID internally from extensions.... Get long hang (no audio) then drop 570 is the auto attendant..... Is there some issue that dialplan cannot point to an auto attendant? If I switch it to an actual registered extension (503) It still does not work..... then after a few minutes it works but very intermittently hit or miss.... I also tried directing to an unregistered extension 555 which should give me voicemail but does not get same type of hang and message. If I dial 555 from any phone I get 555's voicemail like I should. For 503 which is registered *not* busy and completely working if you dial it from another phone... Log shows: [5] 2008/01/19 21:54:09: Dialplan BLVD-1: 503 goes to extension [5] 2008/01/19 21:54:09: Could not start call to extension 503 because there is no registration or the extension is busy " Very confused.... I don't know if I uncovered a bad bug or if I'm doing something wrong. + now I'm out of ideas of how to bring these 5 inbound numbers into the same auto attendant. Steve
  20. I am first trying to get this very basic busy lamp function to work. (nothing else at the moment) I do not have a long list but simply TWO extensions monitoring each other to start so I am hoping we can move forward with the assumption that we are not running into other problems with long extensions lists or UDP packet size bottle necks. You say it works at first.... I am trying to get this initial functionality to work. with just two phones and busy lamp indicate only right now. Can tell me if this basic functinality works and is supported? Also can you help me go over my configuration andtell me if I have setup my system properly for this to work? Please tell me what you need to look at and I will provide it. Thanks
  21. Thanks for getting back to me. I have it setup about as simple as it can get... Two extensions that monitor each other with a single buddy watch. Are you asking to see a packet capture of it working with asterisk? and then another of it *not* working with PBXnsip? Is this a known working feature? All I'm really looking for is the basic LED on/OFF you describe... I do not expect more. Should we take a look at my configuration/setup before getting into packet captures on this? Thanks! Steve
  22. Busy Lamp and online status with Polycom Phones... I'm pretty used to doing this with asterisk. --- However I've been unable to get it to work on PBXnSIP. I have the polycom phones (650s and 550s) configured with presence enabled and buddy watch turned on for a couple of extensions. But they always show up as offline even though they are registered and/active in a call when testing. I've found very little documentation or setup instructions on this and am looking for help or pointers. Phones are all firmware (latest release ware) and PBXnSIP is Debian Linux/ (Linux) I've tried messing with these: Watch the calls of the following extensions (* for all): Watch the presence of the following extensions (* for all): setting things like "*" and entering single extension numbers etc. Also have not found any docs on this or examples.... please help! -Steve
  • Create New...