Jump to content
Vodia PBX forum
Carl Johnson

Issue with outbound from (caller-id)

Recommended Posts

My local vendor for our PRI does not allow outgoing caller-id to be anything but one of our DID's .. the rub is we want that to be the case when calling out from an extenstion so we have opted for Remote Party/Privacy Indication: of an RFC one or the other .. which one someone calls in but I want to forward to a cell phone number, etc the PBX automatically sends that as the caller-id. What can be done about this to retain the proper outgoing DID for the ext the call was sent from, etc?

Share this post


Link to post
Share on other sites
My local vendor for our PRI does not allow outgoing caller-id to be anything but one of our DID's .. the rub is we want that to be the case when calling out from an extenstion so we have opted for Remote Party/Privacy Indication: of an RFC one or the other .. which one someone calls in but I want to forward to a cell phone number, etc the PBX automatically sends that as the caller-id. What can be done about this to retain the proper outgoing DID for the ext the call was sent from, etc?

 

Well, the rules are defined in http://wiki.pbxnsip.com/index.php/Outbound_Calls_on_Trunk.

 

In the next version we'll have a new setting called "ANI" for every account, where you can explicity put the caller-ID that you want to this specific account.

 

I think we need to write something up that explains how this whole Caller-ID presentation works in theory and in real ITSP-operator life.

Share this post


Link to post
Share on other sites

I believe Pbxnsip started with its B2BUA model when it turned impossible to only Proxy SIP messages and hope that the rest of the world would follow all standards (also Many new nice features were then feasible with B2BUA).

Following the same idea and to make life easier to all of us, Pbxnsip should make available the option to replace the “From” header for outbound calls thru the trunk. It would work with almost every ITSP and Voip gateway without having to dig into standards to find out who to blame.

The new "ANI" setting seems promising.....

In the meanwhile take a look at this link where I show screenshots on how I implemented it:

external Caller ID in pbxnsip

Share this post


Link to post
Share on other sites

Due the ruleset it is still an issue then as that seemingly cannot be overridden currently. Our current setup is as such, which works properly EXCEPT in the described scenario .. can I get an ETA on this fix in the PBX as it really negates many functions available otherwise.

 

Trunk DID: Fallback Good number

Remote Party: RFC3225 (Asserted)

Share this post


Link to post
Share on other sites
In the 3.0 release we (will) have a ANI settings that should solve many of these problems.

Here is our problem with Caller ID issue. We offer hosted service. We port many existing customers original numbers to our PRI (we have a provider who will do that) In many cases we have to assign either one of our DID numbers or ported number to an extension so that incomming call can find proper domain. In previous version we were able to assign DID on the trunk and present that as an outgoing caller ID. In our current version (2.1.10.2474) we can no longer do that. Is there a way to force PBX to send the caller ID from DID on the trunk?

 

How soon to the next version?

Share this post


Link to post
Share on other sites
Here is our problem with Caller ID issue. We offer hosted service. We port many existing customers original numbers to our PRI (we have a provider who will do that) In many cases we have to assign either one of our DID numbers or ported number to an extension so that incomming call can find proper domain. In previous version we were able to assign DID on the trunk and present that as an outgoing caller ID. In our current version (2.1.10.2474) we can no longer do that. Is there a way to force PBX to send the caller ID from DID on the trunk?

 

How soon to the next version?

 

In 2.1.10 you can do that by using the tel:alias or a per-account basis, this has higher priority than the DID number setting in the trunk. This solution is okay unless you have two extensions that should both show the same DID which is not the same as the DID for the trunk (that will be fixed in 3.0).

Share this post


Link to post
Share on other sites
Well, the rules are defined in http://wiki.pbxnsip.com/index.php/Outbound_Calls_on_Trunk.

 

In the next version we'll have a new setting called "ANI" for every account, where you can explicity put the caller-ID that you want to this specific account.

 

I think we need to write something up that explains how this whole Caller-ID presentation works in theory and in real ITSP-operator life.

 

We just switched providers and they block any call that doesn't have ANI that matches one of ours. Our providor is concerned about Caller-ID spoofing, and they won't relax this restriction.

 

We are running version 2.1.10

 

Your documentation says: "If the call is redirected from another incoming call, it will use the original number."

 

We can't forward calls to cell phones, or even manually transfer calls to outside numbers since the PBX always tries to use the ANI from the incoming call.

 

We need a setting for "If the call is redirected from another incoming call, use the ANI for the the station doing the redirecting" Help!

Share this post


Link to post
Share on other sites
In 2.1.10 you can do that by using the tel:alias or a per-account basis, this has higher priority than the DID number setting in the trunk. This solution is okay unless you have two extensions that should both show the same DID which is not the same as the DID for the trunk (that will be fixed in 3.0).

 

That is precisly the problem. We have to have tel:alias in order for incomming calls to reach proper domain, remember we are running in hosted mode with many domains. On top of that our povider requires that on outbound calls we send 10 digits to them. Only then they pass it along, if it is not 10 digit number they send the number asociated with PRI (our office main number). If we use 10 digit tel:alias our gateway doesn't know how to send incoming calls correctly since it is a local 7 digit call. So now everyone's caller ID appears as our main number, so we get a lot of calls from people that are "returnig" their calls since it appears that it came from us

Share this post


Link to post
Share on other sites
That is precisly the problem. We have to have tel:alias in order for incomming calls to reach proper domain, remember we are running in hosted mode with many domains. On top of that our povider requires that on outbound calls we send 10 digits to them. Only then they pass it along, if it is not 10 digit number they send the number asociated with PRI (our office main number). If we use 10 digit tel:alias our gateway doesn't know how to send incoming calls correctly since it is a local 7 digit call. So now everyone's caller ID appears as our main number, so we get a lot of calls from people that are "returnig" their calls since it appears that it came from us

 

Remember that you can also use two (or more) tel:alias in one account. The first one will be the one that is used as ANI, but the second one is also used for inbound matching. Maybe that helps to solve the problem.

Share this post


Link to post
Share on other sites
Remember that you can also use two (or more) tel:alias in one account. The first one will be the one that is used as ANI, but the second one is also used for inbound matching. Maybe that helps to solve the problem.

 

I do not see where can I add another tel:alias to account? What is the trick?

Share this post


Link to post
Share on other sites
I do not see where can I add another tel:alias to account? What is the trick?

 

I have found answer to my question which works for us. In case someone has similar problem here is the solution:

 

in the alias field type:

 

tel: your 10 digit number space tel:seven digit number. Hope this helps...

Share this post


Link to post
Share on other sites
Guest Paul McCabe
I have found answer to my question which works for us. In case someone has similar problem here is the solution:

 

in the alias field type:

 

tel: your 10 digit number space tel:seven digit number. Hope this helps...

 

Glad to hear the multiple tel:alias entries for the extension worked...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...