Jump to content
Vodia PBX forum
DarkKnight

Hunt Group--Auto Attendant--Hunt Group Fails to get to Final Stage

Recommended Posts

I'm using version 2.1.14.2498 (Linux) and 2.1.6.2450 (Win32), and have found a possible bug:

 

If you have a Hunt Group's final stage kick to a Auto-Attendant, and then choose a Direct Destination choice off that Auto-Attendant to direct you to a 2nd Hunt Group, the 2nd Hunt Group seems to work, except the call is disconnected before it reaches the Final Stage of the 2nd Hunt Group (in this case just a General VM box - i.e., an Extension with a Voicemail box but no phone registered on it). We have tried several ways around this, but get the same result on both versions.

 

Has anyone else experienced this? Any workaround for it?

 

Is there planning to be a patch made for it in version 3.0 or later?

 

 

Thanks in advance!

 

DK

Share this post


Link to post
Share on other sites

This sounds like you have reached the max number of redirects allowed.

 

This is a feature to stop run-away calls from looping and looping.

 

To fix this....

 

Stop the service

Go to the Working Directory of the PBX

Edit pbx.xml

Look for the XML setting max_loop

Change it to the required value

Start the service.

 

That should do it.

Share this post


Link to post
Share on other sites

Hi Thank you for the tip but it did not work :( we are having the same issue here and we are desperate to resolve that, when there is a incommoding call redirect fine to the auto attendant ext 100, when you press any option given by the auto attendant, it does not redirect calls to the selected options, it is happening to all domains in the PBX, when I restart the PBXNSIP service, it settles for a while but the problem comes back again, any help would be appreciated !!!!

 

Thanks

 

 

 

 

This sounds like you have reached the max number of redirects allowed.

 

This is a feature to stop run-away calls from looping and looping.

 

To fix this....

 

Stop the service

Go to the Working Directory of the PBX

Edit pbx.xml

Look for the XML setting max_loop

Change it to the required value

Start the service.

 

That should do it.

Share this post


Link to post
Share on other sites
Hi Thank you for the tip but it did not work :( we are having the same issue here and we are desperate to resolve that, when there is a incommoding call redirect fine to the auto attendant ext 100, when you press any option given by the auto attendant, it does not redirect calls to the selected options, it is happening to all domains in the PBX, when I restart the PBXNSIP service, it settles for a while but the problem comes back again, any help would be appreciated !!!!

 

That sounds like a DTMF problem to me. Do you see anything in the log (media, level 6) like "Received DTMF 2"?

Share this post


Link to post
Share on other sites
That sounds like a DTMF problem to me. Do you see anything in the log (media, level 6) like "Received DTMF 2"?

 

 

 

No man, I cannot see anything in the logs , we have built the new server, we have tested a new database, tried to import all the data into other server environment and same thing happens, I am desperate for a solution any other suggestion?

 

Thank your very much

Share this post


Link to post
Share on other sites
No man, I cannot see anything in the logs , we have built the new server, we have tested a new database, tried to import all the data into other server environment and same thing happens, I am desperate for a solution any other suggestion?

 

Well, if you don't see any DTMF in the log, that means the PBX does not process any DTMF... Do you have the SIP INVITE packet that hits the PBX (coming from the trunk)? Maybe we can see something there. Or just send my a PM with the HTTP access and we'll log on to your system and do a test call to see what's wrong.

Share this post


Link to post
Share on other sites
Well, if you don't see any DTMF in the log, that means the PBX does not process any DTMF... Do you have the SIP INVITE packet that hits the PBX (coming from the trunk)? Maybe we can see something there. Or just send my a PM with the HTTP access and we'll log on to your system and do a test call to see what's wrong.

 

 

 

Can your please send a email so that I can send you the login details

 

Thank you

Share this post


Link to post
Share on other sites

was there a fix?

 

im facing kinda same issue

i have the hunt group stage 1: 101 and 102 for 20 seconds

final stage: (800)555-1212

when someone calls into that office, the calls are on a hunt group for 20 seconds, then it goes to a autp attendant, then when they select an option from 1-0 it goes into another hunt group which works fine untill it has to get to the final stage, which i set stage 1 to be for 20 seconds then after 20 seconds the call just ends, it doesnt transfer to the extern number i entered inthe field for final stage

Share this post


Link to post
Share on other sites
was there a fix?

 

im facing kinda same issue

i have the hunt group stage 1: 101 and 102 for 20 seconds

final stage: (800)555-1212

when someone calls into that office, the calls are on a hunt group for 20 seconds, then it goes to a autp attendant, then when they select an option from 1-0 it goes into another hunt group which works fine untill it has to get to the final stage, which i set stage 1 to be for 20 seconds then after 20 seconds the call just ends, it doesnt transfer to the extern number i entered inthe field for final stage

 

 

---Yes, for me, jag's reply worked, which was:

 

This sounds like you have reached the max number of redirects allowed.

 

This is a feature to stop run-away calls from looping and looping.

 

To fix this....

 

Stop the service

Go to the Working Directory of the PBX

Edit pbx.xml

Look for the XML setting max_loop

Change it to the required value

Start the service.

 

That should do it.

 

----My version had the "max_loop" default value set at 10, and I changed it to 15, and that has worked ever since, for even more complicated scenarios than what you described.

 

----Oh yeah, just so you know, in your scenario, you cannot put a external telephone number in at the final stage....it does not work that way. Instead, you have to put in an Extension number that has been set to have your external telephone number in the "Call Forward All Calls To:" field (under the Redirection tab) for that Extension you're using as the "Redirection Extension." Hope this helps.

Share this post


Link to post
Share on other sites

i have a diff domains et up where it does transfer the call to the final stage even the final stage is a external number

 

i guess the issue is the looping prevention set to 10 or whatever the default is set to

the problem is i cant afford to reboot the service since there is contacntly ongoing calls on it

Share this post


Link to post
Share on other sites

when i click on that link it tells me the link doesnt have any text on that page

 

Global Settings

From Pbxnsip Wiki

Jump to: navigation, search

There is currently no text in this page, you can search for this page title in other pages or edit this page.

Share this post


Link to post
Share on other sites

I am having the same issue. My customer wants a group with a final destination as an AA with the option to press 1 to ring another group or 2 to leave a message, when dialling 1 it rings the 2nd group which also has an AA as the final destination but the call is cut off after the ringing the 2nd group.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...