Jump to content
Vodia PBX forum
nate

choppy on inbound ring when on on line

Recommended Posts

I am using a snom phone enviroment, with 360's and 320's. They all do the same thing. When on a call, and say my extension is part of a ring group, even if i have the phone set for call waiting indication to off, still when the line rings in, it creates a pause or dead spot in the conversation. If i have call waiting indication to visual only, it does the same thing. Anyone have any ideas? I don't mind if another line rings in while I'm on the phone, but i don't want it to interrupt my current call.

Share this post


Link to post
Share on other sites
I am using a snom phone enviroment, with 360's and 320's. They all do the same thing. When on a call, and say my extension is part of a ring group, even if i have the phone set for call waiting indication to off, still when the line rings in, it creates a pause or dead spot in the conversation. If i have call waiting indication to visual only, it does the same thing. Anyone have any ideas? I don't mind if another line rings in while I'm on the phone, but i don't want it to interrupt my current call.

 

Can you verify that this does not happen with another phone? E.g. pick a softphone and see if you have the same effect. Otherwise, question is what firmware, transport layer (tls, udp).

Share this post


Link to post
Share on other sites
Can you verify that this does not happen with another phone? E.g. pick a softphone and see if you have the same effect. Otherwise, question is what firmware, transport layer (tls, udp).

Same thing with Soft Phone, or any other phone.

Share this post


Link to post
Share on other sites
Same thing with Soft Phone, or any other phone.

 

Whow. How big is your hunt group? You probably create a burst that generates a major hickup. Consider inviting people in the hunt group in a short succesion, e.g. after one second. That will reduce the load by factor 2.

Share this post


Link to post
Share on other sites
Whow. How big is your hunt group? You probably create a burst that generates a major hickup. Consider inviting people in the hunt group in a short succesion, e.g. after one second. That will reduce the load by factor 2.

there are 6 accounts in ring group. how do i invite people in the hunt group in a succession?

Share this post


Link to post
Share on other sites
there are 6 accounts in ring group. how do i invite people in the hunt group in a succession?

 

Well, I would put two in the first stage, have the timeout one second, then put four in the second stage, have a timeout of one second and put all six in stage three, have a timeout of 28 seconds. Then the total timeout is 30 seconds.

Share this post


Link to post
Share on other sites
Well, I would put two in the first stage, have the timeout one second, then put four in the second stage, have a timeout of one second and put all six in stage three, have a timeout of 28 seconds. Then the total timeout is 30 seconds.

Is the timeout duration? or do you specify timeout somewhere else?

Share this post


Link to post
Share on other sites

I run into this all the time , in my opinion there is a bug with SRTP and hunt groups, my guess if you have the same issue I run into all the time , the phones are encrypting SRTP ,

 

when this happens to me I switch from TCP to UDP either with PNP or manually and the problem goes away , hope this helps ..

 

yori

Share this post


Link to post
Share on other sites
I run into this all the time , in my opinion there is a bug with SRTP and hunt groups, my guess if you have the same issue I run into all the time , the phones are encrypting SRTP ,

 

when this happens to me I switch from TCP to UDP either with PNP or manually and the problem goes away , hope this helps ..

 

yori

I don't mean to ask a dumb question, but where are you changing that from tcp to udp?

Share this post


Link to post
Share on other sites

don't sweat it, all questions are good questions here :( ...

 

in the newer 3.0 versions you can go to the System Level settings , go to settings -> PNP -> look for "snom_3xx_phone.xml/transport =" and change it from tls to udp ...

 

if it is a less recent version , you have to dump the PNP and go with hand registration , yori

Share this post


Link to post
Share on other sites
don't sweat it, all questions are good questions here :( ...

 

in the newer 3.0 versions you can go to the System Level settings , go to settings -> PNP -> look for "snom_3xx_phone.xml/transport =" and change it from tls to udp ...

 

if it is a less recent version , you have to dump the PNP and go with hand registration , yori

All right, well i changed it, and we will see what happens..

Share this post


Link to post
Share on other sites

let me know, i'd be curious since I have run into this alot , if you look at the status , you should see cpu spikes in the call history in the pbxnsip GUI if my hunch is correct , then they will go away if you switch to udp and the calls will not lose audio when the lines ring in , BTW what version are you running ?

Share this post


Link to post
Share on other sites
let me know, i'd be curious since I have run into this alot , if you look at the status , you should see cpu spikes in the call history in the pbxnsip GUI if my hunch is correct , then they will go away if you switch to udp and the calls will not lose audio when the lines ring in , BTW what version are you running ?

 

version 3.0.0.2990

Share this post


Link to post
Share on other sites
version 3.0.0.2990

that didn't fix it. it actually made it worse. there are no cpu spikes on the inbound calls. we are running a dual xeon 2.4 server.

Share this post


Link to post
Share on other sites
that didn't fix it. it actually made it worse. there are no cpu spikes on the inbound calls. we are running a dual xeon 2.4 server.

 

For a 2.4 GHz server that is not the problem. Bringing me back to the point of bandwidth limitations. When a group starts ringing, there are a lot of large SIP packets leaving towards the network - they occupy a lot of bandwidth.

 

Did you set the change the registry to enable the tagging of RTP packets for the Type of Service? There is a article from Microsoft on this topic: http://support.microsoft.com/kb/248611/en-us (see http://wiki.pbxnsip.com/index.php/Installing_in_Windows).

Share this post


Link to post
Share on other sites

You'd have to have alot of phones for a 100mbs network to bog down , I would include a packet trace to the thread to be looked at , I'm still not convinced there aren't issues with the HG coding ..

 

sorry my advice made it worse , it's what generally does the trick for me ,

Share this post


Link to post
Share on other sites
For a 2.4 GHz server that is not the problem. Bringing me back to the point of bandwidth limitations. When a group starts ringing, there are a lot of large SIP packets leaving towards the network - they occupy a lot of bandwidth.

 

Did you set the change the registry to enable the tagging of RTP packets for the Type of Service? There is a article from Microsoft on this topic: http://support.microsoft.com/kb/248611/en-us (see http://wiki.pbxnsip.com/index.php/Installing_in_Windows).

 

I don't think it is a bandwidth limitation either, we are on a 1gig local network. do you still think this could be it?

Share this post


Link to post
Share on other sites
can you disable one of the CPU's in the bios , I know there were some old issues with dual CPU , maybe a shot , i'm around tomorrow , do you have remote access ? PM if you want ..

yori

i can disable one of the dual cpus in the bios. i do have remote access .

Share this post


Link to post
Share on other sites
i can disable one of the dual cpus in the bios. i do have remote access .

The software should only bind to one cpu anyways by default and to the one set in the affinity mask if you want to move it to another core. Can you rule out that it is a snom phone issue and add say a softphone to the hunt group and see what that does. A pcap trace from the snom phone would be helpful if it points back to the phone.

Share this post


Link to post
Share on other sites
The software should only bind to one cpu anyways by default and to the one set in the affinity mask if you want to move it to another core. Can you rule out that it is a snom phone issue and add say a softphone to the hunt group and see what that does. A pcap trace from the snom phone would be helpful if it points back to the phone.

 

it also does it on different brand phones, and soft phone.

Share this post


Link to post
Share on other sites
it also does it on different brand phones, and soft phone.

Another thing I've discovered, is it does it when it goes from the hunt group , to the Auto Attendent. So when the AA picks the call up, after ringing the 6 extensions, it cuts out.

The same goes, when ringing the hunt group, and another extension takes the call, when it tranfsers from the hunt group to an extension, it does the same thing.

Share this post


Link to post
Share on other sites
it also does it on different brand phones, and soft phone.

 

What does the PBX log in the beginning? There should be something in the stat like "Timer frequency is xxx us". Maybe there is something strange with the scheduler.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...