Jump to content
Sign in to follow this  
Jan Forcier

SPA2102 T.38 Fax settings

Recommended Posts

I'm testing T.38 Fax with an SPA 2102, with Snon 2.03 latest build, Linux.

Our carrier (for inbound) supports T.38.

I've followed the instructions I can find for the SPA2102 but when I attempt T.38 the faxing fails (g711u works but with the usual reliability problems)

The T.38 Pass thourgh appears to be working since the INVITE packets in the PBXnSIP log clearly show this is passed to the UA (see below).

 

Do you know the settings which will work with SPA2102 T.38? If you know another ATA that has been verified to work, I'd like to know the settings for this adapter and I can possibly buy one.

 

 

INVITE packet below--------------------------------------------

 

INVITE sip:6044844702@159.18.161.101:5060 SIP/2.0

Via: SIP/2.0/UDP 66.119.176.21:5060;branch=z9hG4bK-ad99b3cf8bcd8ade9e941caa73a31e86;rport

Route: <sip:6046379679@159.18.161.67;ftag=159.18.161.101+1+400593+54d16769;lr=on>

From: <sip:6046379679@sproxy.netfone.ca>;tag=c4a452d288

To: Metrobridge <sip:6044844702@159.18.161.101:5060>;isup-oli=00;tag=159.18.161.101+1+400593+54d16769

Call-ID: FC2ED118@159.18.161.101

CSeq: 6652 INVITE

Max-Forwards: 70

Contact: <sip:6046379679@66.119.176.21:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, OPTIONS, PRACK, INFO, PUBLISH, NOTIFY, SUBSCRIBE, MESSAGE

Accept: application/sdp

User-Agent: voipportal-PBX/2.0.3.1708

Content-Type: application/sdp

Content-Length: 273

 

v=0

o=- 428992889 428992891 IN IP4 66.119.176.21

s=-

c=IN IP4 66.119.176.21

t=0 0

m=image 51072 udptl t38

a=T38FaxVersion:0

a=T38MaxBitRate:14400

a=T38FaxRateManagement:transferredTCF

a=T38FaxMaxBuffer:200

a=T38FaxMaxDatagram:200

a=T38FaxUdpEC:t38UDPRedundancy

Share this post


Link to post
Share on other sites

Is this the first packet that the SPA sends? In T.38 the end point first needs to establish a G711 call and then after the fax tone detection switch to T.38.

Share this post


Link to post
Share on other sites

Hi!

 

I have a very similar problem. Our VOIP Gateway to the outside world supports T38.

 

The problem is, i simply cant get the SPA to work with t38. I made traces which very clearly show that the SPA does not switch to T38. Even when the re-invite is sent from our gateway. It sticks to g711. I will now try a Patton/Inalp ATA and the Grandstream Adapter which seems to work better.

 

I shall keep you posted.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...