Jump to content

snom message light


hosted
 Share

Recommended Posts

im running 7.1.35

 

I have the system set to email me and save the email as read. however the light is always flashing and the voicemail on the phone says i have 1 new message. if i call the voicemail it says i have 20 saved messages.. then the voicemail indication is gone.

 

why.. is it not sending the proper messages?

Link to comment
Share on other sites

im running 7.1.35

 

I have the system set to email me and save the email as read. however the light is always flashing and the voicemail on the phone says i have 1 new message. if i call the voicemail it says i have 20 saved messages.. then the voicemail indication is gone.

 

why.. is it not sending the proper messages?

 

It seems that the phone turns the MWI on even if there are "new" saved messages...

Link to comment
Share on other sites

In my display right now it says 1 new 19 old messages.

 

I pressed the VM button... says i have 20 saved messages. light is gone now.

 

 

To me; it seems that pbxnsip is not updating the phone when a messages is emailed then updated to saved status.(instead of new)

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

this actually isnt a snom issue its a pbxnsip issue.

 

Right now my snom VM light is on. I just loaded up eyebeam to the same exension and there is also a VM light. So from eyebeam i called my VM and it says.. " 20 saved messages" I hang up. Now my snom and eyebeam VM light goes off.

 

So pbxnsip is not telling the phones there are no messages.

 

I have my VM forwarded to email and marked as READ. i assume this is the problem.

Link to comment
Share on other sites

  • 2 weeks later...
this actually isnt a snom issue its a pbxnsip issue.

 

Right now my snom VM light is on. I just loaded up eyebeam to the same exension and there is also a VM light. So from eyebeam i called my VM and it says.. " 20 saved messages" I hang up. Now my snom and eyebeam VM light goes off.

 

So pbxnsip is not telling the phones there are no messages.

 

I have my VM forwarded to email and marked as READ. i assume this is the problem.

 

I checked again http://www.ietf.org/rfc/rfc3842.txt. IMHO the MWI bodies of the PBX are correct. If there is no new message, then the PBX will say "Messages-Waiting: no". That is the correct behavior.

Link to comment
Share on other sites

right which is normally does. However this is the only scenerio it doesnt work.

 

set your vm limit to 5 messages and set the voicemail to email you and mark as read. now leave 6 messages the voicemail no matter what give indication that there is 1 message still. call the voicemail and do nothing and it updates the phone.

 

same think scenerio works with polycom, xlite, snom so it has to be the PBX not updating the phone that the message was maked as read and thus not a new message.

Link to comment
Share on other sites

right which is normally does. However this is the only scenerio it doesnt work.

 

set your vm limit to 5 messages and set the voicemail to email you and mark as read. now leave 6 messages the voicemail no matter what give indication that there is 1 message still. call the voicemail and do nothing and it updates the phone.

 

same think scenerio works with polycom, xlite, snom so it has to be the PBX not updating the phone that the message was maked as read and thus not a new message.

 

Yea, the problem is that the PBX first sends the MWI, then sends the email and then marks the message as "saved". We will change the sequence so that the PBX will first send the email, mark the message as saved and then send the MWI. That should fix the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...