Jump to content
Vodia PBX forum
Henrikt

Provisioning from WAN

Recommended Posts

I try to provisioning a Snom phone from the WAN. I have a Vodia PBX behind NAT and setup NAT for all incoming UDP/TCP traffic to the PBX.

If i provisioning the Snom phone on the local network and move it to WAN, then it´s work fine, if i change the lokal PBX IP to the WAN IP.

 

Anyone there have make this setup ?

Share this post


Link to post
Share on other sites

You need to keep in mind that in contrast to a web server, the PBX needs to calculate what IP address it needs to advertise to the outside world. There is an article about this at https://vodia.com/doc/server_behind_nat that may serve as a starting point for solving your problem. In a nutshell, you need to tell the PBX what IP address it will present to the phone when going back through the firewall.

Share this post


Link to post
Share on other sites

Thanks for your help.

I have setup the IP routes and the phone provisioning over WAN and logon to the PBX, but the function keys dosen't provisioning automatic. Here i neet to choose "Save as custom" under buttons for the extensions before they works.

When i reboot or power off the the phones all function keys are gone until i choose "Save as cuntomer" again..

Share this post


Link to post
Share on other sites

You probably need to "open the account up for provisioning" in the extensions list. Then there is a time-window when the phone can fetch the configuration data from the PBX without having a password yet. It is a little bit like Bluetooth or Wifi pairing.

Share this post


Link to post
Share on other sites

Dosen´t works sorry.

I delete the extension and reboot the pbx -> Reset the phone -> create a new extension (open accounts for MAC-based provisioning) -> change "Settings URL" on the phone" and reboot the phone.

Now the Funktions Keys works until i power off or reboot the phone. Then i have to Save buttons as customer again to get the functions keys working.

Share this post


Link to post
Share on other sites

Hi Vodia support

 

If i log in to the Advance -> Update i got this setup:

 

Update Policy : Automatic Update
Setting URL : http://xxxxx.dk (on xxxx.dk my pbx are places and all port TCP/UDP are forwarded to the PBX.)
Settings refresh timer : 0

PnP Config : on

 

The phone logon to the PBX and works fine, it´s only the functionskeys there are the issue until i "save as custom" under buttons for the extensions

Share this post


Link to post
Share on other sites
  • Reset the phone and delete the generated folder for that extension.

 

Path for windows C:\Program Files\Vodia Networks\Vodia PBX\generated

 

Linux usr/local/pbx/generated

 

  • Plug and play the phone again,
  • Don't force the phone to get its this time
  • check the generated folder ---domain---extension and see if all the prov files are there.

Please list them here.

 

Which version are you currently running on the Vodia PBX

 

Please list the phones firmware as well.

 

Best regards

Share this post


Link to post
Share on other sites

I reset the phone and delete the delete the folder. Setup the Settings URL and reboot the phone.

Now the buttons works but in the display i see a note "Reboot required"

 

In the generated\11 i have this files:

 

history.txt, snom_3xx_phone-MAC ID, snom_320_buttons-MAC ID, snom_firmware-MAC ID and snom_models-MAC ID.

 

i use a Snom 375 with firmware 8.9.3.50 and a Vodia PBX 5.4.0 Win64 bit

 

 

Now i reboot the phone and the buttons are not working again.

Share this post


Link to post
Share on other sites

Update

 

I have reset "snom_3xx_phone.xml" to default and then the phone provisioning fine and the functions keys works. :-)

 

But some time i only have one-way-audio. This issue i normal solved with change

 

<user_outbound idx="{lc}" perm="RW">{outbound-proxy snom_transport}</user_outbound>

to

<user_outbound idx="{lc}" perm="RW">sip:192.168.1.200:5060;transport=tcp</user_outbound>

 

where 192.168.1.200 are the PBX. This solution i can´t use with the remote provisioning. Are there a way to change the TLS to TCP? because TCP works each time..

Share this post


Link to post
Share on other sites

Sorry.... but to solved the one-way-audio i try to setup transport to TCP or UDP, but it dosen´t work..

 

If i change to back TLS on port 5061 it´s works fine with the buttons and dial-out, but with the issue as one-way-audio sometime.

Share this post


Link to post
Share on other sites

Last update before weekend. :-)

 

If i change TCP port from 5060 to 5080 and setup transport=TCP port 5080 on outgoing proxy it´s look like it´s works fine... so i think it´s a issue with port 5060..

Share this post


Link to post
Share on other sites

Hi, Henrikt

 

Thank you for the update!

 

This is just an option

 

You can change the outbound proxy in the domain level as well. The setting is under the provisioning parameters. Under the outbound proxy you can do the following.

 

 

0.0.0.0/24/192.168.1.200:5080/tcp

 

 

 

Provisioning Parameters Default PnP dial plan scheme: User must press enter North America (2-digit extensions [2-7]x) North America (3-digit extensions [2-7]xx) North America (4-digit extensions [2-7]xxx) Europe (2-digit extensions [2-7]x) Europe (3-digit extensions [2-7]xx) Europe (4-digit extensions [2-7]xxx) Authentication user: Authentication password: Authentication password (repeat): Authentication PIN: Authentication PIN (repeat): Outbound proxy pattern (e.g. 1.2.3.4/24/192.168.1.2:5060/udp):

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...