Jump to content

One-Way Audio After Retrieving Call from Hold


glpms
 Share

Recommended Posts

Hi,

We recently upgraded from 5.3.2 to 5.5.0 and upgraded all Snom phones from 8.7.3.25 to 8.7.5.35. Now after retrieving a call from a hold, we cannot hear the caller, but the caller can hear us. This happens with extension to extension calls too. The following two log files are from the PBX and from the phone making the call. The phone making the call is also the one put on hold.
Many Thanks
Link to comment
Share on other sites

My guess is that there is something wrong with SRTP. Did you automatically provision the phone? If that is the case, change the transport layer for that extension to TCP, re-provision it again. Or just go to the web interface of the phone and change it there.

 

And I would also make a PCAP trace from the web interface of the PBX for that extension. Then you can see what the PBX was able to decode in the RTP stream.

Link to comment
Share on other sites

Thanks for your reply.

 

I do provision automatically. I changed the "Proposed SIP Transport Protocol" at the extension level. I factory reset the phone and automatically provisioned. However, now when someone calls that extension, it goes straight to voicemail. The error I see in the SIP trace is "No supported media type found". Below is the SIP trace.

 

https://dl.dropboxusercontent.com/u/46769109/No%20supported%20media%20type%20found%20SIP%20Trace.txt

 

Thank you

Link to comment
Share on other sites

Can you please factory reset one phone (for testing) and re-provision it.

 

The problem is the snom phones don't overwrite provisioning settings and with the new version something needs to be updated. That can be done if the phone is in factory reset mode and then provisioned. I am assuming that will be the problem.

 

Thanks.

Link to comment
Share on other sites

Thanks for your reply.

 

As I said in my last post, I already tried factory resetting the Snom 300 phone and re-provisioned using TCP several times and it still reports, "No supported media type found". However, setting the transport layer to TCP on the PBX does turn the RTP Encryption setting off on the Snom phone properly.

 

On the PBX, I have set the transport layer to TCP on the System, Domain and Extension level; each individually and then all together. However, the PBX continues to send a crypto line and the Snom phone does not seem to be ignoring this line.

 

Below is a file of all settings on the Snom phone.

 

https://dl.dropboxusercontent.com/u/46769109/PhoneSettings520.txt

Link to comment
Share on other sites

I got TCP working by setting the, "Domain Outbound Proxy Pattern", instead of using the, "Proposed SIP transport protocol" setting. The latter doesn't work.

 

Now using TCP, call holding and retrieving does indeed work again.

 

However, what specifically do I look at in the PCAP trace to help me figure out what's going wrong with SRTP?

 

Thanks for your help.

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

 

Sorry to barge in but I had this issue before.

It's not Vodia's fault I'm afraid.

It's actually the snom firmware. You need to downgrade for now or use this beta: http://downloads.snom.com/fw/8.7.5.52/snom300-8.7.5.52-SIP-f.bin or http://downloads.snom.com/fw/8.7.5.52/snom821-8.7.5.52-SIP-r.bin

Replace the 300 or 821 with your snom model. But be aware it's a BETA.

There is an issue with switching from headset to handset on this beta and probably some other issues.

Cheers!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...