Jump to content

Wrong date and time in SnomOne Mini


sandromonte55
 Share

Recommended Posts

Hi to all,

 

i'm a snomONE mini user from about 4 years. All worked well in my office, but a couple of days ago, after a power failure, when my Snom mini started up,it didn't work properly. I saw that in it showed a wrong date and hour, and exactly 1-1-1970, hour 00:00

I supposed it needed a little of time to refresh that date but it did't happen.

 

Can anyone help me to understand this and resolve the problem ?

 

below a screenshot of status page..

 

Thanks in advance

 

-sandro

post-70105-0-33677500-1494592245_thumb.png

Link to comment
Share on other sites

Ok, many thanks.. by the way, looking into the file pbx-config, that I found inside a configuration backup, i have seen the following rows:

 

<timezone>CET</timezone>

<ntp_host>pool.ntp.org</ntp_host>
So it seems that the NTP Server is "Pool.ntp.org"
and this server seems to be active
Any ideas ?
Link to comment
Share on other sites

Hi,

 

i 'm trying to connect via ssh to the snomONE but i have a"Permission denied"

I type the followig command

 

ssh admin@192.168.0.11

it ask me the password;: i type administrator pw (nome utente admin, password snomONE)

but the response is "Permission denied"

 

what is the error ? do I need to type something else (i.e port number) ?

 

-sandro

Link to comment
Share on other sites

Hi,

i tried restarting the snomMini several times, via software and also removing power cable (POE cable). The only test I didn't was the reset to default values.

 

I tried with many user name and password but it denied permission. Do I have to tell the PBX what door to use? below the command i used.....

 

Last login: Sun May 14 08:09:24 on ttys000

MacMini-Server:~ server$ ssh admin@192.168.0.11
admin@192.168.0.11's password: snomONE
Permission denied, please try again.
admin@192.168.0.11's password: snomone
Permission denied, please try again.
admin@192.168.0.11's password: blank
Permission denied (publickey,password).
MacMini-Server:~ server$ ssh root@192.168.0.11
root@192.168.0.11's password: snomONE
Permission denied, please try again.
root@192.168.0.11's password: blank
Permission denied (publickey,password).
Link to comment
Share on other sites

Hmm. There is no magic back door here. If you don't have the SSH password then you cannot log in... I know that in the newer versions the root password was written when you write a new admin password from the web interface. I am not sure when that feature was introduced. But maybe we get distracted by trying to get into the system by SSH.

 

If the system was able to get the time before, it should be able to get the time now. I remember that the snom devices were shipped with a NTP server pointing to ntp.snom.com, which does not seem to work properly any more:

xx:~$ ntpdate -d ntp.snom.com
14 May 07:41:01 ntpdate[6808]: ntpdate 4.2.8p4@1.3265-o Wed Apr  5 13:28:09 UTC 2017 (1)
Looking for host ntp.snom.com and service ntp
188.40.67.131 reversed to hedgehog.snom.net
host found : hedgehog.snom.net
transmit(188.40.67.131)
receive(188.40.67.131)
transmit(188.40.67.131)
receive(188.40.67.131)
transmit(188.40.67.131)
receive(188.40.67.131)
transmit(188.40.67.131)
receive(188.40.67.131)
188.40.67.131: Server dropped: strata too high
server 188.40.67.131, port 123
stratum 16, precision -23, leap 11, trust 000
refid [188.40.67.131], delay 0.18391, dispersion 0.00903
transmitted 4, in filter 4
reference time:    00000000.00000000  Thu, Feb  7 2036  1:28:16.000
originate timestamp: dcc2c0d2.f97e6f3f  Sun, May 14 2017  7:41:06.974
transmit timestamp:  dcc2c0d3.b3e478bb  Sun, May 14 2017  7:41:07.702
filter delay:  0.18576  0.24048  0.18391  0.23187 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -0.81079 -0.83555 -0.80983 -0.83128
         0.000000 0.000000 0.000000 0.000000
delay 0.18391, dispersion 0.00903
offset -0.809833


14 May 07:41:07 ntpdate[6808]: no server suitable for synchronization found
Link to comment
Share on other sites

Done !

 

I have changed the pw ,as you said, and now i can access the snomOne mini (see below)

Now can i try to set the NTP server ?

 

Last login: Sun May 14 13:21:44 on ttys000

MacMini-Server:~ server$ ssh root@192.168.0.11
root@192.168.0.11's password:
Linux snomonemini 2.6.33.6 #4 PREEMPT Thu Dec 8 03:18:43 EST 2011 armv5tel
The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jan 1 00:00:59 1970 from 192.168.0.2
root@snomonemini:~#
Link to comment
Share on other sites

Ok, we should be close to solving this mystery. On my mini here the /etc/ntp.conf shows a line

# You do need to talk to an NTP server or two (or three).
server 188.40.67.131

which is actually the IP address of ntp.snom.com. Change it e.g. to pool.ntp.org and restart the PBX...

Link to comment
Share on other sites

excuse, but can you tell me what i need to type into the terminal once i have logged ,to do that you suggest me?

 

be patient, please, i' m not an expert on this......

 

i tried what you can see below to see what was the ntp server settings, but it don' t work, sure i typed wrong.....

 

TIA

 

Last login: Thu Jan 1 16:58:55 1970 from 192.168.0.64

root@snomonemini:~# /etc/ntp.conf

-bash: /etc/ntp.conf: Permission denied

root@snomonemini:~# etc/ntp.conf

-bash: etc/ntp.conf: No such file or directory

root@snomonemini:~#

Link to comment
Share on other sites

Hi,

used vi editor (with some difficult..) to modify /etc/ntp.conf file and changed ntp.snom.con to pool.ntp.org as you can see below in the attachment, saved file, exit. I restarted the PBX, but seeing in status window i have again uptime 1970/1/1 ......

 

help !

post-70105-0-38563300-1494918257_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...