Jump to content
Vodia PBX forum
chrispopp

Provision Yealink phones via RPS

Recommended Posts

When I open the provisioning to Yealink T48. it returns a 500 error. I'm thinking this has to do with the certificates, but I don't know which to add. Unless it can be something else...

[5] 2017/07/24 16:34:23: Prov request: <?xml version='1.0' encoding='UTF-8'?>
<methodCall>
<methodName>redirect.deRegisterDevice</methodName>
<params>
<param>
<value><string>001565EEEEEE</string></value>
</param>
</params>
</methodCall>
[5] 2017/07/24 16:34:23: Prov request: <?xml version='1.0' encoding='UTF-8'?>
<methodCall>
<methodName>redirect.registerDevice</methodName>
<params>
<param>
<value><string>001565EEEEEE</string></value>
</param>
<param>
<value><string>0ec8bb3e8fee21234567</string></value>
</param>
<param>
<value><string>1</string></value>
</param>
</params>
</methodCall>
[6] 2017/07/24 16:34:23: 1 more requests pending to rps.yealink.com:443[7] 
2017/07/24 16:34:23: https:rps.yealink.com:443: DNS A returned 184.106.101.50[7] 
2017/07/24 16:34:23: https:rps.yealink.com:443: Connect to 184.106.101.50
9] 2017/07/24 16:34:23: https:rps.yealink.com:443: Send requestPOST /xmlrpc HTTP/1.1
Host: rps.yealink.com:443
Content-Length: 207
Authorization: Basic <XYZ>
Content-Type: text/xml
Accept-Language: en-us
User-Agent: Mozilla/4.0 (compatible; PBX)

<?xml version='1.0' encoding='UTF-8'?>
<methodCall>
<methodName>redirect.deRegisterDevice</methodName>
<params>
<param>
<value><string>001565EEEEEE</string></value>
</param>
</params>
</methodCall>
[9] 2017/07/24 16:34:23: Initialize TLS connection
[7] 2017/07/24 16:34:23: https:rps.yealink.com:443: Return code 500[5] 2017/07/24 16:34:23: Prov response: 
[7] 2017/07/24 16:34:23: https:rps.yealink.com:443: DNS A returned 184.106.101.50
[7] 2017/07/24 16:34:23: https:rps.yealink.com:443: Connect to 184.106.101.50
[9] 2017/07/24 16:34:23: https:rps.yealink.com:443: Send requestPOST /xmlrpc HTTP/1.1
Host: rps.yealink.com:443
Content-Length: 332
Authorization: Basic XXZZYY
Content-Type: text/xml
Accept-Language: en-us
User-Agent: Mozilla/4.0 (compatible; PBX)

<?xml version='1.0' encoding='UTF-8'?>
<methodCall>
<methodName>redirect.registerDevice</methodName>
<params>
<param>
<value><string>001565EEEEEE</string></value>
</param>
<param>
<value><string>0ec8bb3e8fee21234567</string></value>
</param>
<param>
<value><string>1</string></value>
</param>
</params>
</methodCall>
[9] 2017/07/24 16:34:23: Initialize TLS connection[7] 2017/07/24 16:34:23: https:rps.yealink.com:443: Return code 500[5] 2017/07/24 16:34:23: Prov response: [7] 2017/07/24 16:34:23: REST: GET rest/system/session[7] 2017/07/24 16:34:23: REST: GET rest/domain/self/admin[7] 2017/07/24 16:34:23: REST: GET rest/system/session[7] 2017/07/24 16:34:23: REST: GET rest/user/23333%40mark.ssslll.com/log

Share this post


Link to post
Share on other sites

Hi,

 

I think you meant version 57.3. If so, please upgrade to 58.1 and please try again. If it still doesn't, let us know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...