Jump to content

Snom D315 IO provisioning not working


almoondsllc
 Share

Recommended Posts

Hello,

I just installed the last version of Vodia and I'm trying to do provisioning with a Snom D315 in the LAN but is not working, vodia logs reports:

Web Server: File snomD315/snomD315-firmware.htm not found

And then nothing else.

Phone is this:

https://www.snom.com/ip-phones/desk-phones/d3xx-series/snom-315-desk-telephone/

with firmware version:     snomD315-SIP 8.9.3.46

Vodia PBX version: 60.0.1 (Debian64)

I checked almost everything but it doesn't work, what can I check? Thank you for any tips.

 

Regards,

Alessandro Marzini

Link to comment
Share on other sites

Hi,

 

Looks like it worked on our 60.0 over here.

Here are the admin level logs:

[5] 16:08:30.889 PROV: Identified prov/snom300.htm by pattern snom???.htm
[9] 16:08:30.889 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.889 PROV: HTTP: Received request for file snom300.htm from 192.168.123.26
[8] 16:08:30.890 PROV: PnP: Extracted MAC for file snom300.htm
[9] 16:08:30.890 PROV: Filter configuration file snom_redirect.xml
auth: false
body: 
content-type: text/xml
filename: snom300.htm
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 
macauth: false
match: 300
resource: /snom300.htm
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[7] 16:08:30.890 PROV: File snom_redirect.xml was rendered without a user
[8] 16:08:30.891 PROV: HTTP: file snom300.htm based on template snom_redirect.xml is sent to 192.168.123.26
[9] 16:08:30.967 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.967 PROV: HTTP: Received request for file snom300-000413280753.htm from 192.168.123.26
[8] 16:08:30.968 PROV: PnP: Extracted MAC 000413280753 for file snom300-000413280753.htm
[8] 16:08:30.968 PROV: Provisioning file snom300-000413280753.htm looking for MAC 000413280753
[8] 16:08:30.970 PROV: PnP: Using the credentials of 448@vodia for file snom_300.xml
[9] 16:08:30.971 PROV: Filter configuration file snom_300.xml
auth: true
body: 
content-type: text/xml
filename: snom300-000413280753.htm
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 000413280753
macauth: false
match: 0
model: 300
resource: /prov/snom300-000413280753.htm
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:30.974 PROV: HTTP: file snom300-000413280753.htm based on template snom_300.xml is sent to 192.168.123.26
[9] 16:08:31.065 PROV: Provision for User-Agent Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[8] 16:08:31.065 PROV: HTTP: Received request for file snom_cert-000413280753.xml from 192.168.123.26
[8] 16:08:31.065 PROV: PnP: Extracted MAC for file snom_cert-000413280753.xml
[9] 16:08:31.066 PROV: Filter configuration file snom_cert.xml
auth: false
body: 
content-type: text/xml
filename: snom_cert-000413280753.xml
host: 192.168.0.144
http: true
https: false
ip: ({
mac: 
macauth: false
match: 
resource: /prov/snom_cert-000413280753.xml
user-agent: Mozilla/4.0 (compatible; snom300-SIP 8.7.3.25.9 1.1.3-u)
[7] 16:08:31.066 PROV: File snom_cert.xml was rendered without a user
[8] 16:08:31.067 PROV: HTTP: file snom_cert-000413280753.xml based on template snom_cert.xml is sent to 192.168.123.26

 

 

And this is the setting  from the web GUI of the phone. 

 

Maybe you can switch the firmware on the phone and try it again?

Flash the phone, switch the PBX into the incognito mode, reboot the phone and then it should show up in the LAN devices.

2.png

Link to comment
Share on other sites

Maybe the pattern was just missing in the pnp_snom file. You can try to edit the pnp_snom.xml file in the templates web page, like this (notice the snomD31?):

  <file name="snom_300.xml" encoding="xml">
    <pattern mac="8">snom30?-############.htm</pattern>
    <pattern mac="9">snomD30?-############.htm</pattern>
    <pattern mac="9">snomD31?-############.htm</pattern>
    <prefix>true</prefix>
    <vendor>snom</vendor>
    <anonymous>true</anonymous>
    <protocol>tftp,http,https</protocol>
  </file>

We will include this in the next build, so please after updating just revert the file then.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...