Jump to content
Vodia PBX forum
impiantitel

TLS: Alert Fatal -> Certificate unknown

Recommended Posts

hi,
I'm trying Vodia and in the log I see the following error,
 don't understand if it's alarming or not and how to solve it:
I guess I have to do it on "Certificates and private keys".

5] 8:31:27.926 TLS: Alert Fatal (2): Certificate unknown (46)

 

Share this post


Link to post
Share on other sites

It is just saying Fatal because it's a security concern which the PBX should raise. If you turn on the Let's Encrypt certificate setting (on /reg_settings.htm page) under "ACME Directory URL" and set it to "Let's Encrypt" , your domains will get the valid certificates and it should not show anymore.

Share this post


Link to post
Share on other sites

Thank you for your support,
I actually without touching anything is already set as by the screen that I enclose,
Do I have to do anything else?

I just happen to have to do something about it: -> /reg_certificate.htm  ?
keep in mind that Vodia is not on public ip but on local ip

 

screen.png

Share this post


Link to post
Share on other sites

I realize that this is a bit old. i have always used purchased certs, but this is a much better solution. However, i have read everything above and i am not sure what to do as there are no longer any selections to make as Lets Encrypt is default. I dont see any certifcates in place and i am not sure how to make that happen now, as https now gives the warning, as i have removed the purchased cert.

What are we supposed to do to enable lets encrypt as i have read everything but there seems that there is nothing to actually do to make this happen in v. 64.

 

thanks

Share this post


Link to post
Share on other sites

Well the PBX checks at midnight if any of the certificates need to be renewed. If you can wait until morning it should heal itself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...