Jump to content
Vodia PBX forum
nate

exchange 2007 email relay settings

Recommended Posts

i am having a problem relay voice mail to my exchange 2007 server.

both are on an internal network of 172.16.1.0/24

 

what are the correct settings i should have on my exchange server to relay email properly?

Share this post


Link to post
Share on other sites
i am having a problem relay voice mail to my exchange 2007 server.

both are on an internal network of 172.16.1.0/24

 

what are the correct settings i should have on my exchange server to relay email properly?

 

Well, you have to use SMTP. I know it works with the currently published version, there are several installations talking to Exchange with SMTP. But I am not the big Exchange expert, on the PBX side you just need to point the SMTP server to the Exchange server (that part is easy :D ).

Share this post


Link to post
Share on other sites
Well, you have to use SMTP. I know it works with the currently published version, there are several installations talking to Exchange with SMTP. But I am not the big Exchange expert, on the PBX side you just need to point the SMTP server to the Exchange server (that part is easy :D ).

 

i have it set, other things on the inside can relay with outh authenticating. when i look at the log on pbxnsip, i'm getting

[8] 2008/10/30 19:29:41: SMTP: Send EHLO localhost

 

[8] 2008/10/30 19:29:41: SMTP: Received 250-ex01.tek-hut.com Hello [172.16.1.4]

250-SIZE 10485760

250-PIPELINING

250-DSN

250-ENHANCEDSTATUSCODES

250-AUTH

250-8BITMIME

250-BINARYMIME

250-CHUNKING

250 XEXCH50

 

[8] 2008/10/30 19:29:41: SMTP: Send AUTH LOGIN

 

[8] 2008/10/30 19:29:41: SMTP: Received 504 5.7.4 Unrecognized authentication type

 

[5] 2008/10/30 19:29:41: SMTP Server returned 504

 

any ideas?? it looks like a setting on the pbxnsip side.

Share this post


Link to post
Share on other sites
i have it set, other things on the inside can relay with outh authenticating. when i look at the log on pbxnsip, i'm getting

[8] 2008/10/30 19:29:41: SMTP: Send EHLO localhost

 

[8] 2008/10/30 19:29:41: SMTP: Received 250-ex01.tek-hut.com Hello [172.16.1.4]

250-SIZE 10485760

250-PIPELINING

250-DSN

250-ENHANCEDSTATUSCODES

250-AUTH

250-8BITMIME

250-BINARYMIME

250-CHUNKING

250 XEXCH50

 

[8] 2008/10/30 19:29:41: SMTP: Send AUTH LOGIN

[8] 2008/10/30 19:29:41: SMTP: Received 504 5.7.4 Unrecognized authentication type

[5] 2008/10/30 19:29:41: SMTP Server returned 504

 

any ideas?? it looks like a setting on the pbxnsip side.

 

Do you have control over the Exchange server? Maybe you can try turning TLS on, or check what authentication types you can turn on there. Last resort would be to just trust the IP address of the PBX and don't use a username/password at all.

Share this post


Link to post
Share on other sites

Hello nate,

 

you can create a receive connector on the Exchange 2007. In this connector you can allow only the IP-adress or FQDN of your pbxnsip server. In the connector settings, simply use no authentication. Or activate authentication and configure pbxnsip with authentication.

 

Maybe a good start for the receive connector is Technet Exchange 2007 Receive connectors...

 

Note: If available, using the Exchange Unified Messaging Role together with pbxnsip offers more cool features, than a simple SMTP voicemail relaying. For example PlayOnPhone & Outlook Voice Access.

 

Best regards,

 

Jan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...