Jump to content

Yealink Templates Phones


Recommended Posts

I normally enter the customizations for Yealink Templates Phones in the "Yealink General" window, and all phones regularly take these custom parameters.
I have upgraded my Yealink phones to version and now it doesn't work anymore (even if I enter the customizations in Yealink General, these parameters don't get them from the Yealink phone).
Now to customize the Yealink template I have to edit the file "yealink_common.txt".
Is this a known error?
Is there a solution?


I also found a bug (I think),
basic Vodia sets the listening code of the voicemail = voice_mail.number.1 = {account}
Then pressing the voicemail key from extension 215, for example, will dial 215, so it's an error.
To fix it I tried to insert:
voice_mail.number.1 = *97
The problem is that the * character doesn't take him in charge,
in fact if for example imposed (only for test):
voice_mail.number.1 = 333
At this point, by pressing the voicemail key, the telephone sends 333.
This shows that it is currently impossible to set *97 for voicemail listening.


Link to comment
Share on other sites

Hmm did Yealink change the behavior that the first occurrence of a setting is the one that will be used? If that is the case we will have to move the yealink-general to the bottom of the template. Or we just put it to the top and the bottom. Please make sure that you did not introduce a XML syntax error - then the whole file will not be accepted by the phone.

The voicemail depends on a system setting. The "Calling own extension number goes to mailbox" (in dom_mailbox.htm) controls that. By default this should be on - if you turned it off yes then it will cause that problem. I believe in the next version we should use *97 instead - we will change the template to make sure that this is not causing the problem again.



Link to comment
Share on other sites

as for modifying to *97 seems to me to be the most appropriate solution.

about the behavior of the template for Yealink should check it, maybe I'm wrong.
With 2 previous versions of Yealink it worked for me, with last fw it doesn't work.
Please copy me a couple of examples that you enter in "Yealink General"? I make a comparison with my template.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...