Jump to content

LTS version required


Recommended Posts

Hello,

I would like to give some feedback regarding quality assurance: it doesn't matter which release we use, each version contains a lot of bugs and if we move to a newer version as we get rid of some bugs, we're aware that we'll get new ones. Some examples:

In version 62.1 we had much problems with older snom 370 as the BLF did no longer work properly, so we had to update to 63.0.6. Using this version fixed the previous problem but auto provisioning of the snom D385 did no longer work. The next update to 64.0.3 fixed the problem with the D385 auto provisioning but now the phone LEDs for buttons configured with "agent login/logout" do no longer show the login status of the agent group (led is always off). I just tried to update to the new 64.0.4 but this does not fix the agent group led problem.

Despite from the above mentioned bugs there are a lot of other problems especially with the user GUI (e.g. configuring phone buttons where some of them are assigned from a template simply destroys the preconfigured buttons as template assigned buttons were shown in the user GUI as "not assigned").

It would be great if you could create a LTS stable release which does not get any new features or changes, just bug fixes until everything works properly and will be supported for some years. We do not need one new feature after the next one, we just need a stable PBX with no known bugs. We also do not want to report one bug after the next one, just to get new problems after the old one has been fixed.

Link to post
Share on other sites

Its a complex topic - one the one hand some customers want the latest and most productive features and we want to deliver them quickly. On the other hand many customers mostly want a 24/7 service with no surprises.

We don't require customers to update. That's in many cases best for everyone, even if there are known bugs customers can work around them. 

Some actually love to be on the latest and greatest. We try to set the expectations right that those versions are daily builds. This helps us a lot getting those versions tested much faster than this would be possible with automated tests. For example the topic with the agent login/logout was and still is tricky because we made some major changes underneath that we need for getting reporting up to speed. We have made more changes that brings the old login/logout experience back, however it is not in a release yet. It is in 64.1 but that is a daily build. 

We do entertain a few branches that someone became "LTS" versions - 57.3 is the only that is probably the most popular. With the newer versions we usually try to port the "good" bug fixes back into the branch. We did this e.g. with 64.0.1/2/3/4, 63.0.1/2/3/4/5 although I would not really call this LTS. I am not sure what branch would be a candidate for LTS like the 57.3 branch, especially because of all the new features coming up for the apps. Maybe 63.0 could be a candidate.

Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...