Jump to content
Musarano

WEBRTC Issue after upgrading to 65 version?

Recommended Posts

Hi.

Im sure i post this last week, but i cannot find it.  Or i though i did :)

The thing is that after that, or seems so, perhaps there where a chrome or any other update, but the WEBRTC has stopped from working.

There is an error popup window that comes up saying "media error" 

I have tried today, and its backonline.  I will be monitoring it, and keep you post it.

 

Thank You

-M

Share this post


Link to post
Share on other sites

We are trying also to use the Vodia App on IOS and issues with no voice either direction.  It seems fine on Android

We have only been trying on V65 so not sure.

The vodia has public IP connected direct so not a nat issue and as I say works fine with android and Chrome

Thanks in advance

Share this post


Link to post
Share on other sites

Hi Mal,

Regardless that i havent use the APP for any of the platforms, YET, i cannot be the best of assistance in this matter, YET :)

However, can you verify, if the Vodia APP, have the necessary permissions or allowances to use the internet?

Since you say, there is not audio comm in any direction, i presume you do have either access to it, or you might be using it on a intranet perhaps?

Another thing, have you tried a STUN or enabling NAT regardless ?

Are you using vodia as the PBX? (i know you said, that is working under android)

Can you try that?

If not resolves the issues, i will send you some URLs, or if i can imagine of another local(phone) possibility, will let you know.

Anything similar at the forums?

 

Thank You

Share this post


Link to post
Share on other sites
13 hours ago, Musarano said:

However, can you verify, if the Vodia APP, have the necessary permissions or allowances to use the internet?

Yes it does have all the  permissions. You also have to give it permissions on your cell phone.

And yes if you're using the PBX to work from behind a NAT / Firewall, please enable IP routing list and SIP IP replacement settings on the /reg_sipsettings.htm on the PBX (if it's not working be default for you).

Share this post


Link to post
Share on other sites

Hi,

Just noticed that if I do the IP routing list other SIP apps (my case Bria) stops working. For example in Bria in I go to call statistics  and the Peer IP is 0.0.0.0.

If I leave the IP routing list empty the app gets the peer IP correctly. 

We never used the IP routing list before. We started using it because we want to use the Vodia app.

Any suggestions?

Regards

Share this post


Link to post
Share on other sites

Please try to register your softphones by making changes to this setting: "Outbound proxy pattern" on /dom_settings.htm page on the PBX. 

You can click on "?" on that page (and on every other page for that matter) on PBX to know more about the setting.

Share this post


Link to post
Share on other sites

Hi,

 

Update: changing the SIP transport in Bria from automatic to TLS solves the problem. Automatic was defaulting to UDP. Tried manual UDP and TCP but no luck. Doesn't get that proper peer IP.

Ports are opened fine on the firewall.

Haven't tried yet the "Outbound proxy pattern" yet. Will try once the Covid-19 craziness settles down.

Regards

Share this post


Link to post
Share on other sites

Hi all

Many thanks for feedback

I have done some further investigation  with multiple users from various remote sites

Android devices - NO issue so far

Widow machine using Google Chrome web-rtc  No issue so far

IOS Ipad  using Vodia Phone APP  Can accept incoming calls however don't release properly - have to reset phone

Outbound calls connect but no voice either direction

IOS iPhone   using Vodia Phone APP  Can accept incoming calls however don't release properly - have to reset phone

Outbound calls connect but no voice either direction

Regards

Mal

Share this post


Link to post
Share on other sites

Hi all

I ran update again as suggested so now

Software version
65.0.1 (CentOS64)
Build date
Mar 31 2020 15:46:25
 
However IOS on iPhone  using the vodia Phone app is still the same
Incoming calls can answer and voice ok both directions
If make outbound call no voice in either direction
 
Other devices Android and Win10 webrtc are OK
 
As a side issue it took out password on email setup so emails stopped
 
Regards
Mal
 

Share this post


Link to post
Share on other sites

Thank you for the update.

Yes, please enter the password again in the email section and that should be out of your way.

Share this post


Link to post
Share on other sites

Hi all

Thanks for feedback

I am still having issues with IOS on both ipad and iphones

Have tried all above

IOS on iPhone  using the vodia Phone app is still the same
Incoming calls can answer and voice ok both directions
If make outbound call no voice in either direction
 
Have also tried on another system to see if issue just on that PBX
Still same issues
Note as mentioned previously  Android is fine and Windows PC with Vodia app or Chrome is fine
 
Regards
Mal
 

Share this post


Link to post
Share on other sites

For iOS there should be version 1.1 on the iPhone. There is an issue that the phone keeps ringing if it cannot connect to the PBX - the next version will automatically disconnect in that case. The iOS web socket subsystem seems to be a little bit wobbly - we need to better handle network problems.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...