Jump to content

Voicemail transcription not working


OND
 Share

Recommended Posts

  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

I ran that command, here's what it replied:

--2020-10-23 15:33:52--  ftp://https/speech.googleapis.com/v1/speech:recognize?key=AIzaSyD6XgI-eLss3oX3xl1cLSSUV6Nxg05jCXY
           => ‘.listing’
Resolving https (https)... failed: Name or service not known.
wget: unable to resolve host address ‘https’

Link to comment
Share on other sites

I ran it again without the https like this: 

wget speech.googleapis.com/v1/speech:recognize?key=AIzaSyD6XgI-eLss3oX3xl1cLSSUV6Nxg05jCXY

and it replied with this:

--2020-10-23 15:39:11-- http://speech.googleapis.com/v1/speech:recognize?key=AIzaSyD6XgI-eLss3oX3xl1cLSSUV6Nxg05jCXYResolving speech.googleapis.com (speech.googleapis.com)... 172.217.5.74, 172.217.11.74, 142.250.68.106, ...Connecting to speech.googleapis.com (speech.googleapis.com)|172.217.5.74|:80... connected.HTTP request sent, awaiting response... 404 Not Found2020-10-23 15:39:11 ERROR 404: Not Found.

Link to comment
Share on other sites

  • 2 months later...

I'm having this same issue hoping to add some input as well as help in getting a resolution. 

My System

  • Centos
  • Vodia 66.0.6
  • Hosted on Google Cloud Platform

What I tried:

  • The Cloud-speech-to-Text is enabled
  • I'm not restricting the API key till I get it working. I do however have it restricted to the Speech service. See below.
  • image.png.d93bbf28310f02c168bde93d2f0d62a2.png
  • Reloaded Certificates
  • Made sure the API was enabled properly on Vodia system.

Below is a log on the matter

image.thumb.png.8c08456ea8679d10a24170a1109d50fe.png

 

Link to comment
Share on other sites

1 hour ago, netbit Systems said:

What OS do you have it installed on? I was able to get to work on a system that was not hosted on Google platform. So the API is setup correctly. It's now between the OS on the instance or something goofy with Google platform.

I've got mine running on Debian64 on Google's cloud. I recently installed the a Single Tenant Vodia PBX on a customer's Windows PC at their request, I'm thinking I might try getting the transcriptions working on that to see if we can further narrow down the issue to the OS.

Link to comment
Share on other sites

Sounds good. Mine is a Centos8 (64) instance (I have two instances). The common thread aside from Google Platform is the Linux base. I will also note the system I tried on-prem was also Windows based running 66.0. I believe support is out on that license so I could not try 66.0.7 on it. However I loaded 66.0.7 on the Centos machines with no success. I also reverted to 66.0 per another suggestion but it had the same result. Lastly, I tried to contact Google Platform. It's not very good news. You have to pay extra to receive any kind of support (phone or chat) unless an error was thrown from Google Platform itself. The model is largely for developers and they are the ones to troubleshoot any problems. Based on the information I have gathered the OS is the next best thing to troubleshoot.

Link to comment
Share on other sites

I would really just pay attention to the web client log level 9 on the PBX, maybe also log level 9 for the TLS messages. Then it should become clear where the problem is. E.g. it took us also some time to figure out what needed to be enabled in the Google console to make this API work — it was helpful to see how many requests actually were received for the API Key. 

Link to comment
Share on other sites

  • 3 weeks later...

Hi, we have the same issue. Complete new installation on Ubuntu Server 20.04. We are comming form version 66.0.6 and I also tried with version 66.0.7. Same error: 

Quote

Certificate for speech.googleapis.com could not be verified

On google cloud console we only see a cryptic "compute" error when the vodia tries to access the API.

With level 9 we get this log:

[7] 21:05:50.673	https:speech.googleapis.com:443: DNS A returned 216.58.210.10ⓘ
[7] 21:05:50.673	https:speech.googleapis.com:443: Connect to 216.58.210.10ⓘ
[9] 21:05:50.677	https:speech.googleapis.com:443: Send request (158710 bytes)ⓘ
POST https://speech.googleapis.com/v1/speech:recognize?key=xxxxxxxxxxxx HTTP/1.1
Host: speech.googleapis.com
Content-Type: application/json; charset=utf-8"
Content-Length: 158527
{"config":{"encoding":"LINEAR16","sampleRateHertz":8000,"languageCode":"de-DE","maxAlternatives":1,"profanityFilter":true,"model":"phone_call","enableAutomaticPunctuation":true,"enableWordTimeOffsets":false},"audio":{"content":"xxxxxx}
[9] 21:05:50.677	Initialize TLS connectionⓘ
[9] 21:05:50.677	HTTP 216.58.210.10: Send Client Hello(03036009..00020017)ⓘ
[9] 21:05:50.690	HTTP 216.58.210.10: Receive Server Hello(03036009..00020100)ⓘ
[9] 21:05:50.690	HTTP 216.58.210.10: Receive Certificate(000B7500..9D9CF5CA)ⓘ
[9] 21:05:50.690	HTTP 216.58.210.10: Received chain with 2 certificatesⓘ
[4] 21:05:50.690	Unknown DSA hash algorithm 2A864886F70D01010Bⓘ
[5] 21:05:50.690	HTTP 216.58.210.10: Certificate for speech.googleapis.com could not be verifiedⓘ
[9] 21:05:50.690	HTTP 216.58.210.10: Send Alert(022e)ⓘ
[7] 21:05:50.694	https:speech.googleapis.com:443: TCP disconnectⓘ
[7] 21:05:50.694	https:speech.googleapis.com:443: Return code 500ⓘ
[8] 21:05:50.694	https:speech.googleapis.com:443: Return content (0 bytes)ⓘ
[7] 21:05:50.694	Transscript for 7s failed with code 500ⓘ
[7] 21:05:50.696	Closing connection https:speech.googleapis.com:443ⓘ

From the console (CURL) we can communicate with the API without an issue.

Looks like google implemented ECC certificates and Vodia can't handle the new encyption algorithms of curves.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share




×
×
  • Create New...