Jump to content

QR code stopped working


Lyndon
 Share

Recommended Posts

Tried to scan a QR code but it doesn't work. I'm just taken back to the previous screen that displays the URL field, "Connect" and "Scan QR" buttons. It used to work...?

Tried closing and re-opening the app, no difference.

Tried clearing app data, no difference.

Tried restarting the mobile, no difference.

Tried QR code in user portal and admin console, no difference.

Scanned the QR code with lens which displays URL, user and pass parameters - all seem correct, obviously can't confirm the password as it's hashed.

Link to comment
Share on other sites

I let some time pass then tried to scan a QR code from a different PBX and extension which worked. I then logged out and scanned the QR code for the original extension I was trying to scan earlier and it worked....?

Link to comment
Share on other sites

I've had a lot of issues with the QR code especially with iOS. The one in the user portal almost always works, the one in the management console usually works and the one in the email never works.

Similar for Android in that the email almost never works and the others as above. Really annoying for customers as we always have to direct them to the web portal as the easier one, in the email, is so flaky

Link to comment
Share on other sites

The problem for the PBX is to tell what URL to use. When you are logging in with the browser, the PBX says "oh good, this one is able to see my page so lets use that page". If you are logged in with HTTPS well then that's a good sign. Even when you trigger sending out an email from the web interface, the PBX tries to use the address that you entered in your browser to generate the URL. So the bottom line is, don't log in with the IP address in your browser or an insecure connection. Needless to say, make sure that the domain has the green lock symbol indicating that the browser thinks that the connection is secure—that usually means that the app also believes it is secure. iOS and Android are these days very rejective to insecure connections.

Link to comment
Share on other sites

I think that maybe it. If I display for QR code via http:// it doesn't work. If I display QR code via https:// it works.

For overall security, wouldn't it be a good idea to redirect all http to https, or at least have a setting that does this that you can either enable or disable?

Link to comment
Share on other sites

Excellent, or so I thought...

I have HTTP set to 80, HTTPS set to 443

Redirect to HTTPS was set to 'Automatic' - so would assume that means enabled, opposed to disabled. Changed to 'On' so there is no guessing, saved settings. Browsed to http:// and don't get redirected?

Does this change require a server restart and what does 'Automatic' mean in this sense?

Link to comment
Share on other sites

Its complicated. Keep in mind that many installations are still on premise where there is no (real) HTTPS. "Automatic" will check if there is a certificate for a domain or the server management address, and it that is the case it will do the redirect. If you are running the PBX on a public IP, you might want to rename (or just remove it) the localhost domain so that the PBX knows it has not to serve all incoming requests, which is another challenge for presenting a valid certificate.

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...