Jump to content

Zoho Integration is not working


A_nd_y
 Share

Recommended Posts

Hello,

we are trying to get the Zoho integration to work with our PBX installation. Unfortunately the integration is only half working. But first, some info about the setup:

We are using PBX version 67.0.5 on premise.
The system is running with a static public IP and has the following firewall rules for incoming connections:
5060 TCP
5060 UDP
5061 TCP
15000-30000 UDP
443 TCP
Outgoing connections are not restricted.

The Auth Token has been set up in Zoho and it is also possible to start a call from within Zoho.
But Zoho gets stuck in the connecting state:

grafik.png.77b89e0e46467d64bf590866bfbe8337.png

However, the telephony connection is established.
Incoming connections are not displayed in Zoho at all.

What is going wrong here?
Is there a firewall configuration missing?
Where can I find helpful information (Logfiles etc.)?

For help I would be really grateful

Best regards

A_nd_y

Link to comment
Share on other sites

  • A_nd_y changed the title to Zoho Integration is not working

Thanks for the answer!
With these instructions I have set up the interface.
But unfortunately I do not really get on with this.

There are currently no IP restrictions set up in the firewall.
For testing purposes any IP is allowed to access the system.

Unfortunately, the instructions do not mention how the interface works, what ports and protocols are used.
This makes it very difficult for me to debug the behavior.

Are port forwardings simply missing here in the firewall?

Link to comment
Share on other sites

The ports that you mentioned should be the only ones needed for the integration, but just to confirm, you turned on the Zoho integration from under /dom_crm.htm and then from under the user portal correct?

Both had a green check mark next to it? If yes, then from the PBX's end the integration was done. 

You can then turn on the admin level logs for , "trunks", "CRM Related events" and "call messages" to the highest and make the call and see if there are any PBX related issues.

Link to comment
Share on other sites

I think we are approaching the problem:

When I enable Zoho support on the /dom_crm.htm page, the red x turns into a green check mark. When I reload the page, there is a red x again.

Also, I can't find the "CRM related events" in the log settings:

grafik.thumb.png.c5f777e774e2cd12f1b0079748371ca8.png

Link to comment
Share on other sites

2 minutes ago, A_nd_y said:

When I enable Zoho support on the /dom_crm.htm page, the red x turns into a green check mark. When I reload the page, there is a red x again

That seems to be the problem. Please try to upgrade to 67.0.5 once again and then try the above steps.

Then turn on the necessary logs and try again.

Link to comment
Share on other sites

OK, now the check mark and dom_crm.htm is always set.
But unfortunately Zoho integration still does not work.

The "CRM related events" are still not visible in the log settings.
With these log settings I don't see any output related to Zoho:

grafik.thumb.png.f7983a91bf3dc1f370a4c226e86f3b61.png

Link to comment
Share on other sites

If both of those check marks are seen, then you need to just follow ahead with the documentation.

When you go to the user portal > CRM > Zoho > Get auth code, do you see another window pop up which needs your Zoho account's login?

If yes, that's all that's needed from Vodia's end. If not, then that's what you have to look further into.

Your login creds might be wrong on there?

Link to comment
Share on other sites

I have done everything described in the instructions but unfortunately it just does not work properly. The link with Zoho is done, theuser  auth code is generated, the user credentials for Zoho are also correct.
But it just does not work properly.

Apparently something is not right on the pbx side.
I don't see any log output which has to do with the CRM integration.

 

Unfortunately I can't post any more screenshots here to prove the points

-> Attachment Quota limit

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...