Jump to content

Email Notifications fail with SSL/TLS


jawaid
 Share

Recommended Posts

I have just moved my email hosting to another provider, and setup the relevant settings, but when I try to send a test email, using port 465 it fails with handshake error.

I have used the exact same settings, on my email client and am able to send emails fine. I think the issue might be the Root CA. 

Any advise please? 

I have 

Link to comment
Share on other sites

On 1/9/2022 at 7:03 AM, jawaid said:

I think the issue might be the Root CA. 

If that is the case, please reset the certificates and also try to generate new LE certs for the domains that have expired certs on them. And recreate the cert by turning off and on of the ACME Let's encrypt (LE) setting.

Link to comment
Share on other sites

The email logging either gives a handshake error staight off, or at the end, when it seems that the message has been sent to the email server.

This is on a multi-tenant system which is on v67.0.5, there weren't any changes done with regards to TLS, between this version and the latest stable version available (v68.0.4)?

I haven't updated the tenant system yet, as some changes were done on v68.0.7-beta that I need, so just waiting for a stable v68.0.7 or later to be made available.

 

Link to comment
Share on other sites

  • 2 weeks later...

Seems that it breaks with the STARTTLS. That means the switch from plain text to TLS fails. You could try to use TLS right from the beginning (avoid STARTTLS), maybe you'll have go to an encrypted port. In that case I would turn the TLS log level also to 9 and see what messages are being send and received.

Link to comment
Share on other sites

That means that the issue has been fixed in v68.x as on my test v68.0.7.beta it all works fine, and the settings are exactly the same. Just waiting for a stable release of v68.0.7 or later, before upgrading the customer system. Do you know how long it will be before the release? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...