Jump to content
Vodia PBX forum
Sign in to follow this  
Michaelp

Exchange UM Integration

Recommended Posts

I have followed the instructions to setup Exchange UM, but UM does not answer on a ring no answer. I am using an ITSP (callcentric) with inbound calling only. Can someone please help?

 

Please note that inbound calls do ring my extension - so I know the PBX is working. It's just the voicemail piece that I am having trouble with.

 

Thanks, Michael

Share this post


Link to post
Share on other sites
Just log the traffic to the IP address of the Exchange server. Settings->Logging->Log Watch List (IP), see http://wiki.pbxnsip.com/index.php/Log_Setup.

 

After some more investigation, my tech uncovered this information:

 

I just took a look. The problem is you are using UDP vs. TCP. Exchange only supports SIP over TCP.

 

Sample frame:

 

Frame 39 (853 bytes on wire, 853 bytes captured)

Ethernet II, Src: Buffalo_ae:ed:5a (00:0d:0b:ae:ed:5a), Dst: Vmware_65:98:0b (00:0c:29:65:98:0b)

Internet Protocol, Src: 204.11.192.22 (204.11.192.22), Dst: 192.168.11.6 (192.168.11.6)

User Datagram Protocol, Src Port: 5060 (5060), Dst Port: 5060 (5060)

Session Initiation Protocol

 

How do we make pbxnsip communicate over TCP?

 

Please advise.

Share this post


Link to post
Share on other sites

Did you check out http://wiki.pbxnsip.com/index.php/Microsoft_Exchange? The trick is to use "transport=tcp", search on that page for this string and you will see where it needs to be done. Also, we found out that on Vista, you need to disable some Microsoft TCP optimization, there was a discussion about this today already.

Share this post


Link to post
Share on other sites
Did you check out http://wiki.pbxnsip.com/index.php/Microsoft_Exchange? The trick is to use "transport=tcp", search on that page for this string and you will see where it needs to be done. Also, we found out that on Vista, you need to disable some Microsoft TCP optimization, there was a discussion about this today already.

 

I am not running Vista. I am running pbxnsip in a virtual machine in Vmware Server which runs on Windows Server 2003. I have another virtual machine running Exchange 2007.

 

As for the string it was configured exactly as your config note describes so that's not the issue.

 

Where do I go from here?

Share this post


Link to post
Share on other sites

:-S my recommendation would be to start with a simple setup - no virtual machines. Keep in mind that the PBX needs to run threads with very high priority, otherwise you will get significant jitter and bad audio quality. Maybe you have somewhere a laptop that you can use for the PBX and verify that it works from there. Then if that works you can change the setup.

Share this post


Link to post
Share on other sites
:-S my recommendation would be to start with a simple setup - no virtual machines. Keep in mind that the PBX needs to run threads with very high priority, otherwise you will get significant jitter and bad audio quality. Maybe you have somewhere a laptop that you can use for the PBX and verify that it works from there. Then if that works you can change the setup.

 

What do you think of installing pbxnsip on the Exchange 2007 Server, obviously this runs on Windows Server 2003, I only use Server products for production services, not workstation software (Windows XP). I would run both systems on the physical server - no VMware.

 

What do you think of this proposed configuration? Would this work? What do you recommend?

 

Please advise.

 

Thanks. Michael

Share this post


Link to post
Share on other sites

That sounds at least easier. And it should be possible (the routing on the PBX is intelligent enough to deal with this case), however I have no experience with that.

 

However, for the sake of getting things working, I would still first try the standard setup which is a seperate server for both services. Then as a 2nd step I would move the ttwo services to one server.

Share this post


Link to post
Share on other sites
That sounds at least easier. And it should be possible (the routing on the PBX is intelligent enough to deal with this case), however I have no experience with that.

 

However, for the sake of getting things working, I would still first try the standard setup which is a seperate server for both services. Then as a 2nd step I would move the ttwo services to one server.

 

OK, I have followed your advise and have reinstalled Exchange 2007 and PBXNSIP on two separate servers. I can place inbound and outbound calls through my ITSP (Callcentric). However, on a ring no answer the external caller is disconnected without ever being transferred to the mailbox on the Exchange Server.

 

So I am right back to where I was before. Where do we go from here? Are they any logs you want to see? Have you been able to get this working? I hope we can resolve this soon. Please advise, Michael

Share this post


Link to post
Share on other sites
Guest Paul McCabe
I have followed the instructions to setup Exchange UM, but UM does not answer on a ring no answer. I am using an ITSP (callcentric) with inbound calling only. Can someone please help?

 

Please note that inbound calls do ring my extension - so I know the PBX is working. It's just the voicemail piece that I am having trouble with.

 

Thanks, Michael

 

Michael,

 

Please forward your contact info to sales@pbxnsip.com so we can touch base with you...

 

pbxnsip

Share this post


Link to post
Share on other sites
Michael,

 

Please forward your contact info to sales@pbxnsip.com so we can touch base with you...

 

pbxnsip

 

Thanks. I have emailed my contact info. Michael

Share this post


Link to post
Share on other sites
Thanks. I have emailed my contact info. Michael

 

 

did you get a solution to this?

 

i wish to call my speech server and it has the same issues with SIP and TCP i would love to be able to call my speech server through a PBX.

Share this post


Link to post
Share on other sites

Has anyone else gotten pbxnsip to work with Microsoft Speech Server 2007? I am trying to set it up as an extension but the pbx is not even attempting to forward the call. It just rings, rings, and eventually hangs up. Can anyone help me with this? I will be an extremely loyal customer to pbxnsip if we get this working! I haven't found anything else that will work for me. Thanks!

 

E-mail Daniel@lyntonweb.com

Share this post


Link to post
Share on other sites

I am encountering an issue with the "Play on Phone" feature of Exchange UM.

 

Using Outlook web access or Outlook 2007, you have the option of playing an incoming voicemail on a specified phone -- using the play on phone feature. So, if you need to listen to the message privately (in our case, for example, in front of customers at a retail pharmacy), you can click 'play on phone', pop in a number to dial, pick up the phone, and listen to the message.

 

It works perfectly when I put in a 9 + my extension's 10-digit local number alias (9xxxxxxxxxx) that ends up back into PBXnSIP. It works fine when I put my cell number in as well.

 

It doesn't work when I put in my extension, but it wants to. When I type in my extension and click Dial, my phone doesn?t ring, but one of my lines appears differently.

HPIM0022.jpg

When I hit that line to see if I can pick up the call, I just get dial tone as if I?m trying to place a new call.

 

Looking at the logs, it looks like the call is going straight to voicemail without ringing my phone.

 

[6] 2007/09/12 12:42:10: Sending RTP to local.server.ip:39706

[7] 2007/09/12 12:42:10: Calling extension 2412

[6] 2007/09/12 12:42:10: Redirecting to external voicemail account 2412 destination sip:72412@servername.ourdomain.com

 

Any ideas?

 

Although this is my first post on the forum, I've been working with Model12 on our setup for a few months now and worked with Paul in support on a separate UM issue, so I'm not completely green. :)

 

Thanks for your input,

Sean

Share this post


Link to post
Share on other sites
I guess the problem is that the calls from the Exchange trunk have to run through a dial plan. Maybe you can add "Call Extension" to the dial plan?

 

You are correct, sir.

 

I need to go back and refresh my understanding of dial plans from the doc, but I added a Call Extension trunk with pattern 2* -> 2* with lower priority than the other rules and Play on Phone is completely happy now.

 

Thank you!

 

Have a great weekend.

Share this post


Link to post
Share on other sites

Hello.

I too seem to have a problem , though a different one.

I can't transfer a "play-on-phone" from the exchange to my extension (300) , but i can transfer it to any other extension. If i try to transfer it to 300 , it gets redirected to the mailbox.

Can anyone help me with this odd behavior? thank you!

Share this post


Link to post
Share on other sites

Hello Idti,

 

got the same problem here. I guess if Exchange is calling your extension, for pbxnsip it looks like you want to call pbxnsip for a notice-recording (dictat for yourself). This redirects the call to the voicemail system, in our case Exchange 2007 :(

 

My Workaround:

 

my extension = 18 created an related alias +493039978418 to it.

 

Now I am using not the 18 in Exchange Play on Phone, I use the alias +493039978418

 

A possible improvement for pbxnsip: If pbxnsip differentiate between a Call from the Exchange Trunk to & from the own user extension and a Call from a sip-phone...

 

Best regards and good luck,

 

Jan Boguslawski

 

 

Jan Boguslawski

Consultant IT Infrastructure

MCSE

 

Telefon: +49 30 399 784-0

 

ITaCS GmbH

Friedrichstra?e 121

10117 Berlin

www.itacs.de

Share this post


Link to post
Share on other sites

Same problem here, fwiw.

 

If a user tries to "Play on Phone" to their own phone, it goes straight to voicemail, but if they "Play on Phone" to another extension, it works just fine.

 

I was going to wait until the new polycom firmware configs came out before taking a closer look at any of our issues, but I just happened upon this thread.

Share this post


Link to post
Share on other sites

I feel like the Wiki is missing a few steps at the very least...

 

I'm not using any prefixes or anything in my lab. Just 3 digit numbers. I have the integration with OCS and PBXnSIP working perfectly (well, almost - if I call from a phone to a user, Office Communicator doesn't seem to resolve the name properly, but I can live with that for now).

 

I followed the UM wiki, and I have verified Exchange can contact the gateway by using the test-umconnectivity commandlet so that it rings a phone, but I didn't see any info on how to configure the auto-attendant. I associated a number with the attendant on the Exchange side, but what needs to be done on the pbxnsip side? Do I need to create an account for that number? Add a sip registration for it?

 

How do I configure pbxnsip to send all voicemail requests to Exchange? I entered 200 (the number I associated with the attendant on Exchange) as the redirection target.

 

Right now all I get when I try to dial that number is "Destination not found"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...