Jump to content

Registration expiration timer


jlumby
 Share

Recommended Posts

I am doing some testing with 2 PBXnSIP servers, using one as a trunk server (hosting PBXes register to it as extensions), and the second as the hosting server. This is a fully demo enviornment running 3 minute keys. I have set the hosting server to register it's trunk to the trunk server as an extension. The problem is no matter what I set the trunk's Proposed Duration or Keepalive Time to, on the trunk server that it is registering to, I see the registration expiration timer start at 45 seconds, and count down. This is fine if the Proposed Duration and Keepalive Time are less than 45 seconds, however if they are set to more, then it looses it's registration. The trunk server is on the same subnet, and I cannot figure out where it is getting the 45 seconds from. I checked on the settings tab, and none of the timers are set to 45 seconds, the pbx.xml does not have a 45 anywhere in it. I have tried changing the register_via_count from true to false, and nothing seems to have any effect. I am running 3.1.1.3100 I have seen this same issue with a QuickPhones wireless SIP phone, however I wrote it off as a compatibility issue. I am now surprised to see it in this situation since both client, and server are PBXnSIP

Link to comment
Share on other sites

I am doing some testing with 2 PBXnSIP servers, using one as a trunk server (hosting PBXes register to it as extensions), and the second as the hosting server. This is a fully demo enviornment running 3 minute keys. I have set the hosting server to register it's trunk to the trunk server as an extension. The problem is no matter what I set the trunk's Proposed Duration or Keepalive Time to, on the trunk server that it is registering to, I see the registration expiration timer start at 45 seconds, and count down. This is fine if the Proposed Duration and Keepalive Time are less than 45 seconds, however if they are set to more, then it looses it's registration. The trunk server is on the same subnet, and I cannot figure out where it is getting the 45 seconds from. I checked on the settings tab, and none of the timers are set to 45 seconds, the pbx.xml does not have a 45 anywhere in it. I have tried changing the register_via_count from true to false, and nothing seems to have any effect. I am running 3.1.1.3100 I have seen this same issue with a QuickPhones wireless SIP phone, however I wrote it off as a compatibility issue. I am now surprised to see it in this situation since both client, and server are PBXnSIP

 

As for the registrations between the PBXes - that problem should disappear with your next upgrade, as both sides should support "outbound".

 

The 45 seconds are probably half of 90 seconds. What time do you see in the contact header of the registration reply? It is probably 90 seconds? Then you will find that number in the settings of the admin mode.

Link to comment
Share on other sites

  • 3 months later...
As for the registrations between the PBXes - that problem should disappear with your next upgrade, as both sides should support "outbound".

 

The 45 seconds are probably half of 90 seconds. What time do you see in the contact header of the registration reply? It is probably 90 seconds? Then you will find that number in the settings of the admin mode.

 

This problem has not disappeared in the multiple versions that have come out since. Any updates? I am currently at 3.3.0.3165 Win32

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...