Jump to content

Snom PnP


shopcomputer
 Share

Recommended Posts

I have a new client, using Snom300 with the latest version.

PNP is not working.

I enabled dhcp option 66

I tried putting the manual PNP method, putting the PNP URL into the phone.

Here is the log of the phone.

[6]24/12/2001 00:00:11: I take GUI language English from: /mnt/snomlang/gui_lang_EN.xml

[6]24/12/2001 00:00:12: I take WEB language English from: /mnt/snomlang/web_lang_EN.xml

[5]24/12/2001 00:00:12: read_xml_settings: found dial-plan XML header

[9]24/12/2001 00:00:20: initiate_pnp_settings[8]24/12/2001 00:00:20: Random Seed: 3816301798

[8]24/12/2001 00:00:20: Connect host: 127.0.0.1

[5]24/12/2001 00:00:20: Fetching URL: https://192.168.40.1:443/provisioning/snom3...0041328B37E.htm

[8]24/12/2001 00:00:20: route_pending_packet 1000000: entry=url udp 192.168.40.1:5060

[8]24/12/2001 00:00:20: route_pending_packet 1000000: entry=udp 192.168.40.1 5060

[8]24/12/2001 00:00:20: Send Packet 200

[7]24/12/2001 00:00:51: Conf setup: finished false: code: 500, host: 192.168.40.1:443, file: /provisioning/snom300-00041328B37E.htm

[5]24/12/2001 00:00:51: Fetching URL: http://127.0.0.1/dummy.htm

[7]24/12/2001 00:00:51: Conf setup: all setting urls attempted

[7]24/12/2001 00:00:51: Conf setup: finished false: code: 500, host: 127.0.0.1:80, file: /dummy.htm

[7]24/12/2001 00:00:51: Conf setup: finished true

[5]24/12/2001 00:00:51: Fetching FW URL: http://192.168.40.1/snom300/snom300-firmware.htm

[6]24/12/2001 00:00:51: WEBSV: init() is_initialised: 0

[6]24/12/2001 00:00:51: WEBSV: Close port 0

[6]24/12/2001 00:00:51: WEBSV: Open port 80

[6]24/12/2001 00:00:51: WEBSV: Close port 0

[6]24/12/2001 00:00:51: WEBSV: Open port 443

[5]24/12/2001 00:00:52: read_xml_settings: found phone-book XML header

[6]24/12/2001 00:00:52: I take GUI language English from: /mnt/snomlang/gui_lang_EN.xml

[6]24/12/2001 00:00:52: I take WEB language English from: /mnt/snomlang/web_lang_EN.xml

[6]24/12/2001 00:00:53: RE dialplan initialized

[5]24/12/2001 00:00:53: Opening TCP socket on port 80

[5]24/12/2001 00:00:53: Opening TCP socket on port 443

Link to comment
Share on other sites

I have a new client, using Snom300 with the latest version.

PNP is not working.

I enabled dhcp option 66

I tried putting the manual PNP method, putting the PNP URL into the phone.

Here is the log of the phone.

 

Check out http://wiki.pbxnsip.com/index.php/Snom. Probably the problem is that you either need to provide a password for the phone to get the configuration data or turn the HTTP challenging off (thats in the Ports section of the admin settings, at the bottom).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...