Jump to content


Recommended Posts

Hello all, i have my SMS gateway provider that expects to receive a HTTP GET request like;


I already have parameters needed to send the message.I mean the PORT Number, my USER Account, my Password , And Static SENDERID.

I am using the Vodia PBX VERSION 68.0.30

My question is how can i use all those information to send message in VODIA PBX.

When I select HTTP GET I am asked for Username or account & Application secret.

I read in this forum that the username or account is used for the URL and the Application secret for the password.But i can understand very well.

Someone can tell me exactly what i am suppose tu put in username in this case? What about password? is it necessary to remove it in http://smsgw.gtsnetwork.cloud:PORT/message?user=USER&pass=PASSWORD&from=SENDERID&to=RECIPIENT&tag=GSM&text=MsgBoby&id=ID&dlrreq=DLR  and put it separetly in application secret? Please need your help.

See below a post that i first read.

Best regards

Link to comment
Share on other sites

Hello All, 

I still have the problem to use my sms gateway.Maybe my config is wrong.

See the HTTP Request that my provider send to me for API


The provider send me also 4 parameters to connect (see below "example of parameters that he send me" :  


Username : aurelien 

Password : sms2023

Port : 5070

Static SENDERID : 697677876

Now see how i use it in VODIA PBX :

Provider : HTTP GET

USERNAME OR ACCOUNT http://smsgw.gtsnetwork.cloud:PORT/message?user=aurelien&pass=sms2023&from=697677876&to={to}&tag=GSM&text={MsgBoby}&id=ID&dlrreq=DLR


My config is good? please need your help

PS: I have no information about HTTP Request in my logfile

Best Regards



Link to comment
Share on other sites

I assume these are not the real passwords... Anyhow you should see an error message like this on log live 4 for script:

Unknown parameter ... for converting SMS URL, known parameters are:
 - {body}: The content of the message
 - {url}: A link to the message that is sent out (e.g. image)
 - {password}: The password for the provider
 - {param1}: General parameter 1 for the tenant
 - {param2}: General parameter 2 for the tenant
 - {param3}: General parameter 3 for the tenant
 - {address}: Primary tenant DNS address
 - {from}: The sender phone number in global format
 - {from-e164}: The sender phone number in E164 format
 - {to}: The receiver phone number in global format
 - {to-e164}: The receiver phone number in E164 format

So it could look like:


Please check what the ID and DLR values are for—you might have to replace them as well. Also, it is the best to have it working first with curl before putting this into your PBX.

Link to comment
Share on other sites

Thank for your reply.

After modify http url with good parameter i have this message when going to logfile for script


[8] 12:48:14.231

SMS not enabled by default (setting=, default=true)ⓘ

But i'm surprise about the message because SMS is ENABLED by default (see the screenshot).

There is order thing to do ?

Best Regards


Screen vodia SMS.png

Link to comment
Share on other sites

Hello, yes the provider gives me an example number. This is exactly how I format the number on my end.

Example: 23769XXXXXXX (But I don't think that's the problem).
While chatting with my provider and after troubleshooting, he told me that my message could not be delivered because it came with 2 (two) bad values which are to={to} and text={body}. Normally I am supposed to send it the exact values corresponding to the receiver number {to} and the message content {body}. But this is not the case. Instead it receives to={to} and text={body }

See below the sreenshot that provider send me :



Link to comment
Share on other sites

yes that is exactly the problem that i have.

{to} is suppose to be the real number to send the sms.

i think when i use this url (example) in HTTP GET http://smsgw.gtsnetwork.cloud:5017/message?user=aurelien&pass={password}&from=697677876&to={to}&tag=GSM&text={body}&id=200000&dlrreq=1

When sending sms in webclient account {to} is suppose to take automatically the number value that i put.Example : when sending message to 237694567865, to=237694567865 .

Not so ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...