Jump to content

Filter packets from Registrar [filter_registrar]


hosted
 Share

Recommended Posts

In the PNP how do I turn this value to OFF?

 

 

Filter packets from Registrar [filter_registrar]

 

I dont know if this is a firmware (7.3) issue or not. BUT when I set the snom transport = udp

I start getting 403 Use Proxy from the snom phone because of this setting. Which doesn't make sense because the proxy i sending the RTP.

 

Also when I use udp, the check-sync button doesnt work.... is this a tls feature only?

 

This was a disaster for me today. :blink:

Link to comment
Share on other sites

In the PNP how do I turn this value to OFF?

 

Filter packets from Registrar [filter_registrar]

 

I dont know if this is a firmware (7.3) issue or not. BUT when I set the snom transport = udp

I start getting 403 Use Proxy from the snom phone because of this setting. Which doesn't make sense because the proxy i sending the RTP.

 

Also when I use udp, the check-sync button doesnt work.... is this a tls feature only?

 

Well this setting is not touched by the PnP mechanism. The meaning is that the phone does not accept traffic from any other source than the PBX (which makes sense). But you should be able to change this setting if you like. Check the generated directory, there you should not see this setting.

Link to comment
Share on other sites

is there any way to add this to PNP by manually editing a file? I would prefer to use UDP so my edgemarc's can monitor the MOS score. but doing that means I have to change on a phone by phone basis, not good.

 

also, why doesn't the check-sync work with a snom in udp mode?

 

Funny thing is the RTP traffic was in deed coming outbound proxy IP, BUT the phone is on a different domain and the calls rejected on the snom. i think this setting might be bad or wrong.. there isnt a reason the phone should give me that error message.

Link to comment
Share on other sites

is there any way to add this to PNP by manually editing a file? I would prefer to use UDP so my edgemarc's can monitor the MOS score. but doing that means I have to change on a phone by phone basis, not good.

 

also, why doesn't the check-sync work with a snom in udp mode?

 

Funny thing is the RTP traffic was in deed coming outbound proxy IP, BUT the phone is on a different domain and the calls rejected on the snom. i think this setting might be bad or wrong.. there isnt a reason the phone should give me that error message.

 

In 3.1, we included another setting file that you can edit manually in the html directory: snom_3xx_custom.xml. There you can set whatever setting you like. It is loaded last, so it will overwrite the provisioned settings. Check the snom_3xx.xml file in the generated directory, then you get the idea.

 

I guess snom does not trust UDP very much. Every "idiot" in the network can send UDP packets, and having the phone reboot because a funny guy wants to boot all phones is not very productive work.

Link to comment
Share on other sites

In 3.1, we included another setting file that you can edit manually in the html directory: snom_3xx_custom.xml. There you can set whatever setting you like. It is loaded last, so it will overwrite the provisioned settings. Check the snom_3xx.xml file in the generated directory, then you get the idea.

 

I guess snom does not trust UDP very much. Every "idiot" in the network can send UDP packets, and having the phone reboot because a funny guy wants to boot all phones is not very productive work.

 

Its a cool feature, but it doesnt seem to work in multi-domain environments. and i cant roll to 3.1 until the key system emulation is fixed. heh

Link to comment
Share on other sites

So I manually set the phone to not filter and reboot the phone and the PnP setting overwrites it.. so there has to be a setting in the PnP I can modify..!?

 

Just add a file named "snom_3xx_custom.xml" into the html directory with the following content:

 

<?xml version="1.0" encoding="utf-8"?>
<phone-settings>
 <filter_registrar>off</filter_registrar>
</phone-settings>

 

That will provision this setting in addition to the settings that are already automatically provisioned.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...