Jump to content

Can't dial LD - getting "You must first dial a one..."


Charlie
 Share

Recommended Posts

I have deployed a CS410 appliance to an office here in the US which connects to the PSTN through POTS lines. They can dial out locally just fine. Every time they dial LD, however, they get the operator tones and the message "you must first dial a one."

 

Their carrier is Integra Telecom. If I watch the log from the web interface I see the numbers being dialed out, but the one never shows. Just the 10 digit number.

 

I have the Rewrite Global Numbers set to Check domain country code (which is set to 1).

 

We're running version 3.1.2.3120, though I'm upgrading it to the latest right now...

 

It's a pretty vanilla installation...haven't changed anything I haven't had to. Most settings are at defaults.

 

Any thoughts/ideas? I'm guessing this is an easy fix for someone more expert in this than I am.

 

Thanks!

 

-Charlie

Link to comment
Share on other sites

FWIW downgrading to 3.0.1.3023 fixed the problem.

 

I'd still like to know what the deal-e-o is so I could be running the newer software, but for now all is well...

 

Oh, in the 3.2 version the trunk actually has a setting for this. The "11-digit" representation is probably what you are looking for. You can also solve the problem in the dialplan with a replacement of "1*" (if you have no country code set on the domain level).

Link to comment
Share on other sites

Thanks for your response.

 

I thought the 11-digit would fix it, but it made no difference...

 

As for the dialplan, I had the country code set to 1. The users were dialing 1 (then AC & local number). Still got the message. I guess I could try adding the 1 (1*), but if they're already dialing it, and the dialplan is * * shouldn't it get through?

Link to comment
Share on other sites

I thought the 11-digit would fix it, but it made no difference...

 

As for the dialplan, I had the country code set to 1. The users were dialing 1 (then AC & local number). Still got the message. I guess I could try adding the 1 (1*), but if they're already dialing it, and the dialplan is * * shouldn't it get through?

 

It is strange. Maybe we can "catch" the situation also here in our test system.

Link to comment
Share on other sites

The problem is we dial 7 digits for local call (until next month).

 

So if you call 234-5555 the PBX sends the call at 18012345555 which wont work.

or you can change it to 8012345555 which technically.

 

but you can not send 7 digits down the FXO ports.

 

local carrier if you dial 18015551212 will just play a message "its is not nessesary to dial a 1 before this number"

 

so basically CS410 units are stuck at 3.0.1

Link to comment
Share on other sites

  • 5 months later...

I have exactly the same problem.

 

CS410 (3.4.0.3201 (Linux)) and whenever making a call over the PSTN , the box will not dial the one.

 

I have put a butt set (test set) on the line and confirmed that the system is sending only the area code and number.

 

We are in California where every call must be 11 digits.

 

Here is log:

 

[5] 2009/07/15 18:34:00: Dialplan Default Dialplan: Match 912136181000@sip.scrumption.com to <sip:12136181000@127.0.0.1;user=phone> on trunk PSTN Gateway

 

Note that the PBX is sending eleven digits to the internal SIP adapter and that's where it seems to be stripped. I think this is unique to the CS410's internal adapter.

Link to comment
Share on other sites

I have exactly the same problem.

 

CS410 (3.4.0.3201 (Linux)) and whenever making a call over the PSTN , the box will not dial the one.

 

I have put a butt set (test set) on the line and confirmed that the system is sending only the area code and number.

 

We are in California where every call must be 11 digits.

 

Here is log:

 

[5] 2009/07/15 18:34:00: Dialplan Default Dialplan: Match 912136181000@sip.scrumption.com to <sip:12136181000@127.0.0.1;user=phone> on trunk PSTN Gateway

 

Note that the PBX is sending eleven digits to the internal SIP adapter and that's where it seems to be stripped. I think this is unique to the CS410's internal adapter.

 

No the SIP gateway is pretty dumb when it comes to digits. If you give it 11 digits then it dials 11 digits. The gateway waits some time before actually dialling the number.

 

Regarding dial tone detection. Can you log in and check out the file /etc/sipfxo.conf? There can be a line with the following content: PSTNGW_DETECT_DIAL=1. Then the gateway will wait for the dial tone before starting to dial. P.S.: Don't hit the save button on the web interface on the FXO settings after this change, or at least make a backup of the file...

Link to comment
Share on other sites

No the SIP gateway is pretty dumb when it comes to digits. If you give it 11 digits then it dials 11 digits. The gateway waits some time before actually dialling the number.

 

Regarding dial tone detection. Can you log in and check out the file /etc/sipfxo.conf? There can be a line with the following content: PSTNGW_DETECT_DIAL=1. Then the gateway will wait for the dial tone before starting to dial. P.S.: Don't hit the save button on the web interface on the FXO settings after this change, or at least make a backup of the file...

 

Fair enough, but this is hanging off an AT&T 5ESS and dial tone is instant, but I did what you requested above and got the same result.

 

Again, my analysis points to your SIP gateway. Log files show that 11 digits are sent and it is stripping off the one when outputting DTMF on the line. I monitored what was sent using a decoder clipped onto the POTS (fx) line.

 

I bet there can be a setting in sipfxo.conf that will control this behavior, but the default is floating back and forth in your units because it is not being explcitly set. Can you please check this?

 

Tests

 

If I send twelve digits by adding an extra 1 at the beginning (112136181000@127.0.0.1) the gateway outputs ALL TWELVE DIGITS!

 

If I send 12 digits by adding an extra 0 at the end (121361810000@127.0.0.1), we also get all twelve digits, but the call goes through because the phone company ignores the last digit. This gives us a workaround:

 

WORKAROUND

 

I like to set up dial 9 for outgoing calls as it gives more control and most UScustomers are used to it.

 

IN DIAL PLANS

 

TRUNK: PSTN gateway

PATTERN: 9*

REPLACEMENT: *0

 

This adds an extra digit (0) at the end of the dial string which tricks the gateway into dialing the leading 1. The phone company will ignore the last digit.

 

When this gets fixed, you won't have to recode your dial plan as nothing will change. The only downside to this workaround is an extra 20 milliseconds of wait time before a call goes out - for that extra digit ;)

 

Not quite...

 

Somehow, using the above method it creates another problem and the same number somehow stays in cache so no matter what number is dialed - from any extension - the gateway always sends the first phone number dialed using this method. What a mess.

 

This had probably never been caught because most people send all long distance calls over SIP trunks and not back over the PSTN. Unfortunately, we have to diall 11 digits for all calls.

 

Help? I have to put this thing in production in less than a week.

 

AK

Link to comment
Share on other sites

You should be able to enable the PSTN logging with log level 9 and see what is happening

 

 

Fair enough, but this is hanging off an AT&T 5ESS and dial tone is instant, but I did what you requested above and got the same result.

 

Again, my analysis points to your SIP gateway. Log files show that 11 digits are sent and it is stripping off the one when outputting DTMF on the line. I monitored what was sent using a decoder clipped onto the POTS (fx) line.

 

I bet there can be a setting in sipfxo.conf that will control this behavior, but the default is floating back and forth in your units because it is not being explcitly set. Can you please check this?

 

Tests

 

If I send twelve digits by adding an extra 1 at the beginning (112136181000@127.0.0.1) the gateway outputs ALL TWELVE DIGITS!

If I send 12 digits by adding an extra 0 at the end (121361810000@127.0.0.1), we also get all twelve digits, but the call goes through because the phone company ignores the last digit. This gives us a workaround:

 

WORKAROUND

 

I like to set up dial 9 for outgoing calls as it gives more control and most UScustomers are used to it.

 

IN DIAL PLANS

 

TRUNK: PSTN gateway

PATTERN: 9*

REPLACEMENT: *0

 

This adds an extra digit (0) at the end of the dial string which tricks the gateway into dialing the leading 1. The phone company will ignore the last digit.

 

When this gets fixed, you won't have to recode your dial plan as nothing will change. The only downside to this workaround is an extra 20 milliseconds of wait time before a call goes out - for that extra digit ;)

 

Not quite...

 

Somehow, using the above method it creates another problem and the same number somehow stays in cache so no matter what number is dialed - from any extension - the gateway always sends the first phone number dialed using this method. What a mess.

 

This had probably never been caught because most people send all long distance calls over SIP trunks and not back over the PSTN. Unfortunately, we have to diall 11 digits for all calls.

 

Help? I have to put this thing in production in less than a week.

 

AK

Link to comment
Share on other sites

First of all, did you set the country code in the domain to "1"? If the answer is yet, welcome to the NANPA numbering plan! The PBX assumes you stick to it, so there will be all kinds of problems when you try to send 12 digits.

 

In the gateway trunk, there is a setting on how you want the numbers to be displayed. Did you choose "11" digits?

 

Try turning the SIP logging on on the 127.0.0.1 IP address. Then we can see what the PBX sends to the gateway.

 

BTW what SW version were you using? 3.4.0.3201???

Link to comment
Share on other sites

First of all, let me explain that this is a brand new cs410 It is vanilla, out-of-the box. The only thing I did was update it to the latest firmware 3.4.0.3201 (Linux) and register a phone.

 

I set up the outdialing rules exactly as specified in your pages, hooked up a standard 1MB POTS line from AT&T to the fx0 port and tried to dial a call - and am getting these errors.

 

I thought either I'm blind or something's wrong, but I could find no mention of any 11 digit feature on any page. I looked at every setting on the PSTN gateway page (reg_ip.htm) Domain Setup (dom_settings.htm) and the trunks page (dom_trunk_edit.htm?trunk=1) nothing says 11 digits.

 

Finally, I looked through all the drop downs and discovered an option under 'Rewrite Global Numbers' within an individual trunk page, called For NANPA (11 digits).

 

Rewrite Global Numbers - huh?

 

Now it works, but I also discovered that now, if I try to put in 9[411|911] in the dialing rules, it causes the cache dialing problem I mentioned in a previous post and keeps dialing the same phone number. But that's for when I have time to deal with it. I'll just make two rules for now.

 

Can I make a suggestion? Can you hyperlink every setting name within the admin pages to the support page describing what it does? It would really help tremendously, be easy to do and would probably really cut down on your support calls.

 

Thanks for your help,

 

AK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...