Jump to content

Probleme lost line


Kenhamel
 Share

Recommended Posts

Hi since couple days i have a probleme...I lost communication when i'm talking to someone, i think my probleme is this message

 

PSTN: Number Unobtainable Tone detected on 2 (version: 2.4.2)

 

i'll past a part of the log... if somewone can help me... thanks

 

 

[3] 2009/02/17 16:22:12: PSTN: Channel 2 going to NO_RING

[3] 2009/02/17 16:22:13: PSTN: Channel 2 going to RING

[5] 2009/02/17 16:22:13: Identify trunk (IP address/port and domain match) 4

[5] 2009/02/17 16:22:13: PSTN: Response code: 100

[5] 2009/02/17 16:22:13: Trunk pstn sends call to 701 in domain localhost

[5] 2009/02/17 16:22:13: PSTN: Response code: 183

[5] 2009/02/17 16:22:14: Last message repeated 2 times

[5] 2009/02/17 16:22:14: PSTN: Tone 11 detected on 0

[5] 2009/02/17 16:22:14: PSTN: Tone 255 detected on 0

[5] 2009/02/17 16:22:15: PSTN: Response code: 183

[5] 2009/02/17 16:22:15: INVITE Response: Terminate cad58abf@pbx

[5] 2009/02/17 16:22:15: INVITE Response: Terminate 1104a396@pbx

[5] 2009/02/17 16:22:15: INVITE Response: Terminate 07583f58@pbx

[5] 2009/02/17 16:22:15: PSTN: Response code: 200

[5] 2009/02/17 16:22:15: PSTN: RTP destination=100007f

[5] 2009/02/17 16:22:15: PSTN: RTP destination=64496

[5] 2009/02/17 16:22:15: PSTN: RTP OOB codec=101

[6] 2009/02/17 16:22:15: PSTN: Start call on 2

[5] 2009/02/17 16:22:15: INVITE Response: Terminate 04bd0cab@pbx

[5] 2009/02/17 16:22:15: PSTN: Channel 2 goes offhook

[3] 2009/02/17 16:22:15: PSTN: Channel 2 going to TALKING

[5] 2009/02/17 16:22:15: PSTN: Country Code set to 66

[5] 2009/02/17 16:22:15: PSTN: Tone Detection set to 2

[5] 2009/02/17 16:22:41: PSTN: Number Unobtainable Tone detected on 2 (version: 2.4.2)

[5] 2009/02/17 16:22:49: PSTN: Received BYE message on channel 0

Link to comment
Share on other sites

Hi since couple days i have a probleme...I lost communication when i'm talking to someone, i think my probleme is this message

 

PSTN: Number Unobtainable Tone detected on 2 (version: 2.4.2)

 

i'll past a part of the log... if somewone can help me... thanks

 

Can you log into the box and check the /etc/init.d/pbxnsip file? is there a "--busy-det"? Take it out and reboot. Check if the problem is still there.

Link to comment
Share on other sites

I`ll check and i have no file with --busy-det....

do you have a other solution??

 

In analog PSTN lines, the other side play a tone to signal that the call has been disconnected and the subscriber should disconnect the call. More than hundred years ago people were happy when they could hear the other party.

 

Today, we have tones coming from such strange sources like cars (when you open the door). The PBX might believe that this is the disconnect signal! We also had cases where the carrier was playing such useful hints like "your call has been disconnected, please hang up". You need real intelligence in a PBX if you want to deal with that.

 

Proper hang-up detection is really difficult in the analog FXO world of Alexander Graham Bell. We tried to put some intelligence into the FXO trunk on the PBX side (check "trunk requires hangup detection"). If you feel it is too agressive, consider turning it off. However, then callers might hang in the auto attendant until the hangup-timeout kicks in.

 

I love SIP trunking. Reason #1 is a clear disconnect signal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...