Jump to content

Snom 320 - Outbound Calling/Registration Issue


vichy
 Share

Recommended Posts

I have a domain set up with several snom 320 phones registered.

 

I recently encountered an issue where two of the phones/extensions suddenly had no outbound calling...but everything else worked fine.

 

Basically, I still get dial tone ....dial out, and nothing happens. Eventually I recieve an email from the PBX regarding the unconnected call.

 

The call from sip:5194949545@sip01.envoicanada.com;user=phone to

sip:5199371702@sip01.envoicanada.com has been disconnected because no

media session was establised (source=67.71.140.243:60256)

 

If I look at the log, I see an INVITE, 100...then 401, ACK...then nothing.

 

Whats interesting is that I can fix this issue by either removing the SIP password from this extension, or by using the extension alias as the "Account" that my phone registers with (i.e. instead of using 5199371707/sip password, I use the alias 555/sip password).

 

My question is, shouldnt my phone be able to register with the pbx using either of the numbers in the "Account number(s)" field? (in my case 5199371707 555)

And if not, why does this work for some of the snom 320's but not the others?

 

Thanks!

Link to comment
Share on other sites

I have a domain set up with several snom 320 phones registered.

 

I recently encountered an issue where two of the phones/extensions suddenly had no outbound calling...but everything else worked fine.

 

Basically, I still get dial tone ....dial out, and nothing happens. Eventually I recieve an email from the PBX regarding the unconnected call.

 

The call from sip:5194949545@sip01.envoicanada.com;user=phone to

sip:5199371702@sip01.envoicanada.com has been disconnected because no

media session was establised (source=67.71.140.243:60256)

 

If I look at the log, I see an INVITE, 100...then 401, ACK...then nothing.

 

Whats interesting is that I can fix this issue by either removing the SIP password from this extension, or by using the extension alias as the "Account" that my phone registers with (i.e. instead of using 5199371707/sip password, I use the alias 555/sip password).

 

My question is, shouldnt my phone be able to register with the pbx using either of the numbers in the "Account number(s)" field? (in my case 5199371707 555)

And if not, why does this work for some of the snom 320's but not the others?

 

Thanks!

 

Looks like the phone is not behaving right. What is the version running on the phone? BTW, before changing anything, please do a factory reset and see the problem goes away.

Link to comment
Share on other sites

Looks like the phone is not behaving right. What is the version running on the phone? BTW, before changing anything, please do a factory reset and see the problem goes away.

 

Tried a factory reset, and the problem still seems to exist.

 

I should add that all my buttons work, as far as dialing out to voicemail or other internal extensions.

 

If I try and dial 3 digit extensions...it works.

 

Any 10 Digit number, internal or external produces the same problem.

 

All the snom 320's are running 7.1.35 (the ones that work, as well as the ones that do not). I recently updated the pbx from 3.0 to 3.2.0.3144 (Win32) as well, which did not seem to solve the problem either.

 

I notice there are a few later versions available for the 320's. is 7.1.35 still the recommended version?

 

Any other suggestions?

Link to comment
Share on other sites

Tried a factory reset, and the problem still seems to exist.

 

I should add that all my buttons work, as far as dialing out to voicemail or other internal extensions.

 

If I try and dial 3 digit extensions...it works.

 

Any 10 Digit number, internal or external produces the same problem.

 

All the snom 320's are running 7.1.35 (the ones that work, as well as the ones that do not). I recently updated the pbx from 3.0 to 3.2.0.3144 (Win32) as well, which did not seem to solve the problem either.

 

I notice there are a few later versions available for the 320's. is 7.1.35 still the recommended version?

 

Any other suggestions?

 

Snom 7.1.35 is ok. No issue there.

 

Check the trunk settings and dial plan if you are having issues calling external numbers. Also, enable SIP logging and post the call trace. That would definitely help.

BTW, can you call the same numbers from other phones?

Link to comment
Share on other sites

Can you call the mailbox (*97)?

 

Yes, I am able to get my mailbox using *97.

 

I also just realized that I can complete a call to a 10 digit number if I first press one of the "Shared line" buttons I have set up. This gives me a dial tone, and I can call anywhere. I used to be able to dial direct from the keypad and it would pick a co line for me.

 

Here is the dial plan I am using btw:

 

|^(*[0-9]{2})$|sip:\1@\d|d |^(911)$|sip:\1@\d|d |^(611)$|sip:\1@\d|d |^([2-9]{1}[0-9]{9})$|sip:\1@\d|d |^(1[0-9]{10})$|sip:\1@\d|d

 

Attached is a trace of an unsucessful call

 

Thanks!

trap.txt

Link to comment
Share on other sites

Yes, I am able to get my mailbox using *97.

 

That usually means that the device is working and can make calls...

 

I also just realized that I can complete a call to a 10 digit number if I first press one of the "Shared line" buttons I have set up. This gives me a dial tone, and I can call anywhere. I used to be able to dial direct from the keypad and it would pick a co line for me.

 

Aha. Interesting. Try upgrading to 7.1.39, that contains additional fixes for the shared line.

 

Here is the dial plan I am using btw:

 

|^(*[0-9]{2})$|sip:\1@\d|d |^(911)$|sip:\1@\d|d |^(611)$|sip:\1@\d|d |^([2-9]{1}[0-9]{9})$|sip:\1@\d|d |^(1[0-9]{10})$|sip:\1@\d|d

 

Where do you set that up?! Usually the dial plan should be automatically provisioned!

Link to comment
Share on other sites

That usually means that the device is working and can make calls...

 

 

 

Aha. Interesting. Try upgrading to 7.1.39, that contains additional fixes for the shared line.

 

 

 

Where do you set that up?! Usually the dial plan should be automatically provisioned!

 

I updated the FW to 7.1.39, and so far everything is the same.

 

As I mentioned earlier..I just updated to pbx v 3.2 from 3.0 a few days back, so I was using this dial plan, as the auto provisioning wasnt a feature previously.

I still havent got the dial plan autoprovisioning working correctly yet. Do you see my dial plan as being a contributor to the problem I am experiencing?

Link to comment
Share on other sites

I updated the FW to 7.1.39, and so far everything is the same.

 

As I mentioned earlier..I just updated to pbx v 3.2 from 3.0 a few days back, so I was using this dial plan, as the auto provisioning wasnt a feature previously.

I still havent got the dial plan autoprovisioning working correctly yet. Do you see my dial plan as being a contributor to the problem I am experiencing?

 

If you set the country code to "1" then you must use 10-digit numbers in the dial plan now (not 11-digit). Then on the trunk you can decide on how you want to present the number to the carrier. You can choose 10-digit, 11-digit, global formats. This could be the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...