Jump to content

Sending Extension Number on Internal Trunk


Tim
 Share

Recommended Posts

We have a client that we are configuring PBX for with release 3.2.0.3143 for their road warriors. The client wants to keep their legacy PBX in the office, so we are providing a Mediant M1k to provide a PRI to their legacy PBX for extension to extension calling.

 

I have configured the Mediant and the trunk on pbxnsip, and calling works both directions. The problem I ran into is I can't figure out how to make the pbxnsip trunk send the Extension # as the Caller ID number instead of the ANI. Does anyone know if there is a setting to make the extension be sent in place of the ANI?

 

Thanks,

 

Tim

Link to comment
Share on other sites

We have a client that we are configuring PBX for with release 3.2.0.3143 for their road warriors. The client wants to keep their legacy PBX in the office, so we are providing a Mediant M1k to provide a PRI to their legacy PBX for extension to extension calling.

 

I have configured the Mediant and the trunk on pbxnsip, and calling works both directions. The problem I ran into is I can't figure out how to make the pbxnsip trunk send the Extension # as the Caller ID number instead of the ANI. Does anyone know if there is a setting to make the extension be sent in place of the ANI?

 

Maybe that trick can help: In the ANI field, you can tell the PBX to use a different ANI when using a specific trunk.

 

For example, "9787462777 Trunk1:123" would mean: On trunk "Trunk1" use "123", otherwise use "9787462777" as ANI.

Link to comment
Share on other sites

  • 1 month later...
Maybe that trick can help: In the ANI field, you can tell the PBX to use a different ANI when using a specific trunk.

 

For example, "9787462777 Trunk1:123" would mean: On trunk "Trunk1" use "123", otherwise use "9787462777" as ANI.

 

Is it possible that in the future an option in either the 'Remote Party/Privacy Indication' or the 'Rewrite global numbers' field, I am not sure which this would be applicable to, that sets the trunk to 'Send extension', instead of sending the ANI?

 

Tim

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...