Jump to content
Vodia PBX forum
devakt

Exchange IVR to callers ID

Recommended Posts

hi

 

We have a problem on getting the correct IVR

 

When a caller A make a call to caller B and caller B is engaged or no answer the call goes to Exchange IVR but ask for the A's pin number for the mailbox and not the message to leave a message for B.

 

Is there any setting on the pbxnsip or Exchange to be done. So that the prompt would be to leave a message for B

 

regards

 

deva

Share this post


Link to post
Share on other sites
We have a problem on getting the correct IVR

 

When a caller A make a call to caller B and caller B is engaged or no answer the call goes to Exchange IVR but ask for the A's pin number for the mailbox and not the message to leave a message for B.

 

Is there any setting on the pbxnsip or Exchange to be done. So that the prompt would be to leave a message for B

 

Very strange. Does it work properly if someone from outside (PSTN) calls and gets into the mailbox?

Share this post


Link to post
Share on other sites
Very strange. Does it work properly if someone from outside (PSTN) calls and gets into the mailbox?

 

 

The exchange server is running of sp1 ..

 

does this effect the ivr

 

 

rgd

 

deva

Share this post


Link to post
Share on other sites
The exchange server is running of sp1 ..

 

does this effect the ivr

 

I have no idea. But usually it is a good idea to use the latest service pack.

Share this post


Link to post
Share on other sites

Hi deva,

 

from what you described, my first impression is:

 

1. maybe a little misconfiguration in your setup. Did it ever worked the way you expect it?

 

2. sounds like a wrong or no diversion header info, so Exchange would not be able to recognise this is a redirected call and simply receives a call. Thats why it ask's for the PIN. Did it also ask for A's extension ???

 

Please describe your configuration more detailed! Maybe compare it carefully with the wiki page: http://wiki.pbxnsip.com/index.php/Microsoft_Exchange

 

Additionally: enable Unified Messaging Diagnostic Logging at Exchange UM via Powershell: http://technet.microsoft.com/en-us/library/bb430783.aspx

 

If I remember correctly you can do e.g. a one-liner like this:

 

get-eventloglevel *UM* | set-eventloglevel -level Expert

 

To change all UM related loggings. Please give it a try :) It's like voodoo :)

 

Or try this one :)

 

get-service | restart-service -force

 

Best regards,

Jan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...