Jump to content

date


hosted
 Share

Recommended Posts

No battery included. Because it is a network device, IMHO it is okay to use NTP to fetch the latest time.

 

 

 

ntpdate is not installed in the image. because of this the system starts at 1970 Jan1 00:00

which means you MUST ssh into the box to set the date or your day/night tables will never work properly!

 

you should have a set time on the IP page or something.. and have ntpdate run upon boot.

Link to comment
Share on other sites

The PBX has a built-in NTP client that calculates the current time. Running NTP while the PBX is running screws up all internal callbacks, so if you must run ntpdate do it on startup, but then not again. Complain to the authors of the pthread library, they don't wait for the CPU time, they wait for the "real" time.

Link to comment
Share on other sites

The PBX has a built-in NTP client that calculates the current time. Running NTP while the PBX is running screws up all internal callbacks, so if you must run ntpdate do it on startup, but then not again. Complain to the authors of the pthread library, they don't wait for the CPU time, they wait for the "real" time.

 

so your saying that sense it says 1970 pbxnsip has its own ntp time and it doesnt matter?

Link to comment
Share on other sites

im dying here. hate pissy customers!

 

how can i fix this?

 

PC date is: 04:19 UTC

pbxnsip date: 19:05

REAL date: 18:05

 

however the Service Flag clear time = 05:05

I narrowed down the service flag time but elimination.

 

now check this out. I update the time zone and the log time dates... BUT the service flag is still 5:05.

 

now i updated the time in linux.. and the service zone says its now saturday sometime between 00:00 and 01:00

 

restart pbxnsip.. service flag is now on the right day between 5-6AM

 

But hey this works:

 

00:00-5:00 16:00-23:59 :)

Link to comment
Share on other sites

wow that actually did something cool.

 

ok so i installed ntpdate, shutdown pbxnsip, ran ntpdate which updated correctly, then started pbxnsip.

 

and the service flag and the log time is in sync!

 

BUT my software is still set to China/Taiwan which makes the service flag/log time only 1 hour off.

 

If I set it to MST then its waaaaaaaaaa off.

 

am i really the only person having this problem with the CS410? I would think most companies used day/night mode.

Link to comment
Share on other sites

The way to go is:


    When the PBX starts up, call ntpdate to get the PBX into a reasonable time zone. For this step, ntpdate must be on the box and the startup script must be adjusted.
    Then the PBX will perform a internal NTP date lookup every hour to adjust the differences to the hardware clock in the PBX. For this step we must make sure that the setting ntp_server in the PBX is set properly.

We will include that in the next software patch for the appliance.

Link to comment
Share on other sites

If you like, please try http://www.pbxnsip.com/cs410/update-2084.tgz. This tarball includes the ntpclient and also makes sure that it is called after startup. Other things it does is AGC on the FXO side, which should improve the audio quality and reduce problems with echo.

 

To load that image, just follow the steps in http://wiki.pbxnsip.com/index.php/Applianc...the_PBX_version.

Link to comment
Share on other sites

Ping tells you that the OS is still alive. SNMP tells you that the application is still alive.

 

Rebooting is not an attractive option. Maybe you are suffering from the memory leak in the head branch (2.1 beta), we are trying to isolate it. Check from time to time how much memory it allocated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...