Jump to content

Auto Provisioning Snom 360


Tom Waterman
 Share

Recommended Posts

I am trying to auto provision a snom 360 with firmware 7.3.14. My phone has a DHCP address of 172.16.x.x my server has na ip address of 172.31.x.x The server sits in the DMZ. I can see the phone requesting the file snom360.htm. I have the file below named as such and it is in the tftp and html directories. How ever each time the phone requests the file I see an authentication error. In the PBX under settings-->PNP I have the snom admin password set to 1234. Then under the domain settings--->provisioning parameters I have the password set to 1234. In the phone under security I have the password set to 1234 with a blank username, I have also tried using my account username and password here as well, no dice. Under the update section on the snom I have it seto to update automatically. The setting URL is http://172.31.x.x/provisioning/snom360.htm Subscribe and PnP config are both off. And I get an authorization error in Wireshark everytime. Any help would be great.

here is my snom360 config

<?xml version="1.0" encoding="utf-8" ?>

- <settings>

- <phone-settings e="2">

<redirect_event perm="">none</redirect_event>

<setting_server perm="">172.31.3.10</setting_server>

<subscribe_config perm="">off</subscribe_config>

<ip_adr perm="RW">172.16.2.30</ip_adr>

<netmask perm="RW">255.255.255.0</netmask>

<update_server perm="RW">172.31.3.10</update_server>

<dns_domain perm="RW">mdgn.microdatagis.com</dns_domain>

<dns_server1 perm="RW">172.16.3.1</dns_server1>

<dns_server2 perm="RW">172.16.3.3</dns_server2>

<gateway perm="RW">172.16.2.254</gateway>

<utc_offset perm="">-18000</utc_offset>

<ntp_server perm="RW">172.16.1.1</ntp_server>

<http_pass perm="">*****</http_pass>

<dst perm="">3600 03.02.07 02:00:00 11.01.07 02:00:00</dst>

<timezone perm="">USA-5</timezone>

<admin_mode perm="">on</admin_mode>

<tone_scheme perm="">USA</tone_scheme>

<logon_wizard perm="">on</logon_wizard>

<update_policy perm="">auto_update</update_policy>

<firmware_version perm="">snom360-SIP 7.3.14</firmware_version>

<http_client_pass perm="">*****</http_client_pass>

<use_hidden_tags perm="">on</use_hidden_tags>

<uboot_version perm="">1.1.3-m</uboot_version>

<user_name idx="1" perm="">858</user_name>

<user_host idx="1" perm="">srpbx01.mdgn.microdatagis.com</user_host>

<user_pass idx="1" perm="">858</user_pass>

<user_uid idx="1" perm=""><urn:uuid:0b2f8928-4af7-4214-a4a5-b20f12d91c65></user_uid>

</phone-settings>

<functionKeys e="2" />

<tbook e="2" />

</settings>

 

Also where is the proper placement of this file! Thank you all and by the way we are running pbxnsip version 3.3.1.3177 (Win32)

Link to comment
Share on other sites

I am trying to auto provision a snom 360 with firmware 7.3.14. My phone has a DHCP address of 172.16.x.x my server has na ip address of 172.31.x.x The server sits in the DMZ.

 

DMZ - are you trying to provision the phone from the "outside world" or from the LAN? The PBX has to generate a lot of links for the various files that have to be downloaded during the provisioning process. If it just puts 172.16.x.x there and the phone is somewhere at home behind a router that address cannot be resolved and we are talking about a tricky routing setup here.

 

I can see the phone requesting the file snom360.htm. I have the file below named as such and it is in the tftp and html directories. How ever each time the phone requests the file I see an authentication error. In the PBX under settings-->PNP I have the snom admin password set to 1234.

 

That is just the PIN code if you want to switch from user mode to admin mode on the phone. Has nothing to do with the provisioning itself.

 

Then under the domain settings--->provisioning parameters I have the password set to 1234. In the phone under security I have the password set to 1234 with a blank username, I have also tried using my account username and password here as well, no dice.

 

The username must identify your account. if you have multiple domains, you must use the form user@domain; if you have just one domain then just user may also work (play safe and use the user@domain form). The password is the web password of the account; or you can put the domain provisioning password there. Play safe and use the user web password here...

 

Under the update section on the snom I have it seto to update automatically. The setting URL is http://172.31.x.x/provisioning/snom360.htm Subscribe and PnP config are both off. And I get an authorization error in Wireshark everytime. Any help would be great.

 

If you have an authorization problem, then you should focus on the right username and password. Also if you plan to use DMZ, then try it out first without DMZ in the LAN.

 

Also where is the proper placement of this file! Thank you all and by the way we are running pbxnsip version 3.3.1.3177 (Win32)

 

Don't place this file anywhere. Also if you have a pnp.xml file, move it away. Also for the sake of getting it working, move PnP files away that you might have in the html directory. After you get it working, you can move them back one by one; then you might see which one causes the grief.

 

Sorry for all this trouble; but the 7.3.14 firmware is a little bit "bitchy" if you want to provision a phone without major security holes.

Link to comment
Share on other sites

DMZ - are you trying to provision the phone from the "outside world" or from the LAN? The PBX has to generate a lot of links for the various files that have to be downloaded during the provisioning process. If it just puts 172.16.x.x there and the phone is somewhere at home behind a router that address cannot be resolved and we are talking about a tricky routing setup here.

 

 

 

That is just the PIN code if you want to switch from user mode to admin mode on the phone. Has nothing to do with the provisioning itself.

 

 

 

The username must identify your account. if you have multiple domains, you must use the form user@domain; if you have just one domain then just user may also work (play safe and use the user@domain form). The password is the web password of the account; or you can put the domain provisioning password there. Play safe and use the user web password here...

 

 

 

If you have an authorization problem, then you should focus on the right username and password. Also if you plan to use DMZ, then try it out first without DMZ in the LAN.

 

 

 

Don't place this file anywhere. Also if you have a pnp.xml file, move it away. Also for the sake of getting it working, move PnP files away that you might have in the html directory. After you get it working, you can move them back one by one; then you might see which one causes the grief.

 

Sorry for all this trouble; but the 7.3.14 firmware is a little bit "bitchy" if you want to provision a phone without major security holes.

OK I got this to work. I just have one more question about the address book. When I press the directory button it gives me the first 32 numbers but that is it. Is there a way to make it fetch more of the list from the server? Thank you!

 

Tom

Link to comment
Share on other sites

OK I got this to work.

 

What was the trick? Something that others also might stumble into?

 

I just have one more question about the address book. When I press the directory button it gives me the first 32 numbers but that is it. Is there a way to make it fetch more of the list from the server? Thank you!

 

You can "drill deeper" by entering the next search digit. Then the PBX will refine the search. Don't push the digits too fast, you always have first to wait for the next XML page to show up before your can request the next one.

Link to comment
Share on other sites

What was the trick? Something that others also might stumble into?

 

 

 

You can "drill deeper" by entering the next search digit. Then the PBX will refine the search. Don't push the digits too fast, you always have first to wait for the next XML page to show up before your can request the next one.

 

In the 360 to get it to provision I did the following:

On the Security Tab I have the usernameof:

twaterman@md-911

and my account passowrd

Next on the update tab I have:

update automatically

the settings url of thge server is: http://ip address/provisioning/snom360.htm

refresh timer = 0

subscribe conf = off

PnP config = off

 

reboot and the magic happened.

 

Now as far as drilling down down through the directory. Can you explain how this is done? I get the first 32 number no problem. If I push 8 I get some different number but all of our company extension begin with 8. Thanks for the help.

 

Tom

Link to comment
Share on other sites

In the 360 to get it to provision I did the following:

On the Security Tab I have the usernameof:

twaterman@md-911

and my account passowrd

Next on the update tab I have:

update automatically

the settings url of thge server is: http://ip address/provisioning/snom360.htm

refresh timer = 0

subscribe conf = off

PnP config = off

 

reboot and the magic happened.

 

Now as far as drilling down down through the directory. Can you explain how this is done? I get the first 32 number no problem. If I push 8 I get some different number but all of our company extension begin with 8. Thanks for the help.

 

Tom

 

By pressing the digit 8, you should be seeing the names staring from 'T/U/V' (name search - matches both first name and last name)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...