Jump to content
Vodia PBX forum
djanjic

Returning call based on caller ID

Recommended Posts

I am having a trouble setting up a return caller ID call. Currently when an incoming call come in on SIP gateway the incoming caller ID is presented to the PBX as an area code plus seven digit number, for example 540XXX-XXXX. That is how the Snom phones receives it as well. If the user wants to return the call based on the caller ID the PBX doesn?t know how to send the call out. I will either need to add a 1 in front the whole number or strip area code from the number. The first option is more desirable. Can someone help me with this?

Share this post


Link to post
Share on other sites

It is a good idea to keep numbers in a normalized form. If you are in the USA reagion (10 digits fixed length), you should tell the PBX so and select the dial plan in the domain accordingly. Outside of USA people start to believe that the number +xxxxx (+ sign indicating that it is a globally routable number), I am amongst them.

 

Also that means that you should program the PSTN gateway so that it sends diallable numbers. Same in address book.

 

BTW because of this it is a bad idea to put prefix into the dial plan. At least for "normal" calls they should be diallable without a prefix.

Share this post


Link to post
Share on other sites

I solved this problem by putting a dial plan in the phone that would accept any number an normalize it to 1<area code><number>. For Linksys phones this is the dial plan for area code 801.

 

Use this dialing plan for a direct dial line. Intercom calls can be placed by dialing a three digit number. This will accomedate 2 digit * codes or 2 digit * codes followed by a 3 digit extension (intercom calls)

(*xx|*xxxxx|,[3469]11S0|<:1801>[2-9]xxxxxx|<:1>[2-9]xxxxxxxxxS0|1[2-9]xxxxxxxxxS0|011xx.|xx.|[1-8]xx)

Share this post


Link to post
Share on other sites

is there anyway to set it up in the dialplan that when you dial a 10 digit number it should add the number 1 in front of it?

im also havignt he same problem that when i dial from the missed call log, it doesnt have the 1 in front of it

 

or maybe can we have PBXnSIP add a number 1 in front of the number when display the caller ID? it should only add it on USA 10 digit numbers (so it wont add it on international calls)

Share this post


Link to post
Share on other sites
is there anyway to set it up in the dialplan that when you dial a 10 digit number it should add the number 1 in front of it?

im also havignt he same problem that when i dial from the missed call log, it doesnt have the 1 in front of it

 

or maybe can we have PBXnSIP add a number 1 in front of the number when display the caller ID? it should only add it on USA 10 digit numbers (so it wont add it on international calls)

 

Did you put the country code into the domain settings? That makes the PBX aware about the location and then it tries to be smart about the number representation.

Share this post


Link to post
Share on other sites
maybe someone tell me how to i set up that when i dial a 10 digit number it will automaticly add a 1 in frotn of the number?

 

The trunks also have a setting that tell the PBX how to present a number. Depending on the version, that even works for inbound calls. YOu might have to upgrade to version 3.2 to get that working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...