Jump to content

Snom 370 Auto Dials on 4 digit


Tom Waterman
 Share

Recommended Posts

I have a customer who has the snom 370 phones and they have a local exchange of 358. Until last week they could dial this local exchange no problem. I have made no changes to the PBX in a month at least and the snoms are running the newest firmware 7.3.14. Apparently last week some of the phones rebooted and auto provisioning actually kicked in. So now these phones when you dial 358 on the fourth digit it will auto dial. I can see this in the PBX wireshark which I have attached. This is a major issue as it is a PD and need immediate help.

Link to comment
Share on other sites

I have a customer who has the snom 370 phones and they have a local exchange of 358. Until last week they could dial this local exchange no problem. I have made no changes to the PBX in a month at least and the snoms are running the newest firmware 7.3.14. Apparently last week some of the phones rebooted and auto provisioning actually kicked in. So now these phones when you dial 358 on the fourth digit it will auto dial. I can see this in the PBX wireshark which I have attached. This is a major issue as it is a PD and need immediate help.

 

Did you previously provision a dialplan through PnP? If you turn that off later, then the phone will "stick" to the old plan. The only way to get it out of the phone is to either provision another plan or to factory-reset the phone.

Link to comment
Share on other sites

Did you previously provision a dialplan through PnP? If you turn that off later, then the phone will "stick" to the old plan. The only way to get it out of the phone is to either provision another plan or to factory-reset the phone.

 

How do I provision another plan?

Link to comment
Share on other sites

Go to the domain settings, at the bottom you can select the dial plan that should be provisioned (if available for the phone type).

 

So I was able to get this working but let me tell you what happened so others may know the issue. When we originally installed the system we could not get PnP to work properly. However, with the lat couple of upgrades pnp is now functional, although I did not know this. So the customer had to reboot a couple of the phones and it pulled down the PnP dial plan which was set to 4 Digit North America. Because this client still has 7 digit dialing they would try to dial 358 and on the 4th digit it would dial. This would happen on any of thier local echanges. Ugg. So you would think the if you change the dial plan to "User Must Press Enter" and reboot the phone that this would fix the issue however it does not because onthis setting a dial plan xml file is not generated. Sooo, on the snom 370 I saved the settings and edited the current xml and reloaded it. This fixed the issue! Thanks to, Kevin, Kevin, and Pradeep for the help.

 

Tom

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...