Jump to content

Feature Req - Night mode call forwarding by hunt group


kellenw
 Share

Recommended Posts

I would like the ability for users to assign a call forward number (from the phone) for an entire hunt group and activate it using a star code or button (again, from the phone).

 

We have a person on-call during non-office hours. This is a different person day to day, and sometimes even hour to hour. A simple way for the users to set this up (without going into the user webpage of pbxnsip, where they can simply mess too much stuff up) would be a major time saver.

Link to comment
Share on other sites

I would like the ability for users to assign a call forward number (from the phone) for an entire hunt group and activate it using a star code or button (again, from the phone).

 

We have a person on-call during non-office hours. This is a different person day to day, and sometimes even hour to hour. A simple way for the users to set this up (without going into the user webpage of pbxnsip, where they can simply mess too much stuff up) would be a major time saver.

 

We have added that code to version 3.4. You can just dial a new star code and then enter the destination number. You can do that (as with all star codes) also from your mailbox, so that you can use this feature also from the outside world. A release should be available soon. If you want to try it out, send an email to support@pbxnsip.com and tell us what operating system you need.

Link to comment
Share on other sites

PBXNSIP - I'm using the 4.0.0.3204 (beta) version on a CS410. I'm assuming this version also has that function. Correct?

 

Are we talking about *71 (Call Forward All)? I tried using that, but it appears it won't forward calls coming in through a hunt group. I can, however, use the web gui for an extension (ext 40 in my case) and go to the redirection tab and change the option "When calling the extension in a hunt group" to "Include cell phone in the group", and that calls my cell, but when I answer it's dead air and the caller continues to get ring tone and the other extensions in the hunt group continue to ring.

 

Ideally, I would like a user to be able to simply type in a star code, enter the hunt group number they want to forward, enter the destination number to forward to, and then have all calls to that SPECIFIC hunt group forward to the new destination number. When they are ready to quit their on-call time they enter a star code to disable the forwarding and the hunt group behavior is restored to normal.

 

EXAMPLE:

Ext. 40: dials *71

PBX: Please enter the hunt group number to forward

Ext. 40: dials 72 (which is my main hunt group)

PBX: Please enter destination number

Ext. 40: dials 555-5555 (or whatever)

PBX: All calls to hunt group 72 will be forwarded to 555-5555.

 

Now, when the user is done with on-call...

Ext. 40: dials *72

PBX: Please enter the hunt group number for which you wish to deactivate forwarding

Ext. 40: dials 72 (my main hunt group)

PBX: Forwarding disabled for hunt group 72.

 

Make sense? Possible? Thoughts? I just think this sounds like a great feature and definitely one that would greatly benefit me.

Link to comment
Share on other sites

PBXNSIP - I'm using the 4.0.0.3204 (beta) version on a CS410. I'm assuming this version also has that function. Correct?

 

Are we talking about *71 (Call Forward All)? I tried using that, but it appears it won't forward calls coming in through a hunt group. I can, however, use the web gui for an extension (ext 40 in my case) and go to the redirection tab and change the option "When calling the extension in a hunt group" to "Include cell phone in the group", and that calls my cell, but when I answer it's dead air and the caller continues to get ring tone and the other extensions in the hunt group continue to ring.

 

Ideally, I would like a user to be able to simply type in a star code, enter the hunt group number they want to forward, enter the destination number to forward to, and then have all calls to that SPECIFIC hunt group forward to the new destination number. When they are ready to quit their on-call time they enter a star code to disable the forwarding and the hunt group behavior is restored to normal.

 

No, there is a new code for that. The PBX does not automatically assign a code if you just upgrade the system. Check the feature codes of your domain, there is something new called "Forward calls to domain accounts". Pick something that is not assigned yet (e.g. *51).

 

Then you can either just call *51 and the PBX will change all auto attendants, hunt groups and agent groups of the domain. Or use *51xxx is you want to change just a specific attendants, hunt groups or agent groups. Listen to the annoucements. You can either set the redirection or clear it.

Link to comment
Share on other sites

No, there is a new code for that. The PBX does not automatically assign a code if you just upgrade the system. Check the feature codes of your domain, there is something new called "Forward calls to domain accounts". Pick something that is not assigned yet (e.g. *51).

 

Then you can either just call *51 and the PBX will change all auto attendants, hunt groups and agent groups of the domain. Or use *51xxx is you want to change just a specific attendants, hunt groups or agent groups. Listen to the annoucements. You can either set the redirection or clear it.

 

Also, make sure that "May change the destination for the night mode for the following accounts" under Extension->Permissions tab is not empty.

Link to comment
Share on other sites

Thanks for the reply pbxnsip. I assigned *51 to the "Forward calls to domain accounts" field, and saved and rebooted the pbx as well as the phone just for good measure. Checked the setting in the web gui and it's there, and nothing else is assigned the *51 command. However, when dialing *51 from the phone it states "this feature is not available at this time".

Link to comment
Share on other sites

Thanks for the reply pbxnsip. I assigned *51 to the "Forward calls to domain accounts" field, and saved and rebooted the pbx as well as the phone just for good measure. Checked the setting in the web gui and it's there, and nothing else is assigned the *51 command. However, when dialing *51 from the phone it states "this feature is not available at this time".

 

Did you set the extension->permission tab related setting that is in the previous post?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...