Jump to content
Vodia PBX forum
clarity

Hot Desking with agent groups not working as expected

Recommended Posts

I had shared this directly with pradeep earlier and he had suggested there may need to be a software update to fix this:

I am also cross posting this issue to the public forum per Pradeep's request.

3rdly I have opened a support case and copied this information there as well.

THANKS!

---

 

I’m not sure exactly how to go about trouble shooting this problem.

I imagine it’s simple.

 

We have a customer of whom I’ve set up hot desking where they log onto their extension number (601) Hot desk.

 

Then they log onto the agent queue by pressing *64 (agent login)

 

The person (601) is entered into a number of agent groups as defined in the agent groups themselves..

 

You’ll see “601” is part of maybe 5-10 agent groups.

 

The customer is complaining that they are still getting inbound calls to their phone (from other agent groups) of which they are part of when they are already on the phone..

And that the other agents who are logged in are not getting the calls sometimes…

In other words it does not always go to an available agent who is not on the phone but is ringing him (601) yet he’s already on the phone having answered a phone call earlier..

 

If you need to look on our server. The specific extension (hot desking acct) is 601, he’s logging onto phone (501) and then logging into the agent queue by pressing *64.

 

Server hostname: ******.***.***

Username: ****

Password: ****************

 

 

 

His expectation is that he should not receive any agent queue type calls when he’s already on the phone but someone else who is not on the phone but in the agent group should be getting the second inbound

call rather than him.

 

Here are the call details that he was able to get me on the last time it happened…

I’ve asked him to try and record the events when it happens and to see if it can be recreated.

 

Do you see anything obviously wrong or have any suggestions on where I can begin to test?

Thanks!

 

[Pradeep's response:]

 

 

 

Hi Steve,

 

Here is the response from Christian. Looks like we need to add some code to make the behavior that you are looking for.

 

Pradeep

 

Subject: Re: FW: Pbxnsip Hot Desking Ongoing complaint from customer.

 

Hmm. I believe it is a "feature". The agent is something "logical", while the phone is something physical. The PBX knows that the agent is busy talking, but is not sure about the specific device.

 

I believe the workaround must be that the phones that are used as hot desking devices should not be part of a ACD.

Share this post


Link to post
Share on other sites

Well, the point is that the PBX monitors the calls to an extension independently from the used IP address. For example, when using static registrations, the PBX also does not realize there may be another call going on to that IP address.

 

Same with hot desking. If you send the call to a hot desk phone, the PBX tags this call with the called extension. When you call the hot desk phone directly, it does not have a call active for the original extension number and the call gets put through.

 

If that behavior is a problem, then I would suggest using "agent" extensions and "phone" extensions. For example, you use extensions 4xx for agents, and 5xx for phones. Only 5xx extensions have phones registered, 4xx does not register a phone. Only 4xx extensions are in agent groups. Then when an agent logs in, he or she needs to perform the hot desking in order to log in. The good news is that there is no need to log in as agent any more; hot desking will be enough.

Share this post


Link to post
Share on other sites

What I think you are telling me is to simply have them do just the hot desking (4xx) extension numbers in your example.

Make sure the 4xx phones are in the right agent groups but do not log onto the quoe so skip that step.

 

They are already setup exactly like that.. just that they have been doing the log onto the que step as well as hot desking.

 

So I should simply have them *not log onto the queue* and the just use the hot desking at 4xx (6xx) in our case.

And this should clear up the problem. (make sure 4xx) (6xx) in our case extension numbers are in the right que(s)

hen simply logg off hot desking if not wanting to be in the queue so to speak.

I will have them try this.

 

Thanks..

 

Steve

 

 

 

 

 

 

 

 

 

Well, the point is that the PBX monitors the calls to an extension independently from the used IP address. For example, when using static registrations, the PBX also does not realize there may be another call going on to that IP address.

 

Same with hot desking. If you send the call to a hot desk phone, the PBX tags this call with the called extension. When you call the hot desk phone directly, it does not have a call active for the original extension number and the call gets put through.

 

If that behavior is a problem, then I would suggest using "agent" extensions and "phone" extensions. For example, you use extensions 4xx for agents, and 5xx for phones. Only 5xx extensions have phones registered, 4xx does not register a phone. Only 4xx extensions are in agent groups. Then when an agent logs in, he or she needs to perform the hot desking in order to log in. The good news is that there is no need to log in as agent any more; hot desking will be enough.

Share this post


Link to post
Share on other sites
What I think you are telling me is to simply have them do just the hot desking (4xx) extension numbers in your example.

Make sure the 4xx phones are in the right agent groups but do not log onto the quoe so skip that step.

 

They are already setup exactly like that.. just that they have been doing the log onto the que step as well as hot desking.

 

So I should simply have them *not log onto the queue* and the just use the hot desking at 4xx (6xx) in our case.

And this should clear up the problem. (make sure 4xx) (6xx) in our case extension numbers are in the right que(s)

hen simply logg off hot desking if not wanting to be in the queue so to speak.

 

Yes it is like having two layers. One layer for the phones, and another layer for the agents. If you don't mix them up, it should be clean. And it should also avoid the login.

Share this post


Link to post
Share on other sites

I use kind of the same set up :

 

- Contact center phones (snom) are registered on the extensions 2xx

- Agents login by hot desking with extensions 7xx

- The 7xx accounts are in the agentgroup.

 

This afternoon I had the problem that callers remain in the queue, altough the agents were free. I took a while and then with a few minutes between them calls were send to the agents. Waiting time was more than 10 minutes

 

Settings 'longest idle first' and 'furthermore no redirects. One agent was calling outbound at the moment, but was till hot desked.

 

Any idea what went wrong, do we stille need to use *64 ?

 

Thanks

 

3.3.1.3177

Share this post


Link to post
Share on other sites

Today I saw this problem again. It looks like the first person waiting blocks the queue, after he hangs up, calls were routated again.

I further have tested this, bij disconnecting a call, then the second one waiting was routed.

It looks likes this happens when all agents are in a call, and there is a waiting queue.

/ there a three accounts logged in via hot desking and about zes accounts mentioned in the agentgroup/

 

Any suggestions ?

 

 

I use kind of the same set up :

 

- Contact center phones (snom) are registered on the extensions 2xx

- Agents login by hot desking with extensions 7xx

- The 7xx accounts are in the agentgroup.

 

This afternoon I had the problem that callers remain in the queue, altough the agents were free. I took a while and then with a few minutes between them calls were send to the agents. Waiting time was more than 10 minutes

 

Settings 'longest idle first' and 'furthermore no redirects. One agent was calling outbound at the moment, but was till hot desked.

 

Any idea what went wrong, do we stille need to use *64 ?

 

Thanks

 

3.3.1.3177

Share this post


Link to post
Share on other sites
Today I saw this problem again. It looks like the first person waiting blocks the queue, after he hangs up, calls were routated again.

I further have tested this, bij disconnecting a call, then the second one waiting was routed.

It looks likes this happens when all agents are in a call, and there is a waiting queue.

/ there a three accounts logged in via hot desking and about zes accounts mentioned in the agentgroup/

 

So you are using version 3.4? There was a bug with the setup of hot desking. Maybe you have to log out and log in again. Last resort is to delete the extensions and recreate them (in any case, make a backup of the file system).

Share this post


Link to post
Share on other sites

No we are using 3.3.1.3177. What do you mean bij log in and log out, do you mean *70 and login with the agent extension and than log in by *64 ?

 

Thanks

 

So you are using version 3.4? There was a bug with the setup of hot desking. Maybe you have to log out and log in again. Last resort is to delete the extensions and recreate them (in any case, make a backup of the file system).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...