Jump to content
Vodia PBX forum
Parks

Getting 404 even though I shouldn't

Recommended Posts

We are starting to test for residential service and setup some test accounts. I couldn't get any of the ATAs to register so I thought I'd try to register my x-lite to confirm and couldn't. Here is the log file and everything should be fine. We're using 10 digit btn as their account/extension under 1 domain called residential.vonvox.net. Current system running 3.1.2.3120

 

[7] 2009/06/24 19:33:02: SIP Rx udp:75.149.48.107:8800:

REGISTER sip:residential.vonvox.net SIP/2.0

Via: SIP/2.0/UDP 192.168.5.230:8800;branch=z9hG4bK-d8754z-4a3a8e79161c7f1e-1---d8754z-;rport

Max-Forwards: 70

Contact: <sip:9254185059@192.168.5.230:8800;rinstance=a2889ba708bc4675>

To: "Test User2"<sip:9254185059@residential.vonvox.net>

From: "Test User2"<sip:9254185059@residential.vonvox.net>;tag=2219607b

Call-ID: Yzk0YmFjZGJiOWQxODZhOWUxZDMyMmEwODdkMmZlMGE.

CSeq: 1 REGISTER

Expires: 300

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO

User-Agent: X-Lite release 1100l stamp 47546

Content-Length: 0

 

[7] 2009/06/24 19:33:02: SIP Tx udp:75.149.48.107:8800:

SIP/2.0 404 Not Found

Via: SIP/2.0/UDP 192.168.5.230:8800;branch=z9hG4bK-d8754z-4a3a8e79161c7f1e-1---d8754z-;rport=8800;received=75.149.48.107

From: "Test User2" <sip:9254185059@residential.vonvox.net>;tag=2219607b

To: "Test User2" <sip:9254185059@residential.vonvox.net>;tag=07d93e67c8

Call-ID: Yzk0YmFjZGJiOWQxODZhOWUxZDMyMmEwODdkMmZlMGE.

CSeq: 1 REGISTER

Content-Length: 0

 

Thanks for the help!

Share this post


Link to post
Share on other sites
We are starting to test for residential service and setup some test accounts. I couldn't get any of the ATAs to register so I thought I'd try to register my x-lite to confirm and couldn't. Here is the log file and everything should be fine. We're using 10 digit btn as their account/extension under 1 domain called residential.vonvox.net.

 

You are probably hitting the problem that the number that you register with is a telephone number. Then the PBX compares 9254185059 to +19254185059 and finds no match. Try registering +19254185059, that might solve the problem.

 

This is a kind of a bug; we probably have to change this behavior. Workaround is to use the + format for right now.

Share this post


Link to post
Share on other sites
You are probably hitting the problem that the number that you register with is a telephone number. Then the PBX compares 9254185059 to +19254185059 and finds no match. Try registering +19254185059, that might solve the problem.

 

This is a kind of a bug; we probably have to change this behavior. Workaround is to use the + format for right now.

Yes adding +1 worked and will be fine for using but would they still 11 digits and be able to get their voicemails sense we registered with the +?

Share this post


Link to post
Share on other sites
Yes adding +1 worked and will be fine for using but would they still 11 digits and be able to get their voicemails sense we registered with the +?

 

I think so. Should be easy to find out!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...